Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Not able to access device location through the app centre

Created: 21 Mar 2013 • Updated: 10 Apr 2013 | 5 comments
This issue has been solved. See solution.

I have few devices attached to the app centre and am the administrator running the app cantre. The device inventory and other this all works fine. But not able to access device location through the app centre.

Operating Systems:

Comments 5 CommentsJump to latest comment

mclemson's picture

Have you enabled collection of location-based data in App Center?  Does your device allow it?  During enrollment did you allow it?  Has the device sent other inventory?  What browser are you using?  What happens when you access the Location tab?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

anoop.paul@nine23@co.uk's picture

Hello mclemson,

I have enabled the location- based data in the App center. I am not sure does the device allow it, i am using Ipad 4 th gen. During the enrollment i did allow it and able to access the location on the icloud accout through my system. But not able to access the same through the app center. yeah the device has sent other inventories like the apps downloaded, ip, and update device info, fetch policy etc. it says device location has not yet been reprted.

Your suggestions would of great help.

Regards,

Anoop Paul

Andrew_C's picture

Hello Anoop,

The App Center App will subscribe to Location services. When the device's location has changed greater than ~20 meters (since the previous update), Location services will provide the updated location information to the App Center App. The App Center App will then hold this information until the device polling interval occurs (Settings > Device Management > Check policy every x hours), when it will send the information to the App Center server. The default frequency for this setting is 72 hours / 3 days.

Also, please be advised that it has been brought to my attention there may be a defect where the location is not updated at the device polling interval unless a login has occurred with the App Center App first. In other words, if you wait for the device poll to occur without ever logging into the App Center App, the new location will not be reported to the server. A defect regarding this behavior has been filed with development.

Let me know if this assists in identifying the issue

Thanks,

Andrew

 

anoop.paul@nine23@co.uk's picture

Hello Andrew,

Thanks for your view regarding the same. Yeah the issue was solved, i had to just upgrade the agent version and update the xcode.

regards,

Anoop

SOLUTION
Andrew_C's picture

Thank you for the update, Anoop. This is good to keep in mind for future issues.

If you wouldn't mind, please mark this thread as resolved (you can select your own post as the resolution).

Thanks!

Andrew