Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Not able to backup NAS box

Created: 04 Jun 2012 • Updated: 15 Jun 2012 | 9 comments
This issue has been solved. See solution.

Hi 

Current setup is BE2010R3 sp2 with latest patches. Trying to backup a EMC NX4 NAS box shares. But When try to expand the IP or the Netbois name of the nas box  it gives an access denied popup and gives the logon accounts page to select an other account. I have tried root and nasadmin user of nas box but that also didnt worked. I am able to create B2D folder on to the same NAS box but cannot expand it for backup selection.

On the other hand I have a BE2010R2 machine where I am able to expand the same nas box in the same environment. The BE2010R2 is a production BE server and will be upgraded to BE2010R3  But before that wanted to make sure using a test BE2010R3 setup. Can anyone put some more light on this issue.

Comments 9 CommentsJump to latest comment

VJware's picture

Does the test 2010R3 setup have complete read/write access to the NAS box ? I mean, is the logon account part of the local admins on the NAS ?

Is the test 2010 R3 setup using default ndmp 10000 port ?

Lastly, was the NAS added via IP or name under user-defined selections ?

WikiDonor's picture

Hi

both backup exec servers are in same domain and both can ping nas box. I have tried both IP and Name of the nas box but same result. I will update you again once I confirm if BE2010R3 is on port 10000....

If you find my comment informative and helpful please mark the post as resolved.

WikiDonor's picture

Hi 

I have upgraded the BE2010R2 to BE2010R3 on the production setup and I am still able to select the NAS shares. 

If you find my comment informative and helpful please mark the post as resolved.

CraigV's picture

Hi,

Do you have access to the NX4 through Windows? Meaning can you browse it there and create files/folders on it?

Check to see if your firewall is running, and if it is, drop it and see if this helps. Check your AV...they can do some strange things with BE. If it is blocking BE services, put in exclusions and try again.

The other option is this: if that server is a test box, uninstall BE 2010 R3, and install BE 2010 R2 with the same updates as your production server. Try creating the B2D and browsing the server again.

If this doesn't work, then you need to check the setup on your production server to see what's different there. Maybe you've added the NAS account in to that server, and not on your test server for instance. Something else to consider is whether or not that storage can integrate into AD. If so, consider doing this, as this will get around a lot of permissions issues you'd experience with BE.

The NX4 is capable iSCSI...so the last thing to consider is enabling iSCSI. Create a B2D on that, and then present the LUNs to your backup server. This is a sure-fire way to get around authentication issues (I've used this very successfully with various models of Iomega NAS's during the past year!). Read my article below on this:

https://www-secure.symantec.com/connect/articles/using-iscsi-backup-your-environment-nas-backup-exec

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUTION
Colin Weaver's picture

As the EMC device might support NDMP, make sure you have turned off the NDMP Protocol on the device itself in order to do share level backups. Otherwise BE will think a remote agent is installed and the backup jobs will fail.

OR look at the capabilities of our NDMP Option and consider using that instead.

WikiDonor's picture

As I started the discussion mentioning that our client has 2 BE servers.

1. BE2010R2 in production 

2. BE2010R3 in testing 

The BE2010-R2 is able to browse the shares so I guess the NDMP service is already disabled 

The BE2010-R3 is not able to browse the shares but able to create the B2D on it.

Finally we had to upgrade the BE2010R2 as per the schedule and it is not updated to BE2010R3.

Now I am still able to expand the shares on the production box.

I will try to check if we still facing problem with the test box which my client had reported earlier.

If you find my comment informative and helpful please mark the post as resolved.

CraigV's picture

...upgrade BE 2010 R2 to what though? Are you still ABLE, or UNABLE to browse shares?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

WikiDonor's picture

Yes the original Be2010R2 to Be2010R3 is done now. I am able to expand the shares for backup using the old server which is now BE2010R3 server. 

If you find my comment informative and helpful please mark the post as resolved.

CraigV's picture

...OK, so if you can browse the shares, can you cretae a B2D and then run a small backup of that data to the B2D?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...