Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Not able to import Partner Public key on PGP Command Line 9.0.2 build 560

Created: 15 Feb 2013 | 1 comment

Hi All,

I am trying to import one of the partner public key but it is not getting imported. I am not getting any error just import command runs and nothing happens. I tried to import other partner key and it was working fine. The one which was having issue has below format:

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.4.10 (MingW32)
 
<Acutal Key>
 
-----END PGP PUBLIC KEY BLOCK-----
 
I tried to ran in debug and verbose mode but not much information:
 
bash-2.05$ pgp --debug --verbose --import adobeyckey.asc
pgp:import key (3157:current local time 2013-02-15T12:16:00-07:00)
/usr/home/b2bi/.pgp/pubring.pkr:open keyrings (1006:public keyring)
/usr/home/b2bi/.pgp/secring.skr:open keyrings (1007:private keyring)
 
I am suspecting some compatibility issue here between PGP Command Line 9.0.2 and GnuPG v1.4.10.
 
I am using PGP Command Line 9.0.2 build 560 on Solaris 9 version.

Thanks in advance.

Thanks

Hemendra

Comments 1 CommentJump to latest comment

dfinkelstein's picture

I'm sorry you're having this problem.

9.0.2 is very old.  My guess is that there is some bug in that version that doesn't like some aspect of key (as opposed to a specific compatability issues, say with the key size or algorithm).  The effect for you is the same, unfortunately.  I think your best option is to upgrade to a newer version.

Regards,

--------

David Finkelstein

Symantec R&D