Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Not able to install SEP 11.0.6 client on Wk8 server

Created: 18 Oct 2011 • Updated: 19 Oct 2011 | 10 comments
This issue has been solved. See solution.

 Hi,

I am trying to install symantec endpoint protection 11 client on windows 2008 server Enterprise edition server. But getting some registry permission error. Pleae find the screenshot of error.

Also have a llok on below points, may helpful to get some idea

* There is an entry of Symantec in registry, i am not sure how it came there. may be some one installed it before

* Symantec backup exec is installed in the machine, I just uninstalled it and tried but not worked.

* Tried to change permission of the entry but access denied error

* Then i used "psexec -s -i -d regedit.exe " neither worked.

* I am using Deafult Administrator user to install.

* I succussfully installed Symantec backup exec on the same machine.

* Server itself act as a  standalone domain controller, created for some perticular application and also holding oracle DB but not managing any other machines /users, isolated from network.

 

AtB

Comments 10 CommentsJump to latest comment

rush's picture

I am not able to change the permission of registry..... I have tried all the ways but no luk ..

and also remember it is wk8. The above links are not helped anyway thanks for the help..

Cameron_W's picture

What version of BE are you running? Have you tried uninstalling BE, install SEP, then reinstall BE?

You may have to launch the CMD prompt to 'Run as Administrator' or you may get 'Access Denied' launching PSExec.

If I was able to help resolve your issue please mark my post as solution.

rush's picture

Actually BE doessn't have any relation with this, today only i have installed BE but i have been trying the AV installation since last 1 week. But the existing reg entry is of SEP client, pleas hav a look on screenshot attached.

PSExec , i have tried everything i am not getting any error while using this tool but if i go to the reg entry after changing permission, i will get accesss denied message. means its not changing any permission.

Vikram Kumar-SAV to SEP's picture

Export a new Client install package and try using that.

Hope you are not using too old version of SEP.

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

rush's picture

No, you may wrong.  I just exported the package from my SEPM today :) I have more than 300 windows server edition clients managing by SEPM, The same client only i have installed in this machine, But its alll about the registry permission I think there is no logic in your doubt.

 

BTW thank you

AtB

Vikram Kumar-SAV to SEP's picture

Try using the batch file as mentioned in this doc

http://www.symantec.com/business/support/index?page=content&id=TECH135922

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

SOLUTION
rush's picture

Vimram,

 Thanks for the link, I hop that may work.. i don know, anyway i will give a try tomorrow and let you know the status. Meantime any other solutions are also welcome. i can try one by one tomorrow because i will get very less time to try these all solution :( server will not be available to do any R&D

 

 

 

 

Thank u

AtB

rush's picture

Thanks Vikram,

That worked .. what i did

1. Installed subinacl latest version

2. Opened cmd then change direcotry to Subinacl installed directory

3. Run below lines one by one manually

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

4. got some 25 error while running 4th line

5. Restarted server

6. Tried to install AV, but not worked. Then opened regedit and locate HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Endpoint Protection

7. Right click and permission added Administrator with full rights, then go to owner tab and changed to Administrators group --> Apply --> OK --> OK

8. regedit and locate HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Endpoint Protection\SMC, and repeated 7 th steps

 

:)

 

 

 

 

AtB

Chetan Savade's picture

Hi,

Take a backup of registry.

 

Please use regedit32 to delete HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Symantec Endpoint Protection key.

Try to install SEP.

Chetan Savade
Sr.Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<