Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Not getting full admin GUI with 7.5.0.4

Created: 07 Nov 2012 | 4 comments
js88699's picture

This is strange and I have not been able to figure out why it's happening.  This is a new install overall and very fluid right now.  When I first installed the Java console GUI on my laptop I had the master in a local hosts file.  For this discussion lets just call it Master1.  I connected to the master and everything looked great.  I was able to see everything, confirming my username in auth.conf is correct and working.  I got an email they finalized some network changes and now the IP I was connecting to before is known as Master1-mgmt.  I updated my local host file with that and the FQDN.  The IP did not change, just the names.

Now when I try and login to NBU, using the FQDN, I'm only getting the backup and restore portion of the GUI.  I changed it to the new short name, and got the same results.  I went back to the local host file and added on the SAME line the original name, and it worked just like before.  Connecting to the same IP on the master server, coming from the same laptop, using the same username/password.

I'm missing something somewhere but I can't see it.  Thanks in advance for the help.

Discussion Filed Under:

Comments 4 CommentsJump to latest comment

Marianne's picture

NetBackup master server hostname CANNOT change.

The hostname is deeply embedded into every fibre of NBU and can only be changed with the help of a Symantec Consulting Partner.

Master1 and Master1-mgmt are two completely different names.

What you can do in order to use Master1-mgmt name is to add an alias for master server hostname:

nbemmcmd -machinealias -addalias -alias Master1-mgmt -machinename Master1

The nodename must remain  Master1, otherwise the main Master server processes won't start.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

js88699's picture

Thanks Marianne,  The original short name will still be on the server, but will be a different IP/NIC, so if adding the -mgmt (plus our others) as aliases will resolve that, we'll be in good shape.  Let me give that a try.

js88699's picture

Still not getting the correct version of the GUI.  I added the aliases, here is that info. (edited out actual machine names)

[jsnodgra@xxxxx01]# nbemmcmd -machinealias -getaliases -machinename xxxxx01 -machinetype master
NBEMMCMD, Version: 7.5.0.4
The following aliases were found for the alias: "apinnbsomst01"
xxxxx01
xxxxx01.xxxtools.loc
xxxxx01-mgmt
xxxxx01-mgmt.xxxtools.loc
Command completed successfully.
 

I'm really hoping we don't have to re-install at this point in the game.

js88699's picture

Is the name associated with a NIC or IP address in the inner workings you talked about?