Video Screencast Help

Not licensed

Created: 13 Jul 2012 | 1 comment

I have bought the current version of PGP command line and I have set that up on a computer to the point where I can encrypt successfully.  The next step is for me to automate this job through a job scheduler we have.  Like many schedulers, this one will login remotely to the server at the time to execute the job.

The problem is that when the job is run through the scheduler, I get an error stating PGP is not licensed.  When I run the same command on the server and using the same account as the scheduler, it works fine. I can also see my license is valid.

I ran a command in the scheduler to get me the version info (pgp --version -verbose) and it clearly states the license is not valid.  The problem is that I don't know how to make that a valid license.  As I mentioned above, I am using the same service account for each (when I run the job through the scheduler and when I run it manually) and I thought that would take care of the issue but it didn't.


Comments 1 CommentJump to latest comment

dfinkelstein's picture

License information is stored in the preferences file.  This means that if you license the product as a particular user, the license information is stored in that user's prefs file.  This can be inconvenient if you are trying to use PGP Command Line as different users on the same machine.

In 10.2.1 we started creating a "global" preferences file to store the license information for the entire machine.  If you are running 10.2.1 and licensed PGP Command Line as the root user, then hopefully every user will be licensed.  But if you licensed as a different user (who cannot write to the global preferences location) then only the user(s) who license PGP Command Line will have a valid license (unless users are also sharing the same PGP_HOME_DIRECTORY).

So, if you are running 10.2.1, you could try re-licesning as root.  If you are not running that version (or cannot license as root), then look at the "File information" section after running "pgp --version --verbose".  The "home directory" values are likely different.  One way you can try to fix this is for the "failing" invocation to set "--home-dir" to point to the location of the home directory of the "working" location.



David Finkelstein

Symantec R&D