Video Screencast Help

Not working outbound mail encryption. Outlook 2010 & PGP 10.2.1

Created: 15 Dec 2012 | 8 comments

Don't discovering new accounts, outgoing mail is not encrypted, but incoming mail is processed correctly.

Configuration: PGP Desktop 10.2.1 (Build 4940), Outlook 2010 (Ver. 14.0.6129.5000), Windows 7 ultimate 6.1.7601 SP1 build 7601 (all 64-bit), antivirus Norton 360.

PGP configuration and maximum detailed log attached. I try to connect via POP/SMTP without any complications. Please help community because my ideas are over.

Comments 8 CommentsJump to latest comment

Tom Mc's picture

Do you either have Outlook set to make an SSL connection, or have some other application, such as email AV scanning, using an email proxy?  This Knowledge Base Article may be helpful.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

MStar's picture

My Outlook does not use SSL because together with the mail server is on the same virtual private network.

The only clearly visible process of additional control POP / SMTP port is in Norton 360. Disable antivirus and spam control does not improve the performance of PGP. I did not uninstall Norton 360 because I hope that the program of one brand at least checked for compatibility.

I installed Windows Live Mail, but PGP also sees its activity. So it's either installation PGP proxy or in a process that blocks the activity of a proxy. But how to identify this process I do not know.

Contains the log in the first post any useful information?

Tom Mc's picture

Please reread the PGP Release Notes for any known conflict or settings adjustments that may be needed for your system. 

Although I don't see Norton 360 specifically mentioned, the following quote may offer guidance that might also help with Norton 360 use.

Symantec Norton AntiVirus 9.x through 10.x, Symantec Norton Internet Security 2003, Symantec Norton Internet Security 2004

  • Disable email scanning.
  • For Norton Internet Security users, disable Norton Privacy Control and Spam Alert.
  • Disable SSL/TLS in Server Settings in PGP Desktop and PGP Universal Satellite. (In PGP Desktop, select the PGP Messaging Control Box and then choose Messaging > Edit Server Settings. For SSL/TLS, select Do Not Attempt. In PGP Universal Satellite, on the Policies tab, select Ignore SSL/TLS.) These versions of Norton AntiVirus prevent all mail clients from using SSL/TLS, regardless of the use of PGP software.

Symantec Norton AntiVirus 11.x through 12.x, Symantec Norton Internet Security 2005, Symantec Norton Internet Security 2006

  • No special configuration required for MAPI email.
  • When using POP email, enable Auto-Protect and disable the Anti-Spam and Email Scanning options. Auto-Protect, which is enabled by default, provides protection against viruses in email messages when the message is opened.
  • Disable SSL/TLS in Server Settings in PGP Desktop or PGP Universal Satellite. (In PGP Desktop, select the PGP Messaging Control Box and then choose Messaging > Edit Server Settings. For SSL/TLS, select Do Not Attempt. In PGP Universal Satellite, on the Policies tab, select Ignore SSL/TLS.) These versions of Norton AntiVirus prevent all mail clients from using SSL/TLS, regardless of the use of PGP software.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

BernardL's picture

Hi there,

I sympathize with you. At the time of MS Office 2003, PGP and MS Outlook were coexisting very well together.That is PGP Messaging and MS Outlook were working well with PGP/MIME and/or S/MIME as well (respectively).

Since MS Office 2007, PGP became erratic with Outlook with as a 'bonus' a complete disruption of the processing of the certificate X.509 in Outlook.

I was eager to find a solution, then I persistently pestered Microsoft, PGP/Symantec (Tom et al), McAfee, and the CA (Certification Authority for X.509) to no avail. Nobody seems to understand my problem.

Then I passed to MS Office 2010 (Hoping it was MS) but same story. I bought another laptop thinking about a hardware bug, same story.

Please note that during that time PGP and Windows Mail or Outlook Express were working well. Does it mean that MS Outlook is not compatible with PGP???

After several years of search I discovered that, if I want a communication X.509 based I exit PGP services. If I need a PGP messaging communication I avoid X.509. This is very clumsy as depending on which contact I am communiating with, and despite that I have still renewed my 2013 maintenance subscription with Symantec.

My configuration is: PGP Desktop standalone, MS Office, McAfee Total Protection, Windows Vista and 7 (No TPM nor Smart Card).

Still hoping for the PGP bug to be removed,

Best regards,

Bernard

 

 

 

User of PGP Desktop Pro since 2007

MStar's picture

Bernard, thank you for the condolences.
Tom, did not work, so I removed the antivirus completely. Admittedly it did not help.
But I noticed an interesting fact. When I remove the PGP, I additionally delete the following folders:

c:\Program Files (x86)\Common Files\PGP Corporation
c:\ProgramData\PGP Corporation
c:\Users\All Users\PGP Corporation
c:\Users\User\AppData\Local\PGP Corporation
c:\Users\User\AppData\Roaming\PGP Corporation

and from Registry

HKEY_USERS\.DEFAULT\Software\PGP Corporation
HKEY_USERS\S-1-5-21-1542787493-1721799466-637257041-1001\Software\PGP Corporation
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\CustomUIValidationCache\PGPolplg.PGPConnect.Microsoft.Outlook.Mail.Compose
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\PGP ...
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\eventlog\Application\PGPserv
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\eventlog\Application\PGPserv

When I installed PGP again, I was completely disconnected from the network. However, after entering the license key, I immediately received confirmation "Autorization Successful!"
Conclusion: PGP is not completely uninstalled.
Question: how did completely clean the system from PGP to the new installation?

 

Tom Mc's picture

Please see this Knowledge Base Article.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

MStar's picture

Things got totally hopeless and I reinstalled Windows.

PGP earned but not without errors. Now the situation is like this - on my computer installed two mail client, Live Mail and Outlook 2010. They are all configured to the same mailbox. But Live Mail is working properly, and Outlook gives an error "ProxyLib: Error processing SMTP message, awaiting next client command. (-11495).". This only happens when checking account settings. Regular mail is received and sent successfully. It is clear that there is no guarantee any long success.

 

 

AttachmentSize
PGPlog_3.txt 2.57 KB
PGP_Ben's picture

Before that error, I see another one:

 

Fatal exception evaluating policy for recipient xxx@yyy.zzz: key has been disabled - but no Exception chain to jump to
11:32:47 Email	 Debug	ProxyLib: Finishing transaction. "451 PGP Desktop: Error processing message"

This shows the users key was disabled. So PGP Desktop returns an SMTP error code 451 'action aborted' because it failed to determine how to handle the message.

Did you check the key of the recipient to verify that the key is still active and verified? It does seem strange that it's reporting no Exception chain to jump to. Usually there is always a default implicit 'send in the clear' rule. Unless you are forcing encryption by clicking the PGP encrypt button in Outlook or something. Even then, you would see a slightly different error message.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.