Video Screencast Help

Notification at Netbackup 7.0.1 using blat Faild to send Mails

Created: 14 Feb 2013 • Updated: 20 Feb 2013 | 8 comments
This issue has been solved. See solution.

Hello ,

dears i want to recieve a notification Mail from My master server which running with windows server (64)

and i have symantec Netbackup 7.0.1 and i have 10 server as Host Clients ....

i'm trying to make a notification to backup success or Failer ,

so i installed Blat blat310_64.full on the Master Server and i test the mail for blat and i recieve the testfile Correctly

at my Email :)

then i Configured all Clients from Netbackup Management Console to send mail as client to my Email

but i didn't get any response

also i Configured my Nbmail.cmd

 

@IF "%~4"=="" (

blat %3 -s %2 -to %1 -server xxxxxxx.com -q
) ELSE (
blat %3 -s %2 -to %1 -server xxxxxxx.com -q -attach %4
)

and the End part of the Nbmail.cmd

@IF "%~4"=="" (
blat %TEMP%\nbmail.tmp -s %2 -t %1 -s xxxxxxx.com -q
) ELSE (
blat %TEMP%\nbmail.tmp -s %2 -t %1 -sxxxxxxx.com -q -attach %4
)

 

 

but i still didn't Get any notification Mails....:(

 

 

Please help help help ,,,,,,,,,,,,

 

 

and i already did this instruct form the following Post:-

http://www.symantec.com/business/support/index?pag...

Comments 8 CommentsJump to latest comment

watsons's picture

A good way to troubleshoot this:

1) First, run following in command line to make sure it works, supply your own %1, %2, %3 & %4

blat %3 -s %2 -to %1 -server xxxxxxx.com -q

blat %3 -s %2 -to %1 -server xxxxxxx.com -q -attach %4

2) If the above works, schedule a job and run it using nbmail.cmd (make sure the path of blat is set correctly)

One thing I notice is that, %1 does not seem to work with a mailing list, so try with a single email address first.

Mark_Solutions's picture

Sounds like you have set it to send mail from the client but installed blat on the Master

If you just want to have blat installed on the Master then make sure that it is set that the Master Servers the e-mail - double check your settings

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

eng.elfateh@gmail.com's picture

Hello All ,

First I want to Thank You All cause My Problem Solved .... :)

PS:: After i Installed Blat To Client servers that Using Netbackup i started to revice Notification Mails about it ..

But

Now i Want to Edit the Message of Notification specially at Subject attribute .

I want the Subject to Be Like the Following

 

Netbackup+((operation backup or restore))+ON server ((Client server))+ Job((Success or Failed))

 

Hwo can i do that ?!!!!!!

thanks..

Mark_Solutions's picture

If you look at the backup_exit_notify.cmd script in the clients \netbackup\bin\ directory you will see the format that this send out

The variables are listed in there so you can edit it to suit

It may make life easier to do all of your notification from the Master bearing in mind that you may also have parent jobs so if you want notification of those it needs to be done on the Master using the Parent_End_Notify.cmd

Dont forget if you original questions is answered to mark the answer that helped you the most by using the "Mark as solution" option to help others looking for a similar issue in the future,

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

eng.elfateh@gmail.com's picture

dear Mark,

Thanks For Reply

I searched for the backup_exit_notify.cmd&&Parent_End_Notify.cmd

But i didn't Found any Of them at Nither Master server Nor at Client servers

what should I do .. ?

Best regards ,

Mark_Solutions's picture

You could borrow mine!

Just rename back to .cmd rather than the ,txt

These are from a V7.1 installation but should be the same.

AttachmentSize
backup_exit_notify.txt 3.84 KB
parent_end_notify.txt 3.82 KB

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.