Video Screencast Help

Notification Server Errors

Created: 21 Jan 2014 • Updated: 03 Feb 2014 | 8 comments
This issue has been solved. See solution.

Every couple of minutes i'm getting a bunch of errors in the log viewer & can't seem to figure out whats causing them!

The target item for the client message does not exist. (Guid"{00000000-0000-0000-0000-000000000000}")

Altiris.NS.ClientMessaging.EventQueueDispatcher.Dispatch

AeXSvc

No other information is provided & i'm stuck!

Operating Systems:

Comments 8 CommentsJump to latest comment

rafaelfontana's picture

Hard to tell. Can you provide us the full log?

Have you taken a look at your Event Queues?

Rafael Fontana

If the post helped you somehow please mark it as helpful, if helped solve your problem please mark it as solution.

Turley's picture
Log File Name: C:\ProgramData\Symantec\SMP\Logs\a.log

Priority: 1

Help and Support:

Date: 21/01/2014 12:46:57

Tick Count: 679625126

Host Name: SJH-ALTNS2

Process: AeXSvc (29296)

Thread ID: 2432

Module: AeXSVC.exe

Source: Altiris.NS.ClientMessaging.EventQueueDispatcher.Dispatch

Description: The target item for the client message does not exist. (Guid: "00000000-0000-0000-0000-

000000000000")

Batch of 3-4 of those messages every few minutes, no other errors in log

There are 235 NSE files in queue, not 100% sure what i should be checking for in EvtQue, none are named "00000000-0000-0000-0000-000000000000"

Thanks

rafaelfontana's picture

It's a long shot, more experienced consultants can give way better help on this, maybe.

I'm guessing a resource is corrupted.

Query your database with this SELECT * FROM item WHERE guid =  "00000000-0000-0000-0000-000000000000"

And let's see if this brings up any light to us.

Rafael Fontana

If the post helped you somehow please mark it as helpful, if helped solve your problem please mark it as solution.

Turley's picture

Thanks for the suggestion, the query returned 0 results though

rafaelfontana's picture

If this is bringing concern to you, call Support. I tried to look up but I could not find anything related to this. :(

Rafael Fontana

If the post helped you somehow please mark it as helpful, if helped solve your problem please mark it as solution.

Kel's picture

Thanks Turley, it's good to see I'm not the only one.  I was reading your post last week when I was receiving about 4 of these messages per minute.

Since then we have upgraded our SMP server from SP2 to MP1.1 RUPv7 and this morning I have noitice that while we are still receiving these messages they have reduced to only about 1 per 5-10 minutes.

I'm still keen to eliminate these messages altogether this result is a lot better.  I'll be coming back to this post regularly for a potential fix. wink

Turley's picture

Just an update, logged an incident with support;

ENVIRONMENT/CONDITIONS: ITMS 7.1.1

- We ran the script from the article http://www.symantec.com/docs/HOWTO1191 to find the tables the blank guid belongs to.

- We found that the blank GUID point to resource Guids for different items.

- Each Item participates in one or more relationships. This is how Items are assigned to folders. Root hierarchy containers still have a parent folder relationship, but the container refers to a folder with a null GUID ({00000000-0000-0000-0000-000000000000}). This null GUID indicates that there is no parent folder.

Apparently it is by design & upgrading to 7.5 will stop the error appearing in the log viewer. Not really a solution but it looks like i'll just have to live with it for now!

SOLUTION
rafaelfontana's picture

Thanks on the update Turley!

Rafael Fontana

If the post helped you somehow please mark it as helpful, if helped solve your problem please mark it as solution.