Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Notification server Setup

Created: 03 Apr 2012 | 14 comments

Hi All,

This is Madhu, iam currently installing Notofocation server 6.0 on a Windows Server 2003.

I have installed Altiris DS6.9 SP5. everything working fine except the Notification Server.

When i try to browse the NS on IIS, its throwing an exception as shown below.

i have tried registering the COM dll trough command prompt. Thanks in Advance.

Comments 14 CommentsJump to latest comment

fabio.sanches's picture

Hi,

Close the window and try to restart NSSetup. If the error is still present you can follow this procedure to fix the problem with ASP.NET.

Here are the steps to follow:

Reset ASP.NET settings

Note: Resetting the ASP.NET settings is quick and won't adversely affect your Notification Server. It often helps correct authentication problems in the Notification Server.

  1. Close the IIS Admin Service by clicking the Start > Control Panel > Administrative Services > Services. Then right-click the IIS Admin Service, and click Stop.
  2. On the Notification Server computer, open a command window (Run Command). Use Windows Explorer to go to C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322 (or equivalent in your environment). Register your aspnet_isapi.dll by dragging it into the command window and adding regsvr32 command on front of the path.

    regsvr32 "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll"

    • Run the following command line to view the NS Web applications associated to .NET 1.1.4322:  (Note: Run the following commands from the RUN prompt or from the C prompt.)

      C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -lk

      (Note:  -lk lists all the path of all IIS metabase keys where ASP.NET is scriptmapped, together with the version. Keys that inherit ASP.NET scriptmaps from a parent key will not be displayed.)

      (Note: The aspnet_regiis.exe utility is an administration utility that manages the installation and uninstallation of multiple versions of ASP.NET on a single computer.)

    • Run the following command line to remove the all associations to .NET 1.1.4322:

      C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -k W3SVC/ 

      (Note: -k <path> removes all scriptmaps to any version of ASP.NET from the specified path, recursively. E.g. aspnet_regiis.exe -k W3SVC/1/ROOT/SampleApp1)

    • Run the following command line to add the NS Web applications back to .NET 1.1.4322:

      C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

      (Note: The -i parameter installs this version of ASP.NET and updates scriptmaps at the IIS metabase root and for all scriptmaps below the root. Existing scriptmaps of lower versions are upgraded to this version.)

    • Run the following command to restart IIS services:

      iisreset

Article URL http://www.symantec.com/docs/TECH12667

Regards,

madhunature41@gmail.com's picture

Hi Luke,

I tried the above but of no luck left with the same error.

When i see the Notification Server Logs the below is the error its showing up..

Apr 04 04:03:55 E Failed to start the File receiver. CoCreate Event Router returned 80040154. Altiris NS Receiver AeXNSRcvSvc.exe AeXNSRcvSvc.exe (5156) 4028  
Apr 04 04:03:55 E Failed to start the RPC receiver. CoCreate Event Router returned 80040154. Altiris NS Receiver AeXNSRcvSvc.exe AeXNSRcvSvc.exe (5156) 4028  
Apr 04 04:03:10 E Caught unknown exception. Error=System.TypeInitializationException: The type initializer for "Altiris.NS.Utilities.DbUtils" threw an exception. ---> System.Runtime.InteropServices.COMException (0x80040154): COM object with CLSID {649238E5-891E-4A94-A8BD-0394092D44BE} is either not valid or not registered. at System.Runtime.Remoting.RemotingServices.AllocateUninitializedObject(RuntimeType objectType) at System.Runtime.Remoting.RemotingServices.AllocateUninitializedObject(Type objectType) at System.Runtime.Remoting.Activation.ActivationServices.CreateInstance(Type serverType) at System.Runtime.Remoting.Activation.ActivationServices.IsCurrentContextOK(Type serverType, Object[] props, Boolean bNewObj) at Altiris.NS.Utilities.DbUtils..cctor() --- End of inner exception stack trace --- at Altiris.NS.Utilities.DbUtils.IsNSDatabaseReady() at Altiris.NS.ClientMessaging.ClientEvtQueueWatcher.LogEventQueueStatusThreadProc()

I thought its the problem with the COM components.

i tried registering the COM dll wit srvreg32 command but then also the same error and unable ti install NS.

Pls advice meon this.

Thanks for you support and prompt reply.

Regards,

Madhu

fabio.sanches's picture

Hi Madhu,

In case that you want to remove .NET 2.0 from being used by IIS without removing it from Add/Remove Programs, you can try the following command line (just make sure that you are unistalling the right version of .NET):

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -ua
(Note: the -u switch formerly listed for this command removes .NET 2.0 from being used by IIS and then associates unregisterred applications to the highest installed version of .NET which would still be 2.0. By using -ua, it only removes the registrations.)

Then go back and re-register .NET 1.1 as mentioned on steps 1 a) and 2 b) above.

Then, make sure ASP.NET v1.1.4322 is allowed in Web Server Extensions:

  1. Go to IIS Manager (Administrative Tools/Internet Information Services (IIS) Manager).
  2. In the IIS Manager, go to Web Server Extensions and make sure that at least ASP.NET v1.1.4322 is allowed.

Note: There are cases where in addition to the fix provided in this article, you will need to edit HK-LM\Software\Microsoft\ASP.NET\RootVer to read "1.1.4322" before the InstallHelper would let you continue.

  1. a) Run the following command line to add the NS Web applications back to .NET 1.1.4322:

    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

    (Note: The -i parameter installs this version of ASP.NET and updates scriptmaps at the IIS metabase root and for all scriptmaps below the root. Existing scriptmaps of lower versions are upgraded to this version.)

  2. b) Run the following command to restart IIS services:

    iisreset

    (Note: It will stop and restart IIS services in order to add the changes into IIS.)

Then the application is finished; test to see if it fixed the installation problem.

madhunature41@gmail.com's picture

HI Luke,

I have tried your 2nd reply also...

Even then iam getting the same error..

Iam wondering how the .Net Framework related to COM Components issue..

Thanks for your valuable time on this.

Please suggest me furthur and help me out.

Regards,

Madhu

fabio.sanches's picture

Hi Madhu,

I'm happy to help you. Could you please verify if have any error message at Event Viewer about DCOM or ocurred close to the NS installation time?

Please configure DCOM Permisions like that before run NSsetup again.

  1. Launch DCOMCNFG from Start > Run.
  2. Click the Default Properties tab and verify that the Default Impersonate Level is set to Identity.
  3. Click the Default Security tab.
  4. By default, Default Access permission is blank. If this is the case then local system and local administrators have access. However, if accounts have been added, the default settings are overwritten and only those accounts shown are given access.
  5. If the Default Access permission settings are not blank then this is the source of your problem.

Add administrators to this setting and give it Allow Access permissions. For Windows 2003 servers:

  1. Click on Administrators Tools Components Services Computers > My Computer.
  2. Right-click My Computer and select Properties.
  3. Default Access Permissions:
    • 2003 Default COM Security tab> Self and System both have Allow.
    • 2003 SP1 COM Security tab > Self and System both have Allow Local and Remote.
  4. Default Launch Permissions:
    • 2003 Default COM Security tab > Administrators, Interactive and System all have Allow.
    • 2003 SP1 COM Security tab > Administrators, Interactive and System all have Allow Local and Remote.

If Self is removed, the only way to bring it back is to find it on the Domain. If either Self or System is removed, then they should be brought back as well as Administrators and Interactive should be added with the same permissions.

http://www.symantec.com/docs/TECH14855

Regards,

Fábio Sanches

 
madhunature41@gmail.com's picture

Hi Luke,

I have checked all the default COM Services settings, everything is fine as u explained in your previous post.

Dont know whats going wrong :-(

Iam really worried about this NS.:-(

What shall i try now?

Thanks,

Madhu

fabio.sanches's picture

Hi Madhu,

Continuing the troubleshooting process.

Regsvr32 "D:\Program files\Altiris\Notification Server\Bin\AexUtility.dll"
regsvr32 "D:\Program Files\Altiris\Notification Server\bin\aexlicense.dll"
 

The drive location to the Altiris installation path, in the above instance, was D:\Program files\Altiris so D was used for the path in the command line. It will need to be modified if Altiris is installed to a different drive path. 

1) Backup the web.config and coresettings.config files per http://www.symantec.com/docs/HOWTO10321 (Attention to make the proper steps)

2) Delete the AexSvc.exe and AexSvc.exe.config files from the <Install Dir>\Altiris\Notification Server\bin directory
3) Run a repair on NS Core via Add/Remove programs
4) Run a repair on NS Hotfix KBxxxxx via Add/Remove programs
5) Restore the web.config and coresttings.config files

Regards,

madhunature41@gmail.com's picture

Hi Luke,

Tried to repair the NS from the Control Panel. While installing its saying another installation is in progress.

fabio.sanches's picture

Hi Madhu,

Did you reboot this server and tried repair again?

Regards,

madhunature41@gmail.com's picture

Hi Luke,

Yes i rebooted the server and tried again.

Again i got the same error.

FYI this is the 1st time iam Installing the NS on server, till now i didnt use the NS.

Thanks,

Madhu

madhunature41@gmail.com's picture

Hi Luke,

Thank god by the end the COM Components error has gone and i moved a step forward.

In 3rd step it asked me to connect to the SQL Database.

I tried in multiple ways.

Can u hel me, wher can i locate which credentials apllication will use to connect to DB?

Thnaks,

Madhu

fabio.sanches's picture

Hi Madhu,

Thanks for your good news! Application credentials are the account you have configured at Step 01. Do you have the SQL Server at the same machine? Do you remember when install the SQL Server if was choosed the Mixed Mode authentication?

Mixed Mode authentication allows SQL logins and Windows authentications logins to access the SQL databases, and Applications Credencials need this type of access.

If you don´t remember, try using the SA account. So change the Step 3 to "Use SQL Login" and username SA, and the password configured at SQL installation.

Regards,

fabio.sanches's picture

Hi Madhu, how are you?

Do you have any news about your issue?

Regards,

madhunature41@gmail.com's picture

Hi Luke,

Excuse for late in response, was off the work all these days.

Coming to my NS Problem, still iam facing the same issue.

In UI its showing the DB authentication error as posted in my previous post but when in look into the NS error log it was showing the COM components error.

So i was unable to decide what exactly causing the problem :-(

Any idea on this?

Thanks,

Madhuri