Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Novell client connection very slow on CIFS share SFS

Created: 04 Jul 2011 • Updated: 12 Jul 2011 | 2 comments
This issue has been solved. See solution.

Hello,

Today, i tried to install a new FileStore cluster and i have a big issue. My customer have Novell Client 4.91 SP5 for Windows installed on all computers, and just some server without this Novell Cient.

So, when we try to connect the CIFS share created on the new SFS cluster, it is very slow : More than 2 minutes to have the login box, and 2 minutes again to have the share content, and the browsing is impossible (too sloooow).

So, we uninstall the Novell client on the Windows XP computer, and after the reboot, it works normally. It works also from the computers/servers without Novell client.

My question : How to keep the Novell Client and have a CIFS share on the FileStore ? 

I have already found this article on Novell forum :

 

Re: Slow mapping to samba share when novell client installed

That was it! Thanks your guys for the info. I opened 524 and 139 for samba and now it maps in seconds with the client and firewall up.

 

Paste from <http://forums.novell.com/novell/novell-product-discussion-forums/netware/nw-other/communications/388062-slow-mapping-samba-share-when-novell-client-installed.html

 

Thank you for your help.

Comments 2 CommentsJump to latest comment

Loic Bouquet's picture

Solution previously exposed is not good.

I've found some other articles, but they are not the solution :

 

From : > http://www.novell.com/support/php/search.do?cmd=displayKC&docType=kc&externalId=10095000&sliceId=&docTypeID=DT_TID_1_1&dialogID=92807520&stateId=1%200%2011826795

1. Run Registry Editor (REGEDT32.EXE).

2. From the HKEY_LOCAL_MACHINE subtree, go to the following key:

      \SYSTEM\CurrentControlSet\Services\NetwareWorkstation\Parameters]
      
3. From the Edit menu, select Add Value.

4. Add the following (using Server1, Server2, and Server3 as examples):

      Value Name: BadServer
      Data Type:  REG_MULTI_SZ
      Data:       Server1<CR>Server2<CR>Server3

NOTE: <CR> Indicates you should hit Enter on the keyboard

5. Choose OK and quit Registry Editor.

6. Shut down and restart Windows NT.

 

BUT IT IS NOT WORKING !

 

We try to map Windows Share (from a windows server) and with the novell client installed, it's working normaly.

In FileStore 5.6 RP1, the samba version is 3.5.8

Loic Bouquet's picture

Hello,

Finally, we found a solution :

In the Novell Client -> Advanced Settings, there is a parameter called ‘UNC Path Filter’.

If this option was enabled (it's the default), all UNC request will first filtered by Novell Client. But in our case, we need to bypass this feature.

 

So, the solution is to Disable this option, restart the PC and it's ok.

SOLUTION