Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NS7 - "Computer is available at the exact scheduled time" - Option Not Honored

Created: 15 Feb 2011 | 6 comments

Hello all, and thanks in advance for your time and help.

Server: NS 7.0.8641

Client Management Agent:  7.0.8641.1641

Client OS:  Windows 7 x64 Enterprise

Scenario:  I have a Managed Software Delivery that I want to run only if the computer is on at 3:00am.  So I created a schedule for the Managed Software Delivery to run at a Scheduled Time of 3:00am.  I set the advanced option on the schedule "Computer is available at the exact scheduled time".

Issue:  Computers that are off overnight run the Managed Software Delivery as soon as they are turned on despite the scheduled time being 3:00am and the option checked off to only run it at that exact time.

Alternate solution attempted:  Instead of doing a Scheduled Time schedule I also tried a Scheduled Window with the same option checked "Computer is available at the exact scheduled time".  I get the same results,  the Managed Software Delivery still runs as soon as the computer is turned on; outside of the Schedule Window.

Please let me know if you have any suggestions or need additional information.

Thanks,

Scott Struzik

Comments 6 CommentsJump to latest comment

Cesar_echeverria's picture

testing this configuration

and

Cesar Echeverria Castillo

Consultant Engineer

InterLAN Ltda, Medellin, Colombia

P.S.: If this works please let the community knows about it.

ScottStruzik's picture

Cesar_echeverria,

I tried your configuration.  This results in the Managed Software Delivery not running at all, including at the specified time.  It kicks off the Detection and Applicability checks, but there is Execute portion of it with "Don't Run Remediation" selected.

Thanks for the recommondation, it was worth a try!

Cesar_echeverria's picture

I will replicate your environment at my company, and look how it behaves

Cesar Echeverria Castillo

Consultant Engineer

InterLAN Ltda, Medellin, Colombia

P.S.: If this works please let the community knows about it.

KSchroeder's picture

You may want to try applying the latest agent-side hotfix:

http://www.symantec.com/docs/HOWTO36013

Thanks,
Kyle
Symantec Trusted Advisor

For Forum threads, please click "Mark as Solution" if answered.
For all content, please give a thumbs up if you agree with or support the post.

jimmy.cartrette's picture

We are running into this same problem. Did you apply the agent-side hotfix, and did that work? Is this a known problem now?

nicoled18's picture

I'm sad to report this is still an issue in 7.1 apparently.  It seems that if a computer receives the policy to run a policy at X time but it then gets powered off or put into standby, it will run it when it comes back online.  If a computer never receives the policy, it behaves as expected when it comes online and sees that the time to run the policy has alredy expired. 

I ran up against this issue when trying to schedule a 2AM restart for all computers.  I did not want users to get prompted to restart if they came into work after having their desktops or laptops powered off/on standby the next morning.

I have been using a workaround involving maintenance windows.  I set up a maintenance window for 2-3AM.  Then I tell the policy to run the remediation at the next maintenance window.  This is the only way I have been able to reliably run a policy at a certain time and make sure it does not get run when I don't want it to.

We are lucky in that we have not employed maintenance windows for any other function so we don't have to worry about that.  If you don't rely on maintenance windows for other items, this may be a viable workaround for you so I figured I'd suggest it.

Hopefully this will be fixed at some point... definitely a misleading checkbox given the actual behavior.