Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Nukona on-premise version, trial installer error for mysql

Created: 19 Dec 2012 | 5 comments

 I am installing Nukona on RHEL 5 64 bit virtual machine (x86_64 GNU/Linux). I am following the "App_Center_Installation_and_Operations_Guide_401.pdf" guide.

I have installed jdk6 and Microsoft fonts as mentioned in this document. After that when I proceed with trial installation I get error when the setup installs MySql server. Kindly help me with the error.

Command:

sudo ./setup.sh -d install trial

 

Error (at the last):

.........

...........

--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 mysql                   x86_64     5.0.45-7.el5     installed         7.5 M
 mysql                   i386       5.0.45-7.el5     installed         7.3 M
 mysql-server            x86_64     5.0.45-7.el5     installed          22 M
Removing for dependencies:
 MySQL-python            x86_64     1.2.1-1          installed         288 k
 libdbi-dbd-mysql        x86_64     0.8.1a-1.2.2     installed          54 k
 mysql-connector-odbc    x86_64     3.51.12-2.2      installed         419 k
 perl-DBD-MySQL          x86_64     3.0007-1.fc6     installed         328 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       7 Package(s)         

Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
   Erasing   : mysql-server                 ######################### [1/7]
   Erasing   : MySQL-python                 ######################### [2/7]
   Erasing   : mysql                        ######################### [3/7]
   Erasing   : libdbi-dbd-mysql             ######################### [4/7]
   Erasing   : perl-DBD-MySQL               ######################### [5/7]
   Erasing   : mysql-connector-odbc         ######################### [6/7]
   Erasing   : mysql                        ######################### [7/7]

Removed: mysql.x86_64 0:5.0.45-7.el5 mysql.i386 0:5.0.45-7.el5 mysql-server.x86_64 0:5.0.45-7.el5
Dependency Removed: MySQL-python.x86_64 0:1.2.1-1 libdbi-dbd-mysql.x86_64 0:0.8.1a-1.2.2 mysql-connector-odbc.x86_64 0:3.51.12-2.2 perl-DBD-MySQL.x86_64 0:3.0007-1.fc6
Complete!
=== Installing MySQL server ===
Loading "security" plugin
Setting up Install Process
Parsing package install arguments
No package mysql available.
No package mysql-server available.
Nothing to do
An error occurred while installing mysql mysql-server. No matching package found.
Output logged to /var/log/nukona/nukona-install.log

-Abhijit

Comments 5 CommentsJump to latest comment

abhijit_kadam's picture

After the error when I fire the preinstall commnad I get following:

sudo ./setup.sh preinstall
Trial set...
SELinux detected.
SELinux is not enforced.
Failed to detect operating system version.
Output logged to
[root@nukonatest iso]# ./setup.sh preinstall
Trial set...
SELinux detected.
SELinux is not enforced.
Failed to detect operating system version.
Output logged to
 

abhijit_kadam's picture

Update:

I have set the repositories as follows and enabled the remi repository from the /etc/yum.repos.d/remi.repo file(enabled=1).

 

rpm -Uvh http://dl.fedoraproject.org/pub/epel/5/x68_64/epel-release-5-4.noarch.rpm
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
 
After that I restarted now the installer is able to get the mysql and mysql-server packages however it is unable to get the dependency 'perl-DBD-MySQL'. Note that before the install start this package was there however the installer removed it and later it is unable to find this dependency package.
 
........
Removed: mysql.x86_64 0:5.0.45-7.el5 mysql.i386 0:5.0.45-7.el5 mysql-server.x86_64 0:5.0.45-7.el5

Dependency Removed: MySQL-python.x86_64 0:1.2.1-1 libdbi-dbd-mysql.x86_64 0:0.8.1a-1.2.2 mysql-connector-odbc.x86_64 0:3.51.12-2.2 perl-DBD-MySQL.x86_64 0:3.0007-1.fc6
Complete!
=== Installing MySQL server ===
Loading "security" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.28-3.el5.remi set to be updated
--> Processing Dependency: mysql-libs = 5.5.28-3.el5.remi for package: mysql
---> Package mysql-server.x86_64 0:5.5.28-3.el5.remi set to be updated
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server
--> Running transaction check
---> Package mysql-server.x86_64 0:5.5.28-3.el5.remi set to be updated
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server
---> Package mysql-libs.x86_64 0:5.5.28-3.el5.remi set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: perl-DBD-MySQL is needed by package mysql-server
An error occurred while installing mysql mysql-server
Output logged to /var/log/nukona/nukona-install.log

patriot3w's picture

I think your server not able to find the required packages. can you try to install the packages manually? by running yum or rpm.

tks

 

abhijit_kadam's picture

Thanks for the attention towards this problem. I tried manual install however the trial install uninstalls the mysql and then it is unable to find the packages. Later I enabled remi and epel repository and in addition setup and enabled a local repository from all rpms in installation CD's of RHEL5. After this the installer was able to find all the mysql packages and mysql was installed.

However I got another error, mentioned below. I have attached another install file nukona-install2.zip. It appears that the error is while installing xmlsec1-1.2.18-10.x86_64. The libxmlsec1.so.1 file is there on my system in /usr/lib, /usr/lib64/

 

Finished Dependency Resolution
Error: Missing Dependency: libxmlsec1.so.1()(64bit) is needed by package xmlsec1-openssl
Error: Missing Dependency: libxmlsec1.so.1()(64bit) is needed by package xmlsec1-nss
Error: Missing Dependency: libxmlsec1.so.1()(64bit) is needed by package xmlsec1-gnutls
Error: Missing Dependency: libxmlsec1.so.1()(64bit) is needed by package xmlsec1-devel
An error occurred while installing RPMs(returncode 1)
Output logged to /var/log/nukona/nukona-install.log
 
AttachmentSize
nukona-install2.zip 12.64 KB
mclemson's picture

yum clean all

yum update

Try again?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com