Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Offhost backup of VMWare Physical RDM volume on Equallogic Array

Created: 30 Jul 2012 • Updated: 31 Jul 2012 | 7 comments
This issue has been solved. See solution.

First I describe what I do today:

I have large Exchange volumes, so to back these up, I utilize offhost backups as it's a much faster backup.  The volume is on an Equallogic array, and I connect that volume to my Exchange server via the Microsoft iSCSI initiator, straight through Windows.  Windows in a virtual machine, running on ESX 4.1 server.  Because I'm using the MS iSCSI initiator, VMWare has no idea about this volume.  Basically it's as if this was a physical machine, connecting to my RDM volume.  I backup this volume via Backup Exec 2010 R2, using the ADBO option, and the Equallogic HIT kit is installed on both my media server and my exchange server.  This has worked well for some time.

What I want to do, is convert my volume to a VMWare RDM Physical Volume, because then VMWare knows about the volume, and I can leverage other replication products.  Converting the volume is easy, I've already removed it from the MS iSCSI initiator, and added it as a physical RDM in my VM configuration.

The problem is actually backing up the volume, via offhost means, so I can keep the fast backup speeds.  I tried to run my job as configured, and it fails.  I presume this is because of a VSS issue, because the BE error is:

"VSS Snapshot error. The Microsoft Volume Shadow Copy Service (VSS) snapshot failed. Make sure that all provider services and tasks are running. Check the Windows Event Viewer for details."

Do I need to install a different VSS provider?  Currently I have the Equallogic installed (via their HIT kit) and of course Windows, as this is a Windows Server 2008 R2 server.  VMTools is also installed, so I understand that also has a VSS provider.

Essentially I need to know what I need from front to back, to make my off host backups work, when the volume is a VMWare Physical RDM volume.

Should I remove the Equallogic VSS provider?  Should I install a BE VSS provider?

Thanks!

Comments 7 CommentsJump to latest comment

ZeRoC00L's picture

Physical RDMs are not supported, see the attached FAQ PDF:

Physical compatibility mode

(i.e. persistent-independent) bypasses the ESX storage infrastructure (vmfs file system) and thus cannot have a snapshot taken by vStorage API’s for Data Protection. Physical compatibility mode RDM disks in this configuration are skipped automatically during the backup and logged by Backup Exec as unprotected. For Physical compatibility mode RDM disks, Backup Exec Remote Agents can be installed in the Guest virtual machine to backup their data using traditional backup methods.

For your VSS errors, run the command vssadmin list providers, and check what VSS providers is in error state.

AttachmentSize
Backup-Exec-2010-VMware-FAQ.pdf 385.42 KB

If this response answers your concern, please mark it as a "solution"

Colin Weaver's picture

And ADBO OffHost is not supported against ESX virtual machines either as we use the VMware SAN Transport to provide backup over SAN technology

SPBoston's picture

I guess I don't totally understand.  I read through the above article, and it makes sense, if you're using the Backup Exec agent for VMWare, but I'm not using that.

I'm treating my server as if it were physical (as it states you need to do, in the article above), and just backing up the data via normal means (not using the VMWare agent).

I am using the ADBO option, so I can backup directly from the SAN, but that doesn't require the agent for VMWare, in fact I've been doing this for a few years now.

I guess the problem is, when I switch from a Microsoft iSCSI mounted RDM, to a VMWare Physical RDM, Backup Exec doesn't know how to properly snap the volume from the SAN anymore.  I think it's just missing a VSS piece.

Does this help at all?

ZeRoC00L's picture

Run the command vssadmin list providers, and check what VSS providers is in error state.

If this response answers your concern, please mark it as a "solution"

SPBoston's picture

none of them indicate they are in an error state.  just have the microsoft vss and equallogic vss that show up.

Ben L.'s picture

After doing a bit of research, using ADBO is not going to work when it's connected the drive as an RDM. 

The reason is because now the ESX host is controlling the connection to the iSCSI SAN instead of the Windows OS (with HIT).  Noneof the VSS providers (that I'm aware of right now) were designed to work with ESX on that level.

So when a command is sent to do the ADBO snapshot ESX doesn't know how to handle that and basically drops it or ignores it. 

When the SAN is setup with windows on iSCSI and HIT and the command is sent for the ADBO snapshot it knows to send the commands over to the device for the proper type of snapshot.  To use ADBO, the OS must have a direct connection to the SAN drive (iSCSI or fiber) on the Media Server and the Guest Machine. 

If this response answers your concern, please mark it as a "solution"

SOLUTION