Video Screencast Help

Once again - Unable to create a snapshot of the virtual machine.

Created: 08 Jul 2011 • Updated: 11 Jul 2011 | 6 comments
This issue has been solved. See solution.

I have a brand new installation of Backup Exec 2010 R3 together with a new clean install of vmware vSphere 4.1u1 (with VCenter and 8 ESXi-hosts).
For some reason i cant make it take backup of all my virtual servers. about 75% of them work fine, but for the rest all i get is:

-----------
Final error: 0xe0009574 - Unable to create a snapshot of the virtual machine. The virtual machine may be too busy to quiesce to take the snapshot.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-38260

------------

From searching on the net i found out that this can come from many reasons. I think i've looked through most of them without any luck.

The VM's are normal windows servers (2003, 2008 and 2008 R2) with latest vmware tools installed. if i make a snapshot in vmware (with quiesce guest file system enabled) it workes fine and i can see vid vssadmin that vmware-tools is the provider. But when trying a backup it does nothing. It just skips and gives me the error. I get nothing in the eventlog and nothing in the logs on the vmware server. It looks like Backup exec gives up before even trying.

The latest i found out now is that if i configure Backup Exec to take the backup directly against the esxi-host, then it works. But then it will fail if the VM is moved to another host, so that is not a solution.
Other VM's work just fine so it isn't an access or rights problem.

One VM (an Active directory server) has the RAWS agent installed (and vmware-tools snapshot-provided then was uninstalled) and it fails with same error.

Do you have any ideas?

regards

/Henric

Comments 6 CommentsJump to latest comment

ZeRoC00L's picture

You may have to remove the vmware VSS provider, and install the Symantec Backup Exec VSS provider.

http://www.symantec.com/business/support/index?page=content&id=HOWTO23038

http://www.symantec.com/business/support/index?page=content&id=TECH129724

If this response answers your concern, please mark it as a "solution"

Henric's picture

I get a similar response from symantec (i opened a case with them) togeather with some registry settings and sql-commands on the media server. So i tried it on one of my failing VM's. Installed the RAWS agent and then uninstalled vmware-tools and installed again without the VMware VSS Driver and VMware Filesystem Sync Driver, but backups are still not working. 

I dont get anything in the event-log on the VM. It looks like it does not even try to take a snapshot.

 

This is how it looks on about 15 of my VM's. But at the same time i have 35 other VM's where backups are working fine without any raws agent and only the VSS driver from vmware-tools. I cant find anything that differs between the working and non-working servers. Does anyone have any other ideas?

 

regards

/Henric

ZeRoC00L's picture

The RAWS agent is not necessarily required, but the Symantec VSS provider to create a successfull snapshot.

You can find the VSS provider on the installation (DVD):\BE\WinNT\Install\BEVSSProvider

 

The reason some servers are working, and others not MAY be because of the load, when a server is quite busy a quiesced snapshot cannot be made.

If this response answers your concern, please mark it as a "solution"

Henric's picture

But does the RAWS agent include the VSS provider?

 

About the load, the VM that i am experimenting on is not a busy one. I also tried migrating some other VM's to other esx-hosts to see if more resources would change anything but it didnt. If load also was the case, then i dont think it would be the exact same list of servers that fails every day.

 

Another thing is also the this i wrote in my first post. If i make a selection list against the esx-host instead of the VCenter-server then the backup worked just fine. So what is the difference between going via the VCenter or going directly to the host?

 

Henric's picture

This is actually a bit embarrasing, but since it might help someone else in the future i'll give you the solution anyways.

 

During a call from symantec support, we looked through my media server and after a while we got to my selection list. My VCenter server was check as is should, but when i was looking for my server it was nowhere to be found. And along with it, all my failing servers was missing from the list of VM's.

After searching for a while i found a folder which one of the other admins had made to sort the servers in the vsphere client (i dont even use the "VMs and Templates" view in the client so i didnt think about that one). Under one of the subfolders i then found my VM, and after selecting it there and removing the old selection (which was still under "View selection details") the backup worked fine, and i guess it will on the rest of my servers tonight when next backup-run is.

 

I could still complain a bit about the error-message though. An error telling me "virtual machine not found" whould have been a lot more easy to understand.

 

SOLUTION
Lesta G's picture

and I could really complain about the error-message though. An error telling me "virtual machine not found" whould have been a lot more easy to understand.

:(

Regards
Lesta
_____________________________________________________
If this response answers your query, please mark it as a solution