Video Screencast Help

one directory for a restore is corrupted in NB DB

Created: 23 Jan 2013 • Updated: 24 Jan 2013 | 5 comments
This issue has been solved. See solution.

Hi,

Netbackup Enterprise 7.1.0.4 running on Solaris 10

I tried to restore a destroyed home directory, client just happens to be on the netbackup media server.
Just using the restore tab in the admin GUI and browsing around in the dir tree everything works just fine except for one directory.

Host is ZFS only
I'm backing up ALL_LOCAL_DRIVES
Only one ZPOOL rpool with the standard ZFS /export/home
So all home dirs in /export/home are just dirs.

/export/home/rolands works fine
/export/home/<all other dirs> works fine
/export/home/patti doesn't work it just hangs.

Choosing a backup from 11/05/12 works fine again but that is quite old.
I use a fairly short 1 week retention and older are on weekly (4 weeks ret) and monthly (12 months ret)
Just because we only have a standalone drive in our lab.

What could be wrong here?

Thanks,
- Roland

Comments 5 CommentsJump to latest comment

mph999's picture

So you say the BAR gui hangs when looking in /export/home/patti

I'd start by looking in the .f file for that backup

cat_convert -dump <.f file>

This will be found in 

/usr/openv/netbackup/db/images/<client>/<ctime>

Couple of options :

1.  Could try just restoreing the top level dir /export/home or even /export/home/patti

2. Expire then reimport the image to rebuild the catalog info (would only do this as a very last restort).

Going to ave to dash as late here - need sleep.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
rsm.gbg's picture

Well, using that dump command shows that there is a bunch of files in the patti dir which have funny controll characters in the file name.
Probably the reason why it can't read it.

I wonder if using tar is my only option to get that dir back again?

- Roland

Marianne's picture

Restore will probably work from cmd or using Windows Admin Console.

We have seen in a number of posts on this forum that Java GUI has a problem with 'funny characters' in file/folder names.
Other users eventually get 'no entity found' in Java GUI. Most of these users have opened support calls with no resolution as yet.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
mph999's picture

Thay will be the issue then I suspect - dir reatore may well work, but Mariannes excellent suggestion of a command line rstore will probably be easier (... I don't think of that for some reason).

M

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805