Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Online config LLT interface

Created: 19 Jun 2013 • Updated: 31 Jul 2013 | 4 comments
This issue has been solved. See solution.

Recently I realized that a llt interface in a cluster is not working because the nodes are in different vlans (the interface uses broadcast conf):

Node 0:
 
NODE0:~ # cat /etc/llttab
set-node NODE0
set-cluster 1047
set-timer peerinact:3200
link eth2 eth-00:10:18:0b:7e:12 - ether - -
link eth3 eth-00:10:18:0b:7e:13 - ether - -
link-lowpri eth0 eth-00:14:5e:7b:08:1a - ether - -
 
NODE0:~ # ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:14:5E:7B:08:1A  
          inet addr:10.92.5.134  Bcast:10.92.5.255  Mask:255.255.254.0
 
 
Node 1:
 
NODE1:~ # cat /etc/llttab
set-node NODE1
set-cluster 1047
set-timer peerinact:3200
link eth2 eth-00:0e:0c:ba:3e:ae - ether - -
link eth3 eth-00:0e:0c:ba:41:96  - ether - -
link-lowpri eth0 eth-00:14:5e:7a:aa:3c - ether - -
 
NODE1:~ # ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:14:5E:7A:AA:3C  
          inet addr:10.93.146.123  Bcast:10.93.147.255  Mask:255.255.254.0
 
 
I think I should configure eth0 as an UDP interface, shouldn't I?? I tried somethink like that and It seemed to work:
 
Node 0:
 
//Specifying the other node IP as the broadcast address
lltconfig -t eth0 -d eth0 -b udp -I 10.92.5.134 -B 10.93.146.124
 
Node 1:
 
//Specifying the other node IP as the broadcast address
lltconfig -t eth0 -d eth0 -b udp -I 10.93.146.123 -B 10.92.5.134
 
Is this correct?? What should I define in the llttab file??
 
Regards,
joagmv
Operating Systems:

Comments 4 CommentsJump to latest comment

mikebounds's picture

There is a sample llttab file for LLT over UDP at https://www-secure.symantec.com/connect/forums/if-llt-could-be-configured-over-udp-nat#comment-7542471.

Note also, you can't mix LLT over UDP and LLT over Ethernet - see https://www-secure.symantec.com/connect/forums/how-configure-llt-over-udp-when-you-have-more-1-node-each-site#comment-7189341

So your config will look something like:
set-node NODE0
set-cluster 1047
link hb-eth2-nat /dev/udp - udp 50100 - IP-on-eth2-on-node0 -
link hb-eth3-nat /dev/udp - udp 50101 - IP-on-eth3-on-node0 -
link-lowpri hb-eth0 /dev/udp - udp 50102 - 10.92.5.134 -
 
set-addr 1  hb-eth2 IP-on-eth2-on-node1
set-addr 1  hb-eth2 IP-on-eth3-on-node1
set-addr 1  hb-eth0 10.93.146.123
 
#disable LLT broadcasts
set-bcasthb 0
set-arp 0

I have just chosen 3 UDP ports at random - 50100, 50101, 50102.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION
joagmv's picture

Very helpful Mike.

So, are the commands I executed correct?? I mean, does the command "lltconfig -l -t eth0 -d eth0 -b udp -I 10.92.5.134 -B 10.93.146.124" translate to

link-lowpri hb-eth0 /dev/udp - udp 50102 - 10.92.5.134 -
set-addr 1  hb-eth0 10.93.146.123
 
???

The main doubt I have is about the -B param...

mikebounds's picture

The VCS install guide says:

Use LLT over UDP in the following situations:
 
■ LLT must be used over WANs
■ When hardware, such as blade servers, do not support LLT over Ethernet
 
LLT over UDP is slower than LLT over Ethernet. Use LLT over UDP only when the
hardware configuration makes it necessary.
 
And also says:
The set-addr command in the /etc/llttab file is required when the broadcast
feature of LLT is disabled, such as when LLT must cross IP routers.
 
So my understanding is that if you have hardware, such as blade servers, that does not support LLT over Ethernet, then you use Broadcast feature, otherwise, for WANs when LLT must cross IP routers you disable broadcast and use specific IPs.
 
So the "-B" is for broadcast address, but you have not set a broadcast address, so I am surprised your command resulting in a working config.    The broadcast address is the last arg in the llttab, so an example of lines in the llttab when using broadcast feature is:
 
link link1 /dev/udp - udp 50000 - 192.168.30.1 192.168.30.255
link link2 /dev/udp - udp 50001 - 192.168.31.1 192.168.31.255
 
So if you actually put in your broadcast so ran:
lltconfig -l -t eth0 -d eth0 -b udp -I 10.92.5.134 -B 10.92.5.255
 
then I suspect it won't work as broacast won't cross routers and by using an IP in place of broadcast address, probably means your config is not supported.
 
Mike
 
 

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

joagmv's picture

If i define the -B as the actual broadcast address, It doest work:

NODE0:~ # ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:14:5E:7B:08:1A  
          inet addr:10.92.5.134  Bcast:10.92.5.255  Mask:255.255.254.0
 
NODE1:~ # ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:14:5E:7A:AA:3C  
          inet addr:10.93.146.123  Bcast:10.93.147.255  Mask:255.255.254.0
 
NODE0:/etc # lltconfig -t eth0 -d eth0 -b udp -I 10.92.5.134 -B 10.92.5.255
NODE1:/etc # lltconfig -t eth0 -d eth0 -b udp -I 10.93.146.123 -B 10.93.147.255
 
NODE0:/etc # lltstat -nvv | head
LLT node information:
    Node                 State    Link  Status  Address
   * 0 NODE0         OPEN    
                                  eth2   UP      00:10:18:0B:7E:12
                                  eth3   UP      00:10:18:0B:7E:13
                                  eth0   UP      10.92.5.134
     1 NODE1         OPEN    
                                  eth2   UP      00:0E:0C:BA:3E:AE
                                  eth3   UP      00:0E:0C:BA:41:96
                                  eth0   DOWN    
 
NODE1:/etc # lltstat -nvv | head
LLT node information:
    Node                 State    Link  Status  Address
     0 NODE0         OPEN    
                                  eth2   UP      00:10:18:0B:7E:12
                                  eth3   UP      00:10:18:0B:7E:13
                                  eth0   DOWN    
   * 1 NODE1         OPEN    
                                  eth2   UP      00:0E:0C:BA:3E:AE
                                  eth3   UP      00:0E:0C:BA:41:96
                                  eth0   UP      10.93.146.123
 
BUT, if I define the broadcast as the other IP, it works:
 
NODE0:/etc # lltconfig -u eth0
NODE0:/etc # lltconfig -t eth0 -d eth0 -b udp -I 10.92.5.134 -B 10.93.146.123
 
NODE1:~ # lltconfig -u eth0
NODE1:~ # lltconfig -l -t eth0 -d eth0 -b udp -I 10.93.146.123 -B 10.92.5.134
 
NODE0:~ # lltstat -nvv | head
LLT node information:
    Node                 State    Link  Status  Address
   * 0 NODE0         OPEN    
                                  eth2   UP      00:10:18:0B:7E:12
                                  eth3   UP      00:10:18:0B:7E:13
                                  eth0   UP      10.92.5.134
     1 NODE1         OPEN    
                                  eth2   UP      00:0E:0C:BA:3E:AE
                                  eth3   UP      00:0E:0C:BA:41:96
                                  eth0   UP      10.93.146.123
 
So... my doubt is about taking off the low-priority interface (we do not eant to pass the others LLT interfaces to UDP or just leaving the config that (mixing llt and udp with the broadcast trick...
 
Regards,
Joaquín