Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Ops Center 7.5 - Installation problem - Cannot open Web Console

Created: 24 Aug 2012 • Updated: 30 Aug 2012 | 5 comments
This issue has been solved. See solution.

I have installed Netbackup Ops Center 7.5 but I am unable to get to the console.  I click the WebUI Login link and a browser opens to https://SERVERNAME:8443/opscenter and displays the following message, "Internet Explorer cannot display the webpage".  I looked at the Windows services and noticed the Symantec OpsCenter WebServer Service is set to automatic but not started.  I tried to start it but it stops right away.  Has anyone else experienced this issue? 

Comments 5 CommentsJump to latest comment

Ramazan Cakir's picture

did you check this logs under C:\Program Files\Symantec\OpsCenter\gui\webserver\logs ?

Netbackup Admin Guy's picture

I checked the log and there are a couple errors.  I have bolded them below. Any ideas, I am stuck at this point?

Aug 28, 2012 9:26:04 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\PROGRA~1\Symantec\OPSCEN~1\server\jre\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\PROGRA~1\DISKEE~1\DISKEE~1\;INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: D:\Symantec\OPSCEN~1\server\jre\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\PROGRA~1\DISKEE~1\DISKEE~1\;C:\Program Files\Java\jre7\bin;;.
Aug 28, 2012 9:26:04 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-80
Aug 28, 2012 9:26:06 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-443
Aug 28, 2012 9:26:06 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 3777 ms
Aug 28, 2012 9:26:06 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Aug 28, 2012 9:26:06 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.33
Aug 28, 2012 9:26:07 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive opscenter.war
Aug 28, 2012 9:26:57 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
Aug 28, 2012 9:26:57 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-80
Aug 28, 2012 9:26:57 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-443
Aug 28, 2012 9:26:58 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Aug 28, 2012 9:26:58 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/31  config=null
Aug 28, 2012 9:26:58 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 51570 ms
Aug 28, 2012 9:57:41 AM org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context []
Aug 28, 2012 9:57:41 AM org.apache.catalina.loader.WebappClassLoader clearReferencesRmiTargets
INFO: Failed to find class sun.rmi.transport.Target to clear context class loader for web application []. This is expected on non-Sun JVMs.
java.lang.ClassNotFoundException: sun.rmi.transport.Target
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.apache.catalina.loader.WebappClassLoader.clearReferencesRmiTargets(WebappClassLoader.java:2539)
    at org.apache.catalina.loader.WebappClassLoader.clearReferences(WebappClassLoader.java:1924)
    at org.apache.catalina.loader.WebappClassLoader.stop(WebappClassLoader.java:1833)
    at org.apache.catalina.loader.WebappLoader.stop(WebappLoader.java:740)
    at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4920)
    at org.apache.catalina.core.ContainerBase.removeChild(ContainerBase.java:936)
    at org.apache.catalina.startup.HostConfig.checkResources(HostConfig.java:1212)
    at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1382)
    at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:306)
    at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
    at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1389)
    at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1653)
    at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1662)
    at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1642)
    at java.lang.Thread.run(Unknown Source)
Aug 28, 2012 9:58:05 AM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection refused: connect

    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(Unknown Source)
    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.<init>(Unknown Source)
    at java.net.Socket.<init>(Unknown Source)
    at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:422)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:338)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:416)

Netbackup Admin Guy's picture

so there are no ops center experts out there?  i guess i better call netbackup support.

Netbackup Admin Guy's picture

I deleted the VM and tried from scratch and this time got further, the webserver service actually stays started.  The only difference is I realized I didn't setup a paging file when creating the last test server.  This time I created a paging file, must be required for the webserver service or apache.  Now I get a status 404 /opscetner error when trying to open the console. I will close this thread and open a new one with the new problem.

SOLUTION