Video Screencast Help

Ops Center not emailing new reports

Created: 24 Apr 2013 | 8 comments

Had this problem a couple months back and it randomly fixed itself.  Unfortunately that hasn't happened this time.

Created new scheduled reports with new time schedules.  The reports are set to export and email.  The export works, the email doesn't.  The reason this is particularly vexing is that I have other scheduled reports that work just fine.  New reports are set up just like the working ones.

I have created mutiple time and report schedules, tried sending it to different email addresses, rebooted the server, restarted the services, nothing works.

Operating Systems:

Comments 8 CommentsJump to latest comment

Dyneshia's picture

What anti virus do you have installed ?   I have seen this once before where the antivuirs though the blat.exe was a virus and therefore quarantined it, resulting in no more emails.

If you are using anything other than Symantec endpoint protection, you may have add an exception for the <install_path>\VERITAS\NetBackup\bin directory or you can specify the file.

HankHill's picture

No AV installed on the Ops Center server.  And would be SEP if anything were installed.

HankHill's picture

If no emails were going out at all, that might apply.  However I do have some working schedules.

Also, one of the new reports suddenly worked when I sent it to a different email address, which wasn't working before.  Still not working when I send it to my email address when I add from reciepients, even though I deleted my recipient and re-created it.  The email that worked was also added from the recipient list so I don't think the list is corrupt.

Dyneshia's picture

We may need to take a look at the Opscetner log.

The OpsCener Server Logs are located under : ./installpath/OpsCenter/Server/logs/

The product id is 148.  Here is an example: 58330-148-1108492810-111130-0000001030.log

Could you upload a recent one ?

Dyneshia's picture

Quick question , what version of NBU are you running ?

From your log : 

1) You are getting a Error 25 cannot connect on socket when collecting policy data

us-bak-01.shl.prod getVirtualMachines failed - com.Symantec.v70.NetBackup.SL.NBSLOpException:
DefaultExceptionHandler handleException Exception - com.Symantec.v70.NetBackup.SL.NBSLOpException
DefaultExceptionHandler handleException NBSLOpException message : ErrorCode - 25 : cannot connect on socket

VirtualMachineCollector us-bak-01.shl.prod sync failed  - com.symantec.nbu.nom.scl.common.agent.exception.AgentException: ErrorCode - 25 : cannot connect on socket ()    at com.symantec.nbu.nom.scl.common.agent.exception.DefaultExceptionHandler.handleException
 

Please review : http://www.symantec.com/docs/TECH144010

2) "Agent is in DISCONNECTED state" errors reportedwhen collecting Scheduled Jobs data :

ScheduleJobCollector us-bak-01.shl.prod initialSync failed  - com.symantec.nbu.nom.scl.common.agent.exception.AgentNotConnectedException: Agent is in DISCONNECTED state    at com.symantec.nbu.nom.scl.common.agent.AgentContext.getAgent
PullCollectorContext<ScheduleJobCollector> us-bak-01.shl.prod pull failed  - com.symantec.nbu.nom.scl.common.agent.exception.AgentNotConnectedException: Agent is in DISCONNECTED state
us-bak-01.shl.prod state change : INITIAL_SYNC -> STOPPED

Note : Agent is not connected as it could be down or there could be a network issue. If after resolving the above error code 25 does not resolve this issue, try disabling and re-enabling the data collection. If still unable to resolve this issue, you may want to open a ticket with support.

HankHill's picture

Email problem was resolved.  Apparently there was a problem with the user id set up for the email system.  Why this only broke the new emails and not all the emails, I don't know.