Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

OpsCenter Analytics in Sun Cluster

Created: 18 Sep 2013 • Updated: 20 Sep 2013 | 6 comments
This issue has been solved. See solution.

Hi

I think I've an easy question but it's a little tricky because it's a very particular scenario.

I've just upgraded OpsCenter Analytics to 7.5.0.6 version in Solaris x86. Everything works ok. I installed OpsCenter in one of the nodes of a Sun Cluster where Netbackup is running. There're two nodes for HA. When resource Group is running in the node where OpsCenter is installed it works ok, there is an integrated agent, but when I switch RG to the other node, in "Settings-Configuration-Netbackup" I see there is not connected.

I set "Master Server name" as the logical name in Sun Cluster of the resource but I don't know if it's mandatory to install an agent in the node where OpsCenter is not installed.

By the way I can't find a link where I can download Agents of OpsCenter.

 

Thanks for your help

Operating Systems:
Discussion Filed Under:

Comments 6 CommentsJump to latest comment

Koven1's picture

I've been looking for Opscenter Agents for Solaris x86 but I think there is no agent, only windows and Sparc. Is this true?

tom_sprouse's picture

Koven,

Not to be a bearer of bad news... but the OpsCenter Agent is not supported on Solaris x86

pg 73 - NBU 7.x Compatibility Guidehttp://www.symantec.com/docs/TECH76648

In addition, OpsCenter is only supported on the following:

■ Windows 2008 R2 x64

■ Windows 2008 x86 and x64

■ Windows 2003 x86 and x64

■ Solaris SPARC 10

In addition, you must also use VCS / "Veritas Cluster Server"... 

pg 193 - 7.5 OpsCenter Admin Guide :  http://www.symantec.com/docs/DOC5042

 

If you have any questions, please let me know.

-Tom

 

 

 

 

 

Note: If this post provides you with a solution don't forget to mark the discussion as solved...

 

Koven1's picture

Tom

So what do you think is the best alternative for me.

The scenario is like this

Two nodes with Sun Cluster. Only one Resource Group for Netbackup. OpsCenter Analytics running in one of the nodes. I see an "integrated agent" and I've configured logical hostname to collect data.

If I switch Resource Group to node that has not Opscenter installed then it's not working.

Thanks for your help.

tom_sprouse's picture

Koven1,

Are you running this in a VM? Is the Solaris host running any applications other then OpsCenter?

If so, I would spin up a new VM or move OpsCenter to a stand-alone Solaris x86 server, or even better would be a Windows x64 box. 

OpsCenter was optimized for Windows x64 and you can then also utilize the Windows host to be the Agent Server as well.

You will not be able to take advantage of OpsCenter clustering with your current configuration because the host is Solaris x86.

You need a Solaris 10 SPARC with VCS as your cluster services....

 Please refer to pg 209 in the OpsCenter 7.5 Admin Guide - http://www.symantec.com/docs/DOC5042

for additional information on Prerequisites for Clustering OpsCenter on Solaris 10 SPARC

--Tom

 

Note: If this post provides you with a solution don't forget to mark the discussion as solved...

 

SOLUTION
Koven1's picture

Thanks for your help I'll take this as a recommendation. By the way,do you know if Licensing of OpsCenter Analytics for Solaris x86 can be used in any Windows Server flavour.

I marked your answer as solution.  smiley

 

tom_sprouse's picture

Koven1, 

Yes, your OC-Analytics Key will work across platforms...

--Tom

 

Note: If this post provides you with a solution don't forget to mark the discussion as solved...