Video Screencast Help

OptiPlex 7010 NIC issues

Created: 02 Oct 2013 | 7 comments

I'm trying to set up a bunch of Dell OptiPlex 7010 desktops, and here's what's going on:

- I downloaded the correct NIC driver from Dell's website. If I boot off a Ghost CD and drvload NNGMH\E1C\VISTA-x86\E1c6032.inf, I can successfully resolve DHCP.

- I use the Ghost Boot Wizard to create a Console Boot Partition with this exact same driver.

- Booting to the Virtual Partition fails because drivers could not be found in the PreOS for the NIC and an AHCI device.

- I add the AHCI device to pci.mainfest.txt ({ 0x8086 = { 0x1e02 = () } }), and now I can't boot to the Virtual Partition only because the NIC driver couldn't be found in the PreOS.

- If I add the NIC driver to pci.manifest.txt ({ 0x8086 = { 0x1502 = () } }), the virtual partition boots, however, I get an infinite loop of "polling for bound server...", indicating there's no network connectivity.

The NIC is an Intel 82579LM, which, according to the Googles, is a nightmare.

Any thoughts?

Thanks!

Operating Systems:

Comments 7 CommentsJump to latest comment

Maneesh's picture

If you are using console to image clients,the NIC drivers should be added to WINPE template through Boot Wizard and the same template should be selected under Client machine Properties->Client tab on the console.

Adding the PCI info to PCI manifest file can cheat the system to assume that the drivers are already there but in the end imaging does not work as the drivers are not there .

If you believe that you had added the correct Vista 32 drivers,make sure that the template is selected for the client to use.

The above .inf file is correct for the dev_1502.Add it to WINPE following the steps in the article,

How to add drivers to DeployAnywhere or WinPE.
http://www.symantec.com/docs/TECH110136

mahohmei's picture

I've already folowed those instructions; still doesn't work.

EdT's picture

Search this forum on 82579 and download known working drivers from one of the past links provided. Not all Vista drivers for this chipset work correctly with WinPE, so it is important to use a driver that is known to work. Same applies to the AHCI driver.  If you can create a local WinPE boot device such as a CD or USB stick you can manually test both network connectivity and disk accessibility.

Once you are sure you have the correct drivers, you can use Ghost Boot Wizard to build your pre-OS WinPE image.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

mahohmei's picture

That's where it gets funny. I have the correct driver, and I can boot from a WinPE and image via GhostCast perfectly.

What I can't do is boot WinPE in the virtual partition.

EdT's picture

How exactly did you create the WinPE boot image, and did you use the WinPE-512 version or the compact version?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Terry BU's picture

The 82579LM is a nightmare.  I have written some posts on it, commented on others, and EdT is right that it was a hot topic for quite some time.

 

Dumb question, but you definitely checked the box to add that driver after you added it to the list in the WinPE builder?  I ask since if the console is telling you the driver is missing in the failure info for the "To Virtual Partition" step, then it does not have what it wants

Maneesh's picture

Are you getting the "polling for bound server error" with Console method?If so what is IP address with which its polling?If it is 127.0.0.1 its for sure the drivers are missing?If you see 169.254.x.x,add the ipconfig renew command in the batch file ,under the following localtion,

Doc&settings\All Users\App.Data\Symantec\Ghost\Template\Common\"Winpe template name"\Ghost\Start.bat

or

Program Data\Symantec\Ghost\Template\Common\"Winpe template name"\Ghost\Start.bat

Note:After the line cd \ghost