Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Oracle Backup failed

Created: 29 May 2012 | 5 comments

we have backup exec 2010 agent for oracle,

when we are doing a bakup for the oracle database its giving the follwoing error :

The Database script returned an error.  Refer to the Database script output section in job logs for more details.

this error come before the RMAN logs and there is no error in the RMAN ,

looking for support ,

 

Comments 5 CommentsJump to latest comment

Sush...'s picture

Please refer to the following technotes:

http://www.symantec.com/docs/TECH72297 : Oracle backups fail with error 0xe0000340 - The Database script returned an error. Refer to the Database script output section in job logs for more details. ORA-09925: Unable to create audit trail file

http://www.symantec.com/docs/TECH66307 : Backup of Oracle RAC (Real Application Cluster) database(s) fails with the error "The Database script returned an error. Refer to the Database script output section in job logs for more details".

http://www.symantec.com/docs/TECH59661 : Backup of the Oracle server fails with "database script returned an error" and RMAN output section of job log shows "ORA-27211: Failed to load Media Management Library"

Thanks,

-Sush...

Hope this piece of Information Helps you... and if it does then mark this response as Solution....!!!

mohamadbahra's picture

Sush,

thanks for your reply,

but all of these links pointing to error codes and errors in RMAN logs,

but in my case the error appear without error code or without any RMAN errors,

Sush...'s picture

Then I suppose this would require some detail troubleshooting. Try to re-configure the Remote Agent for Oracle backups. If that does not help then I would suggest you to open a case with Symantec if you have a Support contract with Symantec.

Thanks,

-Sush...

Hope this piece of Information Helps you... and if it does then mark this response as Solution....!!!

Lilavati's picture

Asking for logs and more information about the error.

once I receive the logs, I will update this thread

Thanks,

Lilavati

Lilavati's picture

The logs that you sent me does not have sgmon log of remote machine (i.e. Oracle Server ) it is empty.

I checked your job log and from job log it seems that your backup job is completed successfully.

Can you please try one thing, open restore view and check if backup set is available or not for that particular backup job?

If yes, is it possible you to restore that backup set on another test machine, you can use redirect restore for restoring database on another machine steps are mentioned in the admin guide.

This is just to make sure that data is proper or not.

You can open the support case for this issue.