Video Screencast Help

Oracle Database installer is crashing

Created: 10 Mar 2014 • Updated: 17 Mar 2014 | 12 comments

Hi

I'm running the Oracle_11.2.0.3.0_Server_Win64_1of2.zip & Oracle_11.2.0.3.0_Server_Win64_2of2.zip Symantec Oarcle installation setup.exe and it keeps crashing.

I have turn off UAC, removed AV installed the latest version of JAVA and nothing has worked.

The error message says "Application - java.lang.nullpointerexception".

Can anyone help?

Regards,

Daniel

Operating Systems:

Comments 12 CommentsJump to latest comment

Stu Munro's picture

oates,

 

i am guessing your have not extracted all the zip files properly, you need to extract zip inside the zip and compile 1of 2 and 2 of 2 into i file for installation. From what i rememebr this is not covered in the manual, let me know if you need more help send me a message.

oates-lee's picture

I've extracted both zip files (inside the zip files) in to the same directory called database; as described in the "Symantec DLP 12.0 Oracle 11g Installation and Upgrade guide".

The database folder is 2.34 GB with 2,751 files and 908 folders.

When i then run the setup.exe it passes the basic checks and crashes with the JAVA error.

Are there any software pre-requisites?

stumunro's picture

Can you attach a screen shot?

oates-lee's picture

And this is the screen before the error ... Just uploaded in the wrong order

Capture.PNG
stumunro's picture

this is not running as a virtual machine correct? the error refers to something in the installer it cant reference/find.

 

 

oates-lee's picture

It on a VMware ESXi server, but its a full Windows 2008 R2 standard edition installation. 

 

Its on a VM as its a POC lab.

stumunro's picture

ok this might be the issue the error you have reference memory, Oracle is not offically supported in VM.

Network Monitor and Oracle are supported under physical HW only.

What HW specs do you have assigned to the oracle server

oates-lee's picture

Windows 2008 R2 template.

2x CPU

6GB RAM

40Gb - OS

500GB - Data

I don't have server capaciaty for dedicated kit was everything else is virtualised ... It might have been a little short sighted of Symantec to pick a database vender who only runs on physical servers.

stumunro's picture

Actully this goes back to the vontu days, its not a symc thing.

also when you are installing are you referencing M drive for the oracle partition, and are you running this on a single tier. Is this a lab enviroment or production. If you call symc support they have the option of not helping as symc recomendations where not followed.

DLP Solutions's picture

Oates,

The issue is that you are trying to run the installer in a Windows style folder that is also too deep.

Move the installer files to a top level directory WITH no spaces. (c:\oracleinsatll)

Oracel does not like being too deep in a folder and alos does not like spaces or long names of directories.

Then run the program..

Hope this makes sense.

If this solves your questions please marked as solved.

Ronak

Please make sure to mark this as a solution

to your problem, when possible.

 

oates-lee's picture

Hi All,

I found the answer ... It was to do with the VMware memory.

Basically you need to reserve the full amount of memory for the VM, by doing the following:

Procedure
1      In the vSphere Client, right-click a virtual machine from the inventory and select Edit Settings.
2       In the Virtual Machine Properties window, select the Resources tab and select Memory.
3      In the Resource Allocation panel, select the Reserve all guest memory (All locked) check box.
4      Click OK.

http://pubs.vmware.com/vsphere-50/index.jsp?topic=...

Doing the above will allow you to run Oracle on a VM for test/development purposes.

Daniel