Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Oracle RAC and Backup Exec 2012 R14

Created: 20 Nov 2012 • Updated: 21 Nov 2012 | 5 comments

Hi,

 

I've been trying to configure an Oracle RAC (3 nodes) running on RHEL 6.3 (64bit), with Backup Exec 2012, the media server running on W2008 R2 server. I've tried to follow the instructions posted by Lilavati, but I'm not seeing the same results. The linux-side configuration seems to go ok (and, as far as I can tell, the correct 64bit version of the agent is installed), with the exception being that I'm not prompted for this question:

Do you want to use the full computer name/IP address for Oracle operations? (Y/N): 

and the FQDN line does not appear in the summary when I go to view the entry.

I'm using the local root account (which is not a member of the Oracle admin grp) for database access, and the sys account for the Oracle instance access.

For  /etc/VRTSralus/beoratab, each node has:

 

+ASM1:/opt/app/11.2.0.3/grid:N

<ORACLE_SID>:/opt/app/oracle/product/11.2.0.3/dbhome_1:N
 
where ORACLE_SID is the db name + node number (eg. oracle1, oracle2, oracle3).
 
The sys authentication, and media server address part also goes without a hitch.
 
However, then going on the console is where I get confused: the interface I'm presented with doesn't resembe anything Lilavati describes, or, indeed any of the other few howto's I've been able to find - I assume the GUI has gone through several radical alterations (although Lilavati seems to be talking about a CLI console which I wasn't able to find - linux only?)? There's certainly no "Tools" menu mentioned by several people.
Are there any detailed instructions on how to configure the R14 console to look at the agents?
i) Going from the main button>Configuration and Settings>Backup Exec Settings, there is an Oracle section - what do I put in here?
ii) Am I supposed to manually set up each physical node in Backup and Restore, or just the cluster name, or both? Several articles mention something magically appearing in a separate Oracle Real Application Clusters section - where is this?!
 
I've tried setting up both the nodes and the cluster, and I can get the root account to successfully authenticate on the nodes, but nothing else appears. The cluster address just fails, no matter which account.
 
I can normally find something useful on some forum, but there seems to be nothing that clearly shows how to configure the console after the agent setup with this particular release.
 
Any help appreciated!

Comments 5 CommentsJump to latest comment

pkh's picture

RHEL 6.3 is not supported.  See the SCL below

BE 2012 SCL

skein's picture

I saw that list, but since I'm trying to backup the RAC, not the servers underneath it, is this relevant? I've never used Backup Exec before, but the agents certainly seem to be running ok (the three servers *are* being picked up in the console). My issue is with configuring the Oracle db - am I going about it the right way? Or is the lack of support for 6.3 the reason I'm not seeing the cluster? Is there any other way to back-up the databases (RMAN)?

Also can't seem to get the GRT working on vSphere5 windows vm's when backing up the whole ESX server, as it refuses to authenticate with vm (despite using the vSphere root account, which has no problem with the linux vms!).

 

Many thanks for your help.

pkh's picture

You need to install the RALUS to backup anything on the LINUX server.  If the RALUS cannot be installed properly then you cannot do any backup.  You are using an unsupported variant, hence your problems.  By unsupported, it means that it has not been fully tested by Symantec.

skein's picture

Thanks for taking the time to answer.

I've raised a case to find out if there are any technical changes between 6.2 and 6.3 that would affect the agent, or whether it is merely untested.

Since the console seems to have no problem talking to the RALUS agent, the agent install and authentication went ok (with the FQDN proviso) and the agent seems to be talking to the db, I have a feeling I'm not setting up the console correctly (Lilavati's instructions at this point depart from anything resembling the BE 2012 Windows GUI, so I'm assuming he's talking about a Linux version). Having searched around a fair bit, most of the posts regarding Oracle seem to be about version 2010, which also seems markedly different from 2012, and so again are unhelpful in setting up the console. I have seen quite a lot of posts (unrelated to Oracle) which seem to require FQDNs to be used for hosts, and/or properly set-up domains, and/or passwords needed for certain features to be the default system password, etc, so I do get the impression that there are still a few things to iron out (the sheer volume of posts and replies in this forum, compared to any of the others is also an indicator!).  

I am unsure whether the issue is a technical change from 6.2 to 6.3, the buginess/fussiness of 2012 in not doing what it should, or (more probably) my ignorance. Are there any howtos/idiot guides like Lilavati's for setting up Oracle RAC on 6.2 (ie. supported) and BE 2012 console? That would at least give me a starting point to find out why I can't get it working in our environment. I find the manual garrulous and pedantic in describing every tiny part of the menu, and yet completely unhelpful in actually describing the overall workflow/configuration for setting-up a real-life system (eg. an example run through configuring a RAC system).

I appreciate you're a volunteer, and am very grateful for your help!

skein's picture

Bump!

Anyone have a link to a guide for setting up Oracle RAC 11g2 on RHEL 6.2, with Backup Exec 2012?

 

Any help appreciated.