Video Screencast Help

Outlook Blue Screen - Integrated Search Vault

Created: 17 Dec 2012 • Updated: 02 Jan 2013 | 8 comments
AKL's picture

Hello All

I am here with a very "noob" like question or issue. We're using Enterprise vault 9.0.1 server, Outlook 2007 SP2 client and Enterprise vault 10.0.1 client in this case. (Hotfix for EV10 client installed on EV9 server)

Recently we noticed that when user clicks on search vault, Outlook turns into a complete blue screen with exception of navigation pane i.e the reading pane where integrated search vault page should show, appears complete blue.

Then when user tries to get back to one of folders, he/she get attached error (screen-shot)

There's no error in trace logs. I've read about this issue once and resolved using that same technote or forum but to my bad luck I didn't made note of it and now I cannot find it anywhere. I am hoping smoeone has seen this and can provide quick answer if any please or direction to look into?

ResetEVClient.exe has been tried along with re-registering ole32.dll, vbscript.dll, jscript.dll


Operating System            Microsoft Windows XP Professional Service Pack 3 (build 2600)

Outlook                Microsoft Outlook 2007 (

Internet Explorer             8.0.6001.18702

Enterprise Vault Add-in (Full functionality enabled)

VBScript component (Outlvbs.dll)            Available               


User Mailbox     Property unavailable in an offline store

Outlook connection state             Cached connected full (8)

RPC over HTTP flags        0             


HTTP connection OK       http://EVServer/EnterpriseVault (Status: 0x12)

The trace logs show below lines including local file redirect

7/12/2012 18:50:58.741[1536][M]:     Using search URL: http://EVServer/EnterpriseVault/searcho2k.asp?server=Exchange01&
17/12/2012 18:50:58.741[1536][L]: DesktopCommon::IsCustomLoginMessageRequired: 0x0
17/12/2012 18:50:58.741[1536][L]: DesktopCommonConfig::GetSetting: 0x0
17/12/2012 18:50:58.741[1536][L]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.742[1536][L]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.742[1536][M]:     Desktop Setting: CUSTOMLOGINMESSAGE
17/12/2012 18:50:58.742[1536][M]:     No Value
17/12/2012 18:50:58.742[1536][L]: ~DesktopCommonConfig::GetSetting: 0x1
17/12/2012 18:50:58.742[1536][L]: ~DesktopCommon::IsCustomLoginMessageRequired: 0x0
17/12/2012 18:50:58.742[1536][L]: CDesktopUI::InSearch: 0x0
17/12/2012 18:50:58.743[1536][L]: DesktopCommonConfig::GetConfigValue: 0x0
17/12/2012 18:50:58.743[1536][L]: DesktopCommonConfig::GetSetting: 0x0
17/12/2012 18:50:58.743[1536][L]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.743[1536][L]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.743[1536][M]:     Desktop Setting: RESTRICTPOLICYLOOKUP
17/12/2012 18:50:58.744[1536][M]:     No Value
17/12/2012 18:50:58.744[1536][L]: ~DesktopCommonConfig::GetSetting: 0x1
17/12/2012 18:50:58.744[1536][L]: DesktopCommonConfig::GetSetting: 0x0
17/12/2012 18:50:58.744[1536][L]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.744[1536][L]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.745[1536][M]:     Desktop Setting: CreateTempFolderForWebApps
17/12/2012 18:50:58.745[1536][M]:     No Value
17/12/2012 18:50:58.745[1536][L]: ~DesktopCommonConfig::GetSetting: 0x1
17/12/2012 18:50:58.745[1536][M]:  CreateTempFolderForWebApps = 0 [default]
17/12/2012 18:50:58.745[1536][L]: ~DesktopCommonConfig::GetConfigValue: 0x1
17/12/2012 18:50:58.745[1536][M]: get_HTMLDocument: 0x8A47000E
17/12/2012 18:50:58.745[1536][L]: ~CDesktopUI::InSearch: 0x8A47000E
17/12/2012 18:50:58.746[1536][L]: CDesktopUI::RememberFolder: 0x0
17/12/2012 18:50:58.746[1536][L]: ~CDesktopUI::RememberFolder: 0x0
17/12/2012 18:50:58.746[1536][L]: CDesktopUI::GotoSearchFolder: 0x0
17/12/2012 18:50:58.746[1536][L]: DesktopCommonConfig::GetConfigValue: 0x0
17/12/2012 18:50:58.746[1536][L]: DesktopCommonConfig::GetSetting: 0x0
17/12/2012 18:50:58.746[1536][L]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.747[1536][L]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.747[1536][M]:     Desktop Setting: RESTRICTPOLICYLOOKUP
17/12/2012 18:50:58.747[1536][M]:     No Value
17/12/2012 18:50:58.747[1536][L]: ~DesktopCommonConfig::GetSetting: 0x1
17/12/2012 18:50:58.747[1536][L]: DesktopCommonConfig::GetSetting: 0x0
17/12/2012 18:50:58.748[1536][L]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.748[1536][L]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
17/12/2012 18:50:58.748[1536][M]:     Desktop Setting: CreateTempFolderForWebApps
17/12/2012 18:50:58.748[1536][M]:     No Value
17/12/2012 18:50:58.748[1536][L]: ~DesktopCommonConfig::GetSetting: 0x1
17/12/2012 18:50:58.748[1536][M]:  CreateTempFolderForWebApps = 0 [default]
17/12/2012 18:50:58.749[1536][L]: ~DesktopCommonConfig::GetConfigValue: 0x1
17/12/2012 18:50:58.749[1536][L]: ::IsInetOffline
17/12/2012 18:50:58.749[1536][L]: ~::IsInetOffline
17/12/2012 18:50:58.749[1536][L]: CDesktopUI::DisplaySearchURL: 0x0
17/12/2012 18:50:58.749[1536][M]: pCmdBars->Count = 24
17/12/2012 18:50:59.013[1536][M]: Our control was created
17/12/2012 18:50:59.013[1536][L]: CreateSearchURL: 0x0
17/12/2012 18:50:59.013[1536][L]: CreateRedirectFile: 0x0
17/12/2012 18:50:59.013[1536][M]: Creating redirect file: C:\DOCUME~1\dduck\LOCALS~1\Temp\EVWebViewRedirect.htm
17/12/2012 18:50:59.020[1536][L]: ~CreateRedirectFile: 0x0
17/12/2012 18:50:59.020[1536][M]: Using local file redirect: file:///C:/DOCUME~1/dduck/LOCALS~1/Temp/EVWebViewRedirect.htm
17/12/2012 18:50:59.020[1536][L]: ~CreateSearchURL: 0x0
17/12/2012 18:50:59.051[1536][M]: get_Text: [file:///C:/DOCUME~1/jdduck/LOCALS~1/Temp/EVWebViewRedirect.htm]
17/12/2012 18:50:59.051[1536][L]: ~CDesktopUI::DisplaySearchURL: 0x0
17/12/2012 18:50:59.051[1536][L]: ::IsInetOffline
17/12/2012 18:50:59.051[1536][L]: ~::IsInetOffline
17/12/2012 18:50:59.051[1536][M]: Network connectivity state before '0' and after '0' folder switch
17/12/2012 18:50:59.052[1536][L]: ~CDesktopUI::GotoSearchFolder: 0x0
17/12/2012 18:50:59.052[1536][L]: ~ActionWebCommon::DoSearch: 0x0
17/12/2012 18:50:59.052[1536][L]: ~ActionWebSearch<class ECETraits>::OnAction: 0x0
17/12/2012 18:50:59.052[1536][L]: ~Action<class ActionWebSearch<class ECETraits>,class ECETraits,1>::operator ()

Comments 8 CommentsJump to latest comment

Rob.Wilcox's picture

Every user?  All the time?  Every time?

What happens if a user goes to the URL mentioned above (to searcho2k.asp) in Internet Explorer?

AKL's picture

Nope, just few users - Mostly Outlook 2007 SP2. EV Client is mixed, EV9.0.1 (HTTP) and EV10.0.1

Direct URL works fine, sorry should've mentioned that with original post. They get the search vault page over Internet explorer

Thank You


Rob.Wilcox's picture

Have you got a screenshot of what it looks like 'in action' ?

AKL's picture

Sorry, I "had" it but didn't save a copy it seems. I'll try to get one tomorrow first thing from user's machine.

I cannot replicate it from backend so it is hard to get those and only few users get this issue & even fewer report it to us.

Given it only impacts locally make me think it is some Outlook dll issue, but which one is I am forgetting. New Outlook profile didn't help either.

Thank You


AKL's picture

Sorry this took so long, I've uploaded the "in action" screen-shot with original forum. (Holiday fever)

Also, I found the article I was trying to refer to:

Archive Explorer and Search Vault buttons result in a blank page in Outlook Client

I installed EV 9.0.1 HTTP client on user machine (after un-installing EV10.0.1 client) and same result. Checked the IE settings too as mentioned with technote.

Thank You


Rob.Wilcox's picture

Okay I don't think the article is relevant to the issue here. Because you're not getting a blank page as such.. you're getting some sort of error.

Is this Outlook 2007 SP 3?  Sorry, I don't recall all the .versions of Outlook.

How does the user get to this type of issue?  Do they go in to search, then click on Archive Explorer (without going back to Outlook) for example?

AKL's picture

It's office 2007 SP2

Below is how user gets to error:

  1. User clicks on Search Archive button in Outlook.
  2. Since desktop policy is configured to open search archive within Outlook, Outlook tries to load the search page within Outlook.
  3. User gets blue screen (as per screen shot)
  4. Then user tries to go back to main inbox or any other folder.
  5. Then he/she gets the prompt in bottom right about Object level issue.
  6. User closes and re-opens Outlook to come out of blue screen.

Archive explorer works fine, since it is configured to run on IE. Same for search archive link directly accessed via IE.

Just the integrated Outlook thing is issue.

I fixed similar white screen issue mentioned in article on my Outlook 2010 few months back, so thought it would've been related.

Thank You


Rob.Wilcox's picture

Very odd.

Can you perhaps see if the same happens with Outlook and AE integrated?

Can you try Outlook 2007 SP 3?

For a 'problem user', if they login to a different PC does the problem follow them?