Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Outlook2010/EV9/Citrix

Created: 06 Sep 2012 • Updated: 15 Nov 2012 | 10 comments
GertjanA's picture
This issue has been solved. See solution.

Hello all,

I am struggling with an issue with EV-client on Citrix. The Citrix setup is not completely known to me, but additional information I can get my hands on.

The citrix server is W2008R2, the applications are published. What is published is only Office (2010, Excel, Word, Powerpoint and Outlook), and Adobe Reader. Not Internet Explorer, IE is installed on the system. The EV-client is 9.0.3.1221

The plug-in is installed properly. When opening an archived item, I get prompted for a username and password. When entering, the item is opened fine.

The problem I have I need a solution for is that if in the Enterprise Vault tab I click on Archive Explorer or the Search Vaults button, I get a blank page.

When I create in the inbox a folder, and set the homepage for that folder to the Archive Explorer ui, I get the archive explorer, same for the search-page.

The homepage = https://ev014.europe.intranet/enterprisevault/archiveexplorerui.asp

Attached a client-logfile.

The Citrix Admin has entered the aliasses and hostnames in the trusted sites on the citrix-server for the users.

Does anyone have an idea what can be done/checked/tried to get the Archive Explorer and Search Safe page working. The password prompt we will work on later.

Thanks in advance.

Comments 10 CommentsJump to latest comment

GertjanA's picture

Additional Info:

Citrix Admin has unchecked in IE8

==> Check for server Certificate Revocation

==> Check for Publishers Certificate Revocation

Now it works (for him). Testing..

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

Rob.Wilcox's picture

Worth remembering that when you click on Search or AE on the toolbar the following link is constructed...

06/09/2012 07:55:55.677[91140][M]:     Archive Explorer URL: https://EV014.europe.intranet/EnterpriseVault/ArchiveExplorerUI.asp?server=VPNLCMS92061&mbx=SMTP:Gertjan.Alink@ing.nl&outlook=14

And then a 'redirect' file is created:

06/09/2012 07:55:55.768[91140][M]: Creating redirect file: C:\Users\M06J979\AppData\Local\Temp\6\EVAEViewRedirect.htm
06/09/2012 07:55:55.774[91140][L]: ~CreateRedirectFile: 0x0
06/09/2012 07:55:55.775[91140][M]: Using local file redirect: file:///C:/Users/M06J979/AppData/Local/Temp/6/EVAE...
06/09/2012 07:55:55.775[91140][L]: ~CreateSearchURL: 0x0
06/09/2012 07:55:55.783[91140][M]: get_Text: [file:///C:/Users/M06J979/AppData/Local/Temp/6/EVAEViewRedirect.htm]
06/09/2012 07:55:55.784[91140][L]: ~CDesktopUI::DisplaySearchURL: 0x0

Maybe that file then isn't being picked up, or something.

GertjanA's picture

Hello Rob,

Further information from the Citrix Engineer might prove the above is the issue.

He states that if he logs on using his 'admin account', then create an Outlook profile that uses his 'normal' account, AE and Search Archive work fine. When he logs on to Citrix using his normal account, the open Outlook, it does not work. IMHO this indicates that the functionality is there, but the normal account is missing some permissions (or settings)

We're investigating further.

Thanks!

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

GertjanA's picture

A new snippet from the client log: Anyone knows what 0X40380 indicates?

06/09/2012 13:35:04.264[107052][L]: ~VaultInformationUI::AddCustomAttributes: 0x40380

06/09/2012 13:35:04.264[107052][L]: ~VaultInformationUI::InsertHiddenMessageProperties: 0x0

06/09/2012 13:35:04.264[107052][L]: VaultInformationUI::InsertHiddenMessageProperties: 0x0

06/09/2012 13:35:04.299[107052][L]: VaultInformationUI::AddCustomAttributes: 0x0

06/09/2012 13:35:04.299[107052][L]: DesktopCommon::GetNamedPropList: 0x0

06/09/2012 13:35:04.303[107052][L]: ~DesktopCommon::GetNamedPropList: 0x0

06/09/2012 13:35:04.311[107052][L]: ~VaultInformationUI::AddCustomAttributes: 0x40380

06/09/2012 13:35:04.311[107052][L]: DesktopCommonConfig::GetItemsInCache: 0x0

06/09/2012 13:35:04.311[107052][L]: ~DesktopCommonConfig::GetItemsInCache: 0x0

06/09/2012 13:35:04.313[107052][L]: DesktopCommonConfig::GetItemsInCache: 0x0

06/09/2012 13:35:04.313[107052][L]: ~DesktopCommonConfig::GetItemsInCache: 0x0

06/09/2012 13:35:04.314[107052][L]: ~VaultInformationUI::InsertHiddenMessageProperties: 0x80004005

06/09/2012 13:35:04.314[107052][L]: VaultInformationUI::InsertHiddenMessageProperties: 0x0

06/09/2012 13:35:04.339[107052][L]: VaultInformationUI::AddCustomAttributes: 0x0

06/09/2012 13:35:04.339[107052][L]: DesktopCommon::GetNamedPropList: 0x0

06/09/2012 13:35:04.343[107052][L]: ~DesktopCommon::GetNamedPropList: 0x0

06/09/2012 13:35:04.351[107052][L]: ~VaultInformationUI::AddCustomAttributes: 0x40380

06/09/2012 13:35:04.352[107052][L]: ~VaultInformationUI::InsertHiddenMessageProperties: 0x0

06/09/2012 13:35:04.352[107052][L]: ~VaultInformationUI::InsertHiddenMessageInformation: 0x0

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

Rob.Wilcox's picture

Snippet isn't that much help, without some context of what you were trying to do..

However..

This isn't good .. it's a 'general error occurred'

06/09/2012 13:35:04.314[107052][L]: ~VaultInformationUI::InsertHiddenMessageProperties: 0x80004005

GertjanA's picture

Attached a new logfile. As far as I can determine, the trusted sites are not set. I still need to enter a username/password to open an archived item. When that is done, I can manually archive, restore, open item and archived attachments. When wanting to use Archive Explorer or Search Archive I get a blank screen which sits there indefinitely.

Attached logfile shows staps up to the blank screen. I asked the citrix admin to re-verify the site are in the Trusted Sites.

The action to open AE starts approximatley from 12-09-2012 13:36:11.239

If anyone has a hint...

AttachmentSize
CitrixLiteError.txt 311.48 KB

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

TonySterling's picture

Hey Gertjan,

Just curious, is this still an issue?

GertjanA's picture

Hi Tony, yes it is. I've been mailing with someone in Sym, who advised we needed to first get the latest client. I checked (duh...) and we currently have the client that has the issue with EV and SSL. I advised to install the latest client, and we'll restest.

As soon as that is done, I'll restest and post findings here.

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

GertjanA's picture

Issue Resolved. An excellent Citrix Engineer has found the solution.

On the Citrix server, a Windows 2008 R2 server, Internet Explorer Enchanced Security Configuration was set to ON. This has been set to OFF

When you then login, start Outlook, and then start Archive Explorer, you get a logon prompt.

To avoid this prompt, the URL to Archive Explorer and Search Archive have been added to a local user policy:

Admin Templates\Windows components\Internet Explorer\Internet Control Panel\Security Page: Site to Zone Assignment List Enable :

Put this to Enabled, and then add the URL for Search and Archive Explorer to it, with a value of 1.

I hope this helps anyone encountering this issue.

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

SOLUTION