Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Overwrite issue within same job on USB Flash Drive

Created: 22 Aug 2013 | 13 comments

I have USB Flash/Thumb drives for a 5-day rotation. The devices are initialised as Disk Cartridges with Media type: FLDR. They are automatically put into the media set "Backup Exec and Winodws NT Backup Media" with "Infinite - Do not overwrite" protection. They CANNOT be moved from this group - apparently this is by design in Backup Exec 2012 SP2. The Maximum file size to be just under the formatted size of the USB thumb drives. The USB thumb drives are in a storage pool called "USB Disk Pool".

I have set up a job with a recurrence each week day. Storage is the "USB Disk Pool" with a custom media set. "Eject the media after the job completes" is enabled.

If I don't set the global Configuration and Settings, Backup Exec Settings, Storage, Media overwrite protection level to NONE (don't prompt), the jobs won't write to the USB drive without first prompting (which is obvious useless in an automated backup).

These settings work with a single backup set within a backup job. However, if I wish to backup multiple drives it automatically overwrites the previous task (within the same backup job step) which is very strange behaviour. I can't think of a scenario where this would actually be useful...

So, if I wish to backup say folders on Drive E it works. But if I want to backup folders on Drive E and G and System State, the backup set for G overwrites the backup set for E which has just completed (within the same backup step).

How do I backup multiple locations (on the same server) without 1 overwriting another within the same job?

Operating Systems:

Comments 13 CommentsJump to latest comment

pkh's picture

When you set the Overwrite Protection Level to None, then any OPP setting will not apply.  You need to set your OPL to either Partial or None.

pkh's picture

If I read your problem correctly, you are saying that your backups are overwriting things when they should not.  This is because your OPL is set to None, hence there is no protection.  If you want protection, set your OPL to either Partial or Full.

Sorry there is a typo in my earlier reply, it should say "... either Partial or Full" and not "... either Partial or None"

sstrong's picture

Yes, but this leads to another issue as described above:

"If I don't set the global Configuration and Settings, Backup Exec Settings, Storage, Media overwrite protection level to NONE (don't prompt), the jobs won't write to the USB drive without first prompting (which is obvious useless in an automated backup)."

This wasn't an issue with my old tape drive, and it worked ok in Backup Exec 2010 but BE2012SP2 doesn't seem to behave with new higher capacity USB flash/thumb drives.

pkh's picture

Have you tried setting OPL to Partial and unchecking the prompt option?

What is the name of the alert that you get?

Colin Weaver's picture

Definitely DO NOT SET None as the media protection.

Also be aware that the Eject media at end of job is for things like Stand Alone tape drives and RDX cartridges which actually have an eject function, it is unlikely to trigger the correct operation against the operating system safely remove USB attached device option.

As each resource C: , D: System State etc consititues a backup set and each backup set will create a new BKF or IMG (depending on if GRT is involved) inside the USB disk, are you checking the file system inside your USB disk to see what is actually being used and then comparing the media names listed inside the job log with what you find inside the USB disk.

Note FLDR media are just container objects reperesenting the disk, however overwrite operations and the overwrite protcetion settings of the media set used by the jobs do NOT apply to the FLDR object, they apply individually to the IMG and BKF inisde the  USB drive (which is why the FLDR object cannot be moved between media sets)

sstrong's picture

Ok, still doing more testing.

BTW the Eject media actually works with the USB flash drive. It correctly signals W2K8R2 EE the USB disk is safe to remove (just like ejecting it via the Windows Server desktop interface).

Colin Weaver's picture

Thx for confirming that I was slightly unsure of the eject function and was about to setup a test, but you have just answered it for me.

sstrong's picture

With an empty USB flash drive I create a full backup job on selected folders and System State. OPL is set to Partial with no prompt. The Media Set for the job is 1 hour overwrite and 2 hours append (for testing purposes using the 1 USB drive).

Backup completed creating two backup sets (BKF files on USB drive). The USB drive was ejected so I removed it and then plugged it back in again. RDP to the server and the USB drive is visible and mounted.

After the Expiration time of both backup sets, I started the job again.

There are no alerts however the job is in the Queued state and has taken no action. Typically the jobs start backing up data shortly after the snapshot (1-2 minutes). The job log says:

-Error - Mount failed.

Operation aborted.

pkh's picture

After you plug in the USB drive, did you check in BE under the Storage tab, that the media is online?

sstrong's picture

Yes, USB drive is "Online" and is ticked in USB Disk Pool. This is the same USB drive that ran the previous job which created the two backup set BKF files on the drive.

Colin Weaver's picture

I have been testing with USB pen drives today. My pen drive had some existing old BKF files on it, so did prompt for overwrite on those (because they were classified as imported media)

Once I got clear of existing old bkf files I no longer saw any media requests and new BKF files were created.

Obviously I was set to partial protection with prompts.

heathanderson's picture

USB Flash drive is data storage device that helps to keep or storing extra data (externals data). Basically I used USB flash drives for data storing, therefore while handing any kind of overwirte issues I used to clear any the old storage or keep a backup.