Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

OWA Exchange 2010

Created: 16 Jan 2013 • Updated: 04 Feb 2013 | 31 comments
This issue has been solved. See solution.

Hi,

I read a lot here, but i'm still having issu. (every thing is allright on outlook client)

I have two exchange 2003 server, and two exchange 2010 (Dag, and cas server for eatch other between my 2 2010 server).

I have one url for the webmail of 2003, owa on this work's fine since a long time.

I have another url for the webmail of 2010, and here my issu.

When I log on the 2010 webmail, I see if I right click the "archive" button. Also I could made a search on my vault store, and I see my old archive email. This is fine.

So I test to archive a new mail, on the screen I see

"are you sure you want to archive the select item"

yes...

then I see a screen with processing "item archiving" it's turn turn turn... and nothing, the email his here, If I jump on the archive explore, I dont see it.

If I jump on outlook client I dont see it.

If I do the same thing on outlook the mail go immediatly to his vault store, and if I check on the webmail the mail is gone on the vault store (I could search it).

I think that when I click archive on the owa, he dont find my vault store ? Where can I find some log to help me?

If I could search on the archive explorer, it's mean that it's working a little no?

Edit : If on the archive explorer, I try to restore a mail, see the attachment, seems all missing about the vault store.

Thanks by advanced,

Discussion Filed Under:

Comments 31 CommentsJump to latest comment

Rob.Wilcox's picture

Have you installed the EV OWA extensions on to your Exchange 2010 CAS?

Do you see Search Archives, and Archive Explorer links in the lower left hand corner of the OWA window after you have logged in?

Is this how your OWA right click screen looks?

Specifically, do you have 'archive' above 'create rule' and below 'archive policy' ? 

If all that is correct, then you can enable OWA logging by editing the web.config file.. but we'll get to that.

DelphineFR's picture

Thanks for you answer,

yes I have this icon, something happends when I click on archive, but nothing gone.

I edit my previous post, could you check the print screen, I think i'm missing a step in the configuration. But what ?

Rob.Wilcox's picture

When does that screen appear?

It looks a lot like the dialog that can appear with EV OWA for Exchange 2003.

I'd suggest taking a look at editing the web.config file (per method 2) in this article:

http://www.symantec.com/business/support/index?page=content&id=TECH60712

Then reproduce the problem, so long as you are using an Exchange 2010 mailbox through the Exchange 2010 CAS.

DelphineFR's picture

In fact you are right there is some new windows, like your print screen, and when I try to restore an archive, it's like 2003 windows.

I will read the technote you link, I let you know.

Thanks

DelphineFR's picture

If you check my print screen you will see

Print screen name :

owa2010 : main windows with archive icon

owa2 : I click on it, it ask me yes or no archive the item

owa3 : I click yes, it's processing.

Owa4 : the left windows where I could search in my vault directory.

owa5 : old email that was archived by outlook client.

Owa6 : I will restore on item.

owa7 : say that the item is restored in folder "item restore" (I dont know where is this folder)

the owa7 print screen make it work, because before, on the first screen on my previous answer, I field the name of one of my exchange serveur, and filed the name of my account. Now he dosent ask me anymore this question.

But I dont know where is this email restore.

Also, I check the link witch give me another link http://www.symantec.com/business/support/index?page=content&id=TECH141519

If I check the owa IIS, here what's configure, seems to miss a lot of think describe in the technote.

please check the print screen name :iis_exchange_vault

what I miss? and where?

owa2.PNG owa3.PNG owa4.PNG owa5.PNG owa6.PNG owa7.PNG owa2010.PNG IIS_exchange_vault.PNG
Rob.Wilcox's picture

You need to generate a log file .. it's much like a client log file, but it's created on the CAS server:

You may already have these keys in the web.config, but it is likely that the logEnabled one is not set to true... so set it to true.. and don't change any of the others, for now.

METHOD 2:
The options listed below can be used to customize the Web.config file on the CAS, which can typically be found in the directory:
 
\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\
 
The name of the Version folder containing the Enterprise Vault resources that will be loaded during the Outlook Web Access (OWA) session, which is a sub-directory of 'OWA\EnterpriseVault\':
 
<add key="EnterpriseVault_ResourceVersion" value = "v8.0.3.1845"/>
 
This will enable diagnostic logging for the Enterprise Vault OWA Extensions per CAS:
 
<add key="EnterpriseVault_LogEnabled" value="true"/>
 
The Folder where the above diagnostic Log Files will be generated (the default value is listed):
 
<add key="EnterpriseVault_LogFolder" value="C:\Program Files\Enterprise Vault\OWA 2007\logs"/>
DelphineFR's picture

I will, but before, one last question

I did not do that : http://www.symantec.com/business/support/index?page=content&id=HOWTO37839#v40199744

is not my mistake? My exchange 2010 is also cas, so maybe it's my missing configuration?

what you think ?

But because i'm not very confortable with power shell, I'm triing to understand what to complete in the command line : New-ManagementRoleAssignment -Name:role assignment name
-Role:ApplicationImpersonation -SecurityGroup:security group name

Do you think i'm on the good way with this technote?

Rob.Wilcox's picture

How many CAS serves do you have?

The article is referring to CAS Proxying, which takes place when you have 2 or more CAS servers... and well then, it only happens in specific situations.

DelphineFR's picture

2 cas server, but all my exchange server having all the role.

Two server exchange2010, on a dag configuration.

The both server are cas.

I will active the logging anyway, i will try ;)

DelphineFR's picture

log are set up!

There is a lot of line on it, I try to find something wrong when I try to archive, but I dont know what to check?

Is some key word to check if functionning?

Rob.Wilcox's picture

Let me dig out some key bits, and post them here (later on today)

Rob.Wilcox's picture

Look for :

ProcessEVAction] ArchiveItems action called

That is likely to indicate the start of the archiving process.  Look for 'bad' things like:

Exception

Unauthorized

When the dialog is showing you that it is 'archiving'..  and a little thing spinning.  That's good.  Give it a minute or so, and it will disappear..  Then press send/receive.

Remember the item might not turn in to a full shortcut, depending on your safety copy setting on your vault store -- just like when you manually archive an item from Outlook, it might just go 'pending'.

Also remember that you should then click away from the item you've just archived, and then click back on it.  Depending how your shortcut is configured you'll see 'Enterprise Vault Archived Item' Click here to view this item, and...  'This message has been archived', in a blue banner, along with a small snippet of the archived item.

If you're still stuck.  Upload the OWA log file somewhere.. and send me a private mesasge with the location, and I'll take a look.

DelphineFR's picture

ok,

ProcessEVAction => i've got it maybe time.

unfortunatly i've got also Exception, and an unable to connect to one of our reverse proxy, I have already send the log file to the personn in charge of this reverse, maybe there is something to do to accept the connexion, here the log, do you think it's the issu ?

17/01/2013 10:54:33 [4544,23] [EVServerRequest::CreateRequest] Request timeout (milliseconds): 30000

17/01/2013 10:54:54 [4544,23] [ClientActionRequest::Send] Exception sending client action request: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <IP of the reverseproxy>:80

this error mean that on exchange and ev server, I did not miss something?

Rob.Wilcox's picture

Look for the URL that is going to.  It will be a line or a few lines before the error... near the request timeout part.

DelphineFR's picture

I see it, it's the correct url for my enterprise vault,

there is a lot of thing after, but I think it's normal

look like :
17/01/2013 10:54:33 [4544,23] [EVServerRequest::CreateRequest] Sending request to: url = lot of think about I think the exchange organisation and my active directory.

but this url is ok without all the asp?act=[...] in a normal web browser, and also a normal way in the "old" webmail 2003.

DelphineFR's picture

i made a mystake between yersterday and today, my archive on the 2003 webmail are broken!

and i'm sure i know why, by mystake I double click a script name : owauser.wsf... i'm sure it has put something wrong on my owa...

on my 2003 webmail, when I try to archive, now it dont find my vault store (something like the new webmail ;))

I will be crazy, I will come back, I need to repaire this before go one owa 2010.

Rob.Wilcox's picture

So now I'm confused.

Are you saying that items DO correctly get archived on the OWA 2010  side of things?  Or not?

If your OWA 2010 log file is showing:

<snip>

17/01/2013 10:54:33 [4544,23] [EVServerRequest::CreateRequest] Request timeout (milliseconds): 30000

17/01/2013 10:54:54 [4544,23] [ClientActionRequest::Send] Exception sending client action request: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <IP of the reverseproxy>:80

</snip>

And it is NEAR the entry for that clientaction.asp call ... then it's not working, because the request isn't going out to the EV server, it's getting stopped by your reverse proxy.

If the issue is not on Exchange 2010 side of things, I'd suggest starting a new thread on the Exchange 2003 side of things (and..  check your exchangeservers.txt file has the IP addresses of the Exchange servers in it, and rerun OWAUSER.WSF .. from a command line, so you can see the output)

DelphineFR's picture

Sorry,

my owa 2010 (new fresh install) never worked, with the log we see that I have a problem to communicate with the reverse proxy (hope it's that)

butt to be sure that the url that is call in the cas log was ok on my older 2003 server, but still in activity of course,  I went to my "old" webmail to check, we have both exchange 2003 and 2010.

Yesterday that was working fine. For fixing the 2010 owa, I tried a lot of think.

So now My new owa enterprise vault archive 2010 dont work, but my old 2003 (and you imagine that it's my production server) are down also. But I know what I did yesterday, so I will dig to rollback the configuration.

2003 was working well, until I tried to fixe the 2010, but I think I do so many thing that now my 2003 are also broken.

But you are right it's a different issu, here it's the 2010 issu, but for now i'm waiting that the man in charge of the reverse send me a feed back about the log sequence.

And during this time, I will try to repaire my biiiggg mystake on the 2003 owa ev.

Rob.Wilcox's picture

ok.

The reverse proxy seems to be the thing for the OWA 2010 side of things, at least that is the FIRST thing.  There might be other issues after that (such as 401's that I was getting earlier today)

DelphineFR's picture

thanks a lot Rob, as I have a beggining of resolution i'will come back here.

I think I will open a case for my two problem, because one are now much critical (owa 2003) than the other.

Rob.Wilcox's picture

Regarding OWA 2003: I would suggest a new forum thread..  I'm sure it will either have some input quickly, or no input -- in which case you can down the Symantec Support route.

If you do create a thread.. indicate...

* What you see -- do yo usee an EV Toolbar in OWA?

* What happens if you click on Search

* What happens when you try to manually archive an item

Earlier you mentioned that when you tried to restore an item it goes to the 'restored items folder'..  that's a folder at the same level as 'Inbox' and 'Sent Items' called .. 'Restored Items'.  You might not see it straight away in OWA, you might need to do a refresh, well, if it is the first time you've ever done it.

DelphineFR's picture

after a little break on the 2003 owa, I understand more how our enterprise vault and our exchange server work.

And I think, i've got a network issu on my exchange2010.

tell me if i'm right.

if on my exchange2003 server who work well (witch are not Cas, because this option up with exchange 2007 server) so it's like a stand alone server, if I put the url of our enterprise vault server, it's return "HTTP 500 error" witch I know that is correct, because I read a technote on it.

But on my new exchange2010 witch are CAS role add, if I do the same, It return nothing, it could not resolve it.

I know why, it's not the same root because of the cas role we dont use the same default gateway.

So I think the issu is more under the network guy from my companie, than from a miss configuration on enterprise vault.

When I click on the archive button, he try to contact the reverse proxy but with no succes because of this default gateway, and for now I could not change it because Cas server.

I let you know, but finaly because my owa 2003 broke, I much understand now the way of EV/OWA working.

As I find a way, I come back here.

Thanks again Rob for you great great help.

Rob.Wilcox's picture

So is it working, or not?

Do you see any exception, or problems, like before:

17/01/2013 10:54:54 [4544,23] [ClientActionRequest::Send] Exception sending client action request: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond <IP of the reverseproxy>:80

SOLUTION
DelphineFR's picture

No it's not working, and it wont, until we find a way with our network.

in fact for use the CAS role, the administrator of the network use a different gateway on the new 2010 server, and because of that, the reverse proxy as we try to ask him the enterprise vault/Evanon acces, he could not answer.

Dont ask me why, i'm not in charge of that. I understand what happends, but the "why" it's a little complicate for me ;-)

I'm afraid that there is no  "easy" solution, or maybe if we add a second network card (we are virtualize that is not a problem) and configure this with the other gateway (the one we use for exchange2003)

So one for the loadbalancing of Exchange, one for the archive of enterprise vault... but as I'm sure this will work, I'm not sure that it's a good think to "complicated" the architecture of exchange + enterprise vault. And i'm pretty sure that the outlook client is better solution than the OWA acces that for me is a "+" in the use.

I dont know if you understand me, because in french it's difficult for me to explain what I have also difficult to understand my self ;) so in english I really dont know how you read what I'm writting ;-)

But as I have a beggining of solution or no solution, I will come back here to explain what we'll do or what we wont do.

Rob.Wilcox's picture

Just *tell* your networking guy that if they want to have Exchange 2010 then it does kind of need to talk to other parts of the environment.

DelphineFR's picture

I have just have a talk with who manage the network, seems to be more easier than I believe.

Just some new "root" to add to tell to our exchange if you want to reatch the reverse proxy pass by this gateway, if not by this other.

I'm waiting, as it configure, I will test the owa. I let you know about the issu, but seems to be in a good way.

Rob.Wilcox's picture

Excellent - glad you are getting sorted.

Let's see what happens after that.

At least now you know the sorts of things to look for in the log file which is produced.

Oh by the way, remember to turn it off again in the web.config when you are done with testing.

DelphineFR's picture

yes, as we finish the configuration I will stop the logging, for now it doesnt grew up so much, because we havent yet migrate our users on the new exchange2010, just few email to test.

Hope in few day I could come back to close this topic.

Thanks Rob, you've been very helpfull on both subject I had open this week.