Video Screencast Help

OWA not working after upgrading to EV10

Created: 29 Mar 2013 • Updated: 05 May 2013 | 14 comments
This issue has been solved. See solution.

We have upgraded from EV 9.0.1 x32 to EV10 (2008 R2 Server) we can open archived emails from Outlook successfully, however not from OWA.

Receive error 'Remote server returned an error:(404) Not Found'

I have changed the server name in the evserver.txt file and ran the OWA 2003 Extension msi again then restarted IIS with no success.

We are using Exchange 2003

Please advise.

 

Operating Systems:

Comments 14 CommentsJump to latest comment

Rob.Wilcox's picture

A couple of quick questions:

a/ Do you see the shortcut icons in the list of mail messages (in the Inbox for example)?

b/ Do you see the OWA toolbar?

TonySterling's picture

Also, did you run the owauser.wsf on the new EV Server so the EVAnon website would be created?

Jun1or's picture

Yes I can see the icons in OWA i can also the vault icon.

No i havent ran the owauser.wsf, where do i find this?

When clicking on the item i get a different message now.

The remote server returned an error (401): unauthorised/

TonySterling's picture

Look in the Setting_up_Exchange_Server_Archiving.pdf that is in the Documentation folder in the Configuring Enterprise Vault access for OWA users  section.

This will walk you through all the steps you need to do.

Or you can view this:

Configuring Enterprise Vault access for OWA users

Article:HOWTO58373  |  Created: 2011-08-01  |  Updated: 2013-01-18  | 

Article URL http://www.symantec.com/docs/HOWTO58373

and

Configuring Enterprise Vault for anonymous connections

Article:HOWTO58375  |  Created: 2011-08-01  |  Updated: 2013-01-18  |  Article URL http://www.symantec.com/docs/HOWTO58375

 

Advisor's picture

If its a Frontend / backend setup of Exch 2003, did you upgrade the OWA extensions on both servers? then can you first try to login to OWA using BE URL such as:

http://backendservername/exchange

And check if you can retrieve the archived items. If not then login to EV Server using Vault Service account credentials and open command prompt (run as administrator) , change the directory to EV installation directory for eg: c:\program files x86\enterprise vault and then type following command:

OWAusers.wsf /domain:<EnterDomainName> /User:<AnonUserAccount> /Password:<PasswordofAnonUser> /Exch2003

Note: If you dont know the anon user account details, you can search in AD or quickly create a new user (just normal user without any extra rights/group memberships)

After running above command, crestart EV Admin service and sync all users from mailbox archiving task properties in admin console. Check IIS if EVAnon VD has been created or not. Once confirmed, make sure Data Access Account has been configured, in admin console, goto Directory on <EvServerName> , right click >> properties >> Data Access Account. There you will need to specify Anon User account details.

And at last check the shopping basket permissions, by going into properties of shopping services from admin console, make a note of the shopping basket path, then using Windows explorer check NTFS permissions on that folder. Anon User should have Full Control on that folder and child folder/objects.

Now again I would recommed you to restart the admin service and sync the users. Check OWA from backend server first, if you can retrieve without error. Try clearing the IE cache if does not reflect.

I hope this helps.

Jun1or's picture

I have followed these guides.

Installed the latest Add-In on the mail servers and ensured the evserver.txt file contains the correct servernames.

I ran OWA and RPC script on each exchange server

Installed the OWA Add-In on the Front-End OWA server ran the OWA and RPC Script

Restarted IIS

Ran the following on the EV server and received an error at the end.

C:\Program Files (x86)\Enterprise Vault>cscript owauser.wsf /domain:local /user:evadm /password:joebloggs
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

WScript version: 5.8
Configuring for Exchange 2003/2007
Running as: LOCAL\evadm
User name: evadm
User domain: networks
Assigned user right: SeNetworkLogonRight
Assigned user right: SeInteractiveLogonRight
Assigned user right: SeBatchLogonRight
Assigned user right: SeChangeNotifyPrivilege
ERROR: Failed to update IP address restrictions. Check that Feature Delegation f
or 'IPv4 Address and Domain Restrictions' is set to 'Read/Write'

Advisor's picture

As per the error goto IIS Manager, check that Feature Delegation for 'IPv4 Address and Domain Restrictions' is set to 'Read/Write'

Jun1or's picture

Thanks, I will look into this and update tomorrow.

Jun1or's picture

Not seeing the IPv4 error anymore after granting read/write permissions, however still can't open archived emails in OWA with 401 unauthorized error?

Restarted IIS on OWA server, restarted EV servers and synchronised all mailboxes.

Still no luck.

Advisor's picture

On EVAnon VD, ASP impersonsation enabled? Its under Authentication section

Jun1or's picture

Yes it is enabled, however it is using authenticated users.

Both anonymous authentication and ASP.Net are enabled, anonymous is using the Admin account.

TonySterling's picture

 When you ran the script did you use the Data Access account or the Admin?  You should have used the data access account.

cscript owauser.wsf /domain:domain /user:(data access account)
 /password:password
SOLUTION
Jun1or's picture

All - Thank you for your input.

In the end i restarted IIS on the EV server, this resolved the issue.

I think after running cscript owauser.wsf /domain:domain /user:(data access account) /password:password needs IIS restart.