Video Screencast Help
New Company Name and Logo Announced. Learn More.

Package server missing packages

Created: 12 Feb 2013 • Updated: 22 May 2013 | 3 comments
This issue has been solved. See solution.

I have a package server that lists packages and associated ID's under the package server tab. I have found that packages that are listed as "Package last updated" on /12/20/2012 do not exist on the package server. Most importantly the "software Management Plug-in for Mac Package" is missing and about 50 other packages. in the packagedelivery folder there are no packages with a modified date of 12/20/2012.

I can find the associated guid folders in the folder PackageStatus

Due to this I cannot set up any new macs as they require this agent to download software.

To resolve I have tried the following without avail.

renamed the file in client policies folder servername.xml.old

ran all the package server schedules on the notification server

update configuration on package server

refresh packages and resend package status

none of above makes any difference to the packages downloaded on the 12/20/2012

Any ideas

Cat

Comments 3 CommentsJump to latest comment

mclemson's picture

Reboot a package server.  Restarting IIS and services might work to avoid a reboot if reboots are not allowed, but everywhere I go, people are OK with restarting package servers.  This usually solves intermittent or odd issues.

Do the missing packages appear on a package server's status tab?  If so, what status do they have?  If they don't appear on this tab, check the package.  Is it assigned to 'All package servers,' or is it set to something like 'Individual package servers' or 'Package servers with manual prestaging'?  In the last two cases, the package will only be sent to the package server if the package server is selected, or if the package server is told to download it in order to serve it to a client in its site, respectively.

Does this help?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Ludovic Ferre's picture

I have found a few package server not exactly operating as they should with a few different customers lately.

Most of the time a restart of the agent or server would do, but in a couple of cases I had to stop the agent, unregister the package server agent and restart the agent.

Then depending on the environment the PAckage Server installation or upgrade would kick off but in other cases I just re-registered the agent.

Command line used:

  • cd %ProgramFiles%\Altiris\Altiris Agent\
  • regsvr32 /u aexnscpackageserver./.dll
  • regsvr32 aexnscpackageserver./.dll

I am currently off-net, on a retreat of some kind. I'll be back real soon, and you sure will hear from me then ;-).

Ludovic FERRÉ
Principal Remote Product Specialist
Symantec

cathossie's picture

Hi all in the end I had to remove the package server services within the NS and then uninstall the agent on the package server and then reinstall. The packages then all downloaded again and are all working find . I did notice that the packages that were not working were last updated around the same time the NS database was shrunk.

Thanks

SOLUTION