Video Screencast Help

Packages associated to "AIX runtime libraries" on AIX 5.3/6.1

Created: 03 Oct 2012 • Updated: 07 Oct 2012 | 4 comments
ddm2's picture
This issue has been solved. See solution.

Release Notes for NBU 7.5.0.4 states these prerequisites for AIX 5.3 (pag.18):

 

---------

AIX runtime libraries 8.0.0.10 or 9.0.0.3 or later

xlC.rte 8.0.0.10 fileset

AIX 5.3 TL12 SP2 (5300-12- 02-1036) 
----------
 
What packages shoud I check with the lslpp command to verfy the first prerequisite (AIX runtime libraries) on AIX 5.3 and AIX 6.1?
 
Thanks
 

 

Discussion Filed Under:

Comments 4 CommentsJump to latest comment

CRZ's picture

Just xlC, I believe.  Unless I'm not understanding the question.

I believe this note is a later relative of this earlier TechNote:

3RD PARTY: NetBackup 6.x fails on AIX running downrev versions of the C++ runtime libraries. Updated libraries from IBM are required.
 http://symantec.com/docs/TECH54293

Run the following command can be run on an AIX server to identify the version that is currently installed:
lslpp -l | grep xlC

I think that command might be what you're looking for.  Let us know!


bit.ly/76LBN | APPLBN | 75LBN

ddm2's picture

Thanks for your answer.

Frankly I don''t understand the RN and the TN too.

The RN seems to say "check the AIX runtime libraries AND the xlC.rte fileset".

I can't understand if the runtime libraries and the xlC.rte are the same thing or not.

Confused...

CRZ's picture

I believe in this case we are using those terms interchangably, yes.  It would have been more precise if we had stuck with "C++ runtime libraries" as we did in the TechNote, but the AIX 5.3 section of this particular table is pretty much word for word what we had in the 7.5.0.1 Release Notes AND the 7.5.0.3 Release Notes.  (...and the 7.5 Release Notes, 7.1 Release Notes AND 7.0 Release Notes, for that matter!  So if you have ANY 7.x already working on your AIX 5.3 machine...you have probably already satisfied this condition.)

What the Release Notes are saying is that everything "xlC" needs to be at (8.0.0.10 or above) OR (9.0.0.3 or above)...

AND ALSO (if you're at 8.0.0.10) you may need IY91284.

Is this any clearer?


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION