Video Screencast Help

Patch created but not updating target

Created: 01 Jul 2009 • Updated: 21 May 2010 | 3 comments

Hi,
I'm trying to create a patch by running UpdateSync from the latest project against the original .msi and then follow Wise Installer help files on creating patches.  I have added an extra file and updated an executable, but when the patch is ran the files in the target directory aren't being updated as required. The patch would seem to have completed as it is available in add/remove programs for roll back.   I can't see anything that suggest why my directory hasn't been updated by the patch, but then again this is first time I've tried to do this. 

I've ran the patch with verbose log output, I've attached it to this post. Hopefully someone will see where I'm going wrong

Many thanks

Discussion Filed Under:

Comments 3 CommentsJump to latest comment

EdT's picture

Can you ZIP the log file before you attach it. If you try and open the text file you have attached, it has lost all carriage returns and the text is basically unreadable.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

JohanH's picture

The log looks fine in an editor that understands different encoding, such as Notepad++.  The only error I notice is Internal Error 2769. SetPatchMode, 1. I am not sure what it means, though. It looks like it is trying to do some custom action.

EdT's picture

The MSI.CHM help file lists Error 2769 as: Custom Action [2] did not close [3] MSIHANDLEs.

I don't believe this is the underlying cause of the problem.

Is the extra file being added? As for the existing file being updated, what are the file versions of the old and new file?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.