Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Patch missing for some components

Created: 30 Jan 2013 • Updated: 07 Mar 2013 | 4 comments
Faisal Saleem's picture
This issue has been solved. See solution.

My query.

I was updating SFHA 5.0 MP3RP3 with the rolling patch of MP4RP1.

The patch I downloaded did not contain any instalmp or installrp script. There were respective directories in which rpms were available. I had to to rpm -Uvh *.rpm to install them which even led me in the confusion for should i install all the rpms in all the directories or should I install repsective to products I am using.

My usage is, Global Cluster Server and Replication - 2 Node Primary & 1 Node DR

Anyhow what I did was just installed the rpms which were in the directories of Storage Foundation and Veritas Cluster Server, though while I tried to install rpms from Cluster Server directory after installing rpms from Storage Foundation directory I was received with a message of rpms already installed.

Please update me on the above queries where I am leading myself in confusion

Furher, I carry a similar replica enviorment with another client who is already on SFHA 5.0 MP4RP1. I compared the result of rpm -qa | grep VRTS to see if I have missed any of the rpms which should be installed and found 4 Rpms which were of older version in my new enviorment. I manually started finding it with find command in the entire patch directories but was unable to find them. The rpms are

VRTSmapro-common-5.0.3.0-RHEL4
VRTSvcsmg-5.0.40.00-MP4_GENERIC
VRTSvcsmn-5.0.40.00-MP4_GENERIC
VRTSvcsvr-5.0.40.00-MP4_GENERIC

I have similar packages in my enviorment but they are of different versions, kindly inform me where I will be able to find these rpms ? and why were they not available in the 5.0 MP4RP1 rolling patch which I downloaded from Sort

Thanks

Comments 4 CommentsJump to latest comment

Marianne's picture

I don't have first-hand experience with the patches you are looking for, but I always look for all available documentation when i download patches. Patch contents and dependencies along with installation instructions can usually be found in the documentation.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Faisal Saleem's picture

Thanks for the kind words Marianne,

I have went through documentation along with patches i downloaded. But I am having some query with comparing things of already an enviornment with MP4RP1 and these 4 patches differentiate while I patched on my new enviornment and rest of the questions I asked are still on the que.

mikebounds's picture

Are you saying that another system shows MP4RP1 for the 4 packages you listed - if not and you are just wandering why some packages are not at level MP4RP1, then read on:

The 5.0MP4RP1 release notes lists the packages that are in the RP and I believe these listed packages are the packages in RP1, not MP4, even though MP4 is actually in the patch.  So if you search for VRTSmapro and VRTSvcsvr in this doc, these are not listed which suggests they were not changed from MP4 to MP4RP1.  But note, if you started from MP3RP3, then as you now have VRTSvcsvr MP4, this proves that MP4 is in the patch.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION