Video Screencast Help

Patch reports in VOM 4.1 show nothing

Created: 19 Jul 2012 • Updated: 02 Oct 2012 | 6 comments
This issue has been solved. See solution.


I have successfully installed VOM 4.1 on a RHEL5 machine and added all VCS clusters. I tried to setup the patch report functionality. In our company I have to use a proxy server to access external sites. I enabled the download function and entered the proxy informations. When I test the configuration I get an OK. But when I look back to the deployment management page, nothing is displayed. I already tried to download the patch information manually using WSH.

Am I missing something?

Kind Regards

Comments 6 CommentsJump to latest comment

RodP's picture


Sorry about missing the post and an untimely response. We have newer versions out now and the latest is VOM5 from the download site (requires your serial key)

To answer your question I will include a few versions as you may have upgraded by now.

The proxy must be configured to also allow HTTPS traffic

4.0        Proxy configuration  Patch download

4.0RU1  Proxy configuration  Patch download

4.1        Proxy configuration  Patch download

5.0        Proxy configuration  Patch download

Let me know if these are not resolution to your issue.



Rollsreuss's picture

Hello Rod,

I already tried to configure the patch reports via proxy. The 'test' function is successful, but no information gets downloaded. Maybe I'll do the update to 5.0 this afternoon.


Rollsreuss's picture


also no luck with VOM 5.0. The patch information obviously doesn't get downloaded. I also checked the proxy settings again and the test was successful. Are there any logfiles for this?



RodP's picture


Can you attempt manual upload and ensure that works for you. It provides a workaround and I will try to test a proxy configuration if I am allowed to cross the DMZ from our lab environment.

To use the manual upload in the case of a failure to download patches due to receiving an error on the patch page follow the steps below.

We have an error:

Or a failure to reach a proxy

So we create a script from the Central Management Server console on a node that has full internet access and is running the prerequisites for windows. Using the download button via the console which is running on our Windows host we execute the script and upload the Patch or Price Tier info to the server so it shows in the deployment page.

1) Download the files

 Directory of C:\VOM\patchproxy
09/04/2012  01:22 PM             1,015 pricetier.vbs  # Downloaded
09/04/2012  01:10 PM             1,123 vos.vbs # Downloaded

2) confirm Internet access

Microsoft (R) WinHTTP Default Proxy Configuration Tool
Copyright (c) Microsoft Corporation. All rights reserved.

Current WinHTTP proxy settings under:
    SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\
      WinHttpSettings :

     Direct access (no proxy server).

Pinging [] with 32 bytes of data:

Reply from bytes=32 time=103ms TTL=53

Run the script(s)

C:\VOM\patchproxy>cscript /Nologo vos.vbs
Finished generating vos.txt

C:\VOM\patchproxy>cscript /Nologo pricetier.vbs
Finished generating pricetier.txt

3) Upload the file(s)

 Directory of C:\VOM\patchproxy

09/04/2012  01:23 PM           495,407 pricetier.txt # For Upload
09/04/2012  01:16 PM             3,186 vos.txt # For Upload

4) Check the page for patches

I hope to have some resources to test the proxy for you soon.



Rollsreuss's picture

Hey Rod,

thanks for the whole lot of information. It worked now using the VBS script. But when I look into one specific server also obsoleted patches or products that do not match our installation (e.g. CFS) are also displayed. Is this correct? I will also check this with other machines. Maybe it has something to do with the base product information, but it's a little bit confusing.

Regarding the proxy thing: I tested to provide some dummy information (e.g. wrong proxy password) and the connection test also stated a successful attempt ;) So I don't know what's wrong here.



RodP's picture


I suspect the proxy server configuration. I am unsure how I will be able to test it as I either have direct connect or a firewall preventing connection. The manual method seems to be the resolution for you if you are getting a successful test but a failure to connect. The server Administrator should be able to check the firewall or allow rules for HTTPS traffic and add the site.

In the scripts (vos.vbs) you can see the command: "GET", "  - with your string.

in the vos.txt file you will see the values returned based upon the licenses and nodes installed (we call them Managed Hosts) viewable under Manage > Servers > Hosts page.

Check your file you uploaded for the CFS (Cluster Files System) entry by hotfix number (HF05000####-VV  V is version). You may have had a license enabled or qualified under an install or evaluation key. Symantec provides all available patches pertinent to your environment and the option to research and install is available to you.

Each patch contains a readme file for the download page and can be viewed (you may have to copy the link if you use a console on the server without internet connection) for relevant details to the purpose of the patch or alignment made to the software.

As this software works with many Operating Systems and platforms we have to stay in lock step with device API changes or third party enhancements.

I am glad you were able to bring down the information for your environment in the SFM (Storage Foundation Manager - the old product name) Domain for VOM (Veritas Operations Manager).