Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

PC Anywhwre Quick connect error "There are no devices selected in the connection item"

Created: 18 Feb 2013 | 20 comments
rajeshm_81's picture

Dear All,

I am fed up with the PC Anywhere Error " There are no devices selected in the connection item" when trying to connect to another system through PC Anywhere. We are running Altiris Agent version 7.1 and PC Anywhere vesion 12.6.8096.

Any one have the idea about this error. Please help as this error comes after uninstalling and installing the PC Anywhwre new version.

Regrds,

Rajesh Singh.

Comments 20 CommentsJump to latest comment

Ashish-Sharma's picture

Hi,

Check any connection type do you have choose

To check port are selected:

  1. Right-click the connection item and then click Properties.
  2. Click the Connection Info tab.
  3. On the Device list
  4. verify selection list.
    For example, if the modem, Standard modem, is on COM2, and you have both Standard modem and COM2 selected, this could be the cause of the problem.
    If

Thanks In Advance

Ashish Sharma

 

 

rajeshm_81's picture

Hi Ashish,

 

Thanks for your reply.

Which connection item you asked for In symantec PC anywhere Quick connect there are only Browse, Connect, Close, help and option tab.

Can you please tell me from where this options will availed?

 

Regards,

Rajesh Singh

Ashish-Sharma's picture

Hi,

How many system having problem ?

 

Thanks In Advance

Ashish Sharma

 

 

rajeshm_81's picture

Recently, I have got the error on couples of systems don't know in future how many systems will have this kind of issue.

 

Regards,

Rajesh Singh

consoleadmin's picture

HAve you check the required port is open for pcanywhere?

https://support.norton.com/sp/en/us/home/current/solutions/v60749971_EndUserProfile_en_us

https://www-secure.symantec.com/connect/forums/how-access-pcanywhere-host

What port(s) do the pcAnywhere 12.5 SP4 and pcAnywhere Agent 12.6.8096 host programs use?

 

Article:TECH187304  |  Created: 2012-04-25  |  Updated: 2012-04-25  |  Article URL http://www.symantec.com/docs/TECH187304

 

Thanks.

rajeshm_81's picture

hi all the default ports are already opened up. still facing the same issue.

 

Regards,

Rajesh

006's picture

we're experiencing the same issue since a week now.  Actually, since last update.

complete remove & reinstall doesn't solve it.

demanded ports are open...

happens not on every w7 machine, but already a couple & afraid more to follow...

 

already found a solution?

honey_jack's picture

Replace the PCAQuickconnectDll.dll according to version

Navigate to the pcAnywhere install folder and back up the existing PCAQuickconnectDll.dll

  • C:\Program Files\Symantec\pcAnywhere
  • C:\Program Files (x86)\Symantec\pcAnywhere
AttachmentSize
12_6_7_Sol.zip 35.01 KB
12_5_sp4_Box.zip 35.02 KB

Thanks & Regard

Honey Jack

 

If your issue has been solved, please use the "Mark as Solution" for the valid thread.

006's picture

Unfortunately, this did not help.

Error message appears as soon as you click on connect.  Without receiving the popup for credentials.

PS: dll says the file version 12.5.4.8211

and

symantec pcanywhere agent version 12.6.8209

 

 

honey_jack's picture

Please share the Snapshot of the error Message.

Thanks & Regard

Honey Jack

 

If your issue has been solved, please use the "Mark as Solution" for the valid thread.

honey_jack's picture

Have you tried this one 12_6_7_Sol.zip file

Disable firewall of client system

Thanks & Regard

Honey Jack

 

If your issue has been solved, please use the "Mark as Solution" for the valid thread.

006's picture

Yes, tried again.  No luck.

I gave the user local admin rights and did a run as administrator of the quickconnect too.  No luck

(registry cleaned up too)

even logged in as a new user account: same error

BUT when i log in as the domain administrator, it works...

However, before the latest update, this wasn't a problem for the users and pcs that have this error now...

Firewall is always disabled and since the last user got this error message, i uninstalled mcafee completely too (just to be sure).  pcAnywhere has been reinstalled a couple of times now already too (through Altiris).

Default ports are open

BugTastic's picture

Hi- did you manage to find a solution to this - I have it on one of my servers. I'm sick to death of this software. Its nothing but trouble.

 

006's picture

unfortunately i've already spend a lot of hours uninstalling, cleaning everything up and reinstalling the quickconnect from scratch...without result.

i just installed the complete 12.5 suite on that computer so they were able to work again.

hopefully someone will come up with a solution cause that's not really an alternative for everyone.

Philippe OUVRARD's picture

Hi,

I have the same issue on 20 PCs...

no solution for the moment, but i think that is a rights issue because in Local Admnistrator Account, the quickconnect is OK.

For information, PCs that have the problem are not inpact if remote control is launch from the SMP Console.

 

Thanks for your help...

Philippe OUVRARD's picture

I've found a solution :

1. delete the file : c:\users\ « user profile » \Documents\pcAQuickConnect\pcAQuickConnect.chf

2. restart PCAnywhere service

3. Launch QuickConnect by a right clic and "Start as Administrator"

 

 

kevbts's picture

Has anyone come up with a solution here? Yes, I could start the RC session by right clicking as "Start as Administrator". However, do you want to use PcAnywhere without prompting "Start as Administrator". Please let me know if you're in luck.

Philippe OUVRARD's picture

Hi,

for my issue,

just run QuickConnect "as administrator" one time,

after, QuickConnect is ok without "start as administrator" .

rweiss77's picture

The problem is actually a coruption of the CHF files located in the user profile and in program data.  I wrote a quick script to fix the issue which also clears up the invalid CHF errors we have been seeing even post HF1 installation.

 

Try running this to see if this clears up your issue:

echo off
Rem script will fix pcanywhere by deleting corupt chf files and replacing them with a known good file
 cd %userprofile%\Documents\pcAQuickConnect
 IF EXIST pcAQuickConnect.CHF DEL pcAQuickConnect.CHF ELSE GOTO :CHSVCSTP

:CHSVCSTP
 
REM Stop the pcAnywhere agent service
Net Stop awhost32

REM rename the default chf file in programdata
 cd %ProgramData%\Symantec\pcAnywhere
 REN Chtempl.chf Chtempl.chf.old
 
REM move the direct.chf file into the %ProgramData%\Symantec\pcAnywhere directory and rename it to Chtempl.chf

cd Remotes
Xcopy Direct.chf  %ProgramData%\Symantec\pcAnywhere
cd %ProgramData%\Symantec\pcAnywhere
REN Direct.chf Chtempl.chf

REM start the pcAnywhere services

Net start awhost32

exit