Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PCanywhere 12.5.5 SP4 (1086) Problems requiring T.S. assistance.

Created: 31 Aug 2012 • Updated: 02 Sep 2012 | 3 comments

I have been going insane with the PCanywhere 12.5.5 SP4 (1086) Retail Box Host & Remote version allowing connectivity after upgrading. 

I always shut-down the HOST first, then perform the upgrade, preserving all existing data.

Most systems I have had to UNINSTALL the product completely, then REINSTALL and recreate all of the hosts and remotes manually all over again.

At first I thought there was a problem with USERNAME or PASSWORD length, but the real problem appears to be after the machine is rebooted. It will connect initially after installation, but once the machine reboots, it won't allow access again.  There must be something unexpected going on  in the installer with regards to the encryption key.

FOUND A BUG:    There is definitely a bug (Windows 7 x86 or x64) that if I check the LAUNCH WITH WINDOWS box, after the machine has been restarted after installation, the machine will hang forever, requiring either a task manager shutdown or reboot to recover.

 

I have also found on forums/knowledgebase searches, two file fixes and one registry fix, but would love clarity as to what these fix and what they do:

File AWIO.DLL  version 12.5.5.1201   copied to PCanywhere directory

File AWTERM32.DLL  version 12.5.5.1200  copied to PCanywhere directory

Registry Fix:

    32bit:       HKLM\SOFTWARE \Symantec\pcAnywhere\CurrentVersion\Remote Control

    64bit:       HKLM\SOFTWARE\Wow6432Node\Symantec\pcAnywhere\CurrentVersion\Remote Control  

    Add DWORD:     NonPCAHostTimeout     and set to decimal value of:     45          (default value is 15)

These don't appear to have fixed MY problems, and the only fix I can find is total removal and reinstallation.

Any suggestions would be most appreciated.

Please note: Installation on all sides is this new version (no older copies).  Our configurations are semi-complicated,  with non-standard Host Ports 2000-64000, and the following Security Options are turned off (unchecked):
     Prompt when receiving a remote TCP/IP session request,
     Prompt to confirm connection,
     Blank PC screen after connection,
     Secure workstation,
     Disconnect if inactive,
     and the Encryption is set to the new AES256 standard (by default).

   Windows firewall has an assigned INBOUND port rule for the specific PCaw port, and routers are designed to port-forward specific ports to specific machines based upon MAC-to-IP address assignments.

Am I missing an update (I ran Live Update from all machines with everything showing up-to-date) ?  Most machines are running Avast antivirus program, could this be interfering with the installation (without notification) as everything appears to be working correctly ?

Sincerely,

John Martoccio
Intelligent Solutions (a computer VAR/Integrator)
 

Comments 3 CommentsJump to latest comment

CraigV's picture

...moved to the correct forum!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

CPUjohn's picture

MORE INFORMATION ABOUT THE CONNECTION ISSUE:

After being unable to connect to a primary machine at a client, I drove out there to try to troubleshoot what is going on.  This machine is a Windows XP with the Windows Firewall turned off.  I found that I could not initially connect to this computer, as it would popup with the USERNAME/PASSWORD dialog box over-and-over, even  after entering the correct credentials, however, if I turn off the Symantec PCanywhere Host Service, and restarted, I could go right in.   I then restarted the computer and again it would not let me in, I then restarted the service, again, right in !

Anyone with a clue as to why this behavior, would be most appreciated !

I also edited all Windows 7 machines (both x86 and x64) and set their Windows Firewall, Advanced, Inbound Rules, Advanced Tab,  on each PCanywhere Host in the list to allow from ALL PROFILES (Domain,Public,Private), and to ALLOW Traverse Edge Device, just in case that was preventing access.

Has anyone noticed a difference between installing using the "Run as Administrator"  versus installing as a user that is an Administrator ?

Also note: All machines at client's are on identical motherboards-video, with different OS's (2-XP's,3-Win7-x86,1-Win7-x64) and all drivers for video are identical (for their OS's). Also tried updating to latest video driver per suggestion, just in the off-chance this was related, but same behavior: Appears to connect, then timesout with dialog box prompting for USERNAME/PASSWORD, and never allows sign-in, until service is cancelled and restarted (via another station when remotely accessing).

Tried the Mirror Driver disabling technique with same results.   http://www.symantec.com/docs/TECH110005

I am quite disappointed in Symantec's lack of support on this retail product.  If they had been more dilligent on their own security,  I would not have needed to do all this work.

 

Jay Hicks's picture

Hello,

I can't say I have ever seen the login issue you are having, but I can answer your question about installing as administrator.

There are definitely problems that can arise from not installing pcAnywhere as administrator.  On newer operating systems that have UAC, even an Administrator account is not truly running with full Admin permissions, so "Running as Administrator" while logged in to an Adminstrator account is best practices.

As far as the login issue, I can think of no explanation of why you are seeing what you are seeing, especially after the clean install with new connection items.  Only thing I can think of is you stated that this occurs after a reboot, but if you restart the pcAnywhere host service, you are able to log in.  Perhaps there is a timing conflict with the loading of the pcA host service and setting a delay on it would help.

Tech article http://www.symantec.com/docs/TECH106566 shows a reg key for HostStartupDelay.  I have also heard of users creating a dependency on another service, usually one that starts later in the loading process, so that pcAnywhere service starts after it does.

I hope this helps.

Regards