Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PCAnywhere connecting over wireless

Created: 20 Dec 2012 | 6 comments

We have a lot of docked laptops in our environment where turning wireless off/on isn't possible.

We have ran a script on the workstations to correctly always prioritize ethernet over wireless, which works fine for clients.

The problem is when we try to remote into machines using PCanywhere in CMS, PCanywhere connects over wireless.  I can see the wireless address it's trying to connect over right after accepting the cert.

We have much better success if I have technicians manually type in the ethernet address versus the given machine name that comes up, but this can be tedious sometimes to get from the client.

Is there any fix for this, how does PCAnywhere choose the address it's connecting to?  When it just happened today, the IP address showing under computer name in the console was the ethernet address - not the wireless, so you'd think it'd pick that one?

Comments 6 CommentsJump to latest comment

Ludovic Ferre's picture

Hello Sally,

It would probably depend on the DNS resolution at execution time. Which turns the problem around - assuming the DNS registration is done via DHCP, and that you have a centralized DHCP, how can you configure the WLAN Adapters so that the fqdn may differ from the lan adapter?

I'm not sure it could work for you, but a scheme like appending a pre-fix to the DNS (like '.wifi.mydomain.com' would probably be sufficient. This would be handled from the DHCP scope for the Wifi subnets.

I am currently off-net, on a retreat of some kind. I'll be back real soon, and you sure will hear from me then ;-).

Ludovic FERRÉ
Principal Remote Product Specialist
Symantec

ICHCB's picture

Are you using quick connect or useing the Console to initiate your connection?   If you use quick connect then it is the DNS responce that pcA will try to connect to.    As Ludovic points out.   If you ping that machine by name what IP comes back?

Alternatly if you don't ever want the wifi to be used you can modify pcAnywhere from a registry key to only use a specific NIC.   Take a look at the following kb and see what you think about the use of the TCPIPHostBindMode registry key would help your situation.

http://www.symantec.com/docs/TECH138227

Cheers

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

Sally5432's picture

We use the console to initiate the connection.  

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

ICHCB's picture

Then is should be using the IP that is in the Database for that system.  Keep in mind that this may be stale information as it isn't updated real time but when the Altiris Agent checks.  Every 4 hours by default I think.

The proposed use of the registry key to force the client to only answer on one nic is still applicable. As is the DNS suggestion.

cheers.

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

Sally5432's picture

@ICHCB - the ethernet address correctly shows in the console.  When you right click to connect via PCAnywhere, it tries to connect over the wireless address if you leave machine name in for connection.

I've been training our techs if they are connecting to a wired laptop, instead of leaving machine name in the PCanywhere prompt in the console, use backspace and instead type the wired ethernet address that shows right there in the console.  It's not a huge deal, just an annoyance. 

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

ICHCB's picture

Thanks for the clarification.   I don't use the console to connect but rather the quick connect since it save me time and I know it used the DNS results to pull the IP that is then used.  

I thought that the console would pull the IP from the machine info but it sounds like they changed that or I had it wrong.   The issue I was aware of with the console is when machine info was outdated (vpn user connects but client hasn't updated yet) then the wrong machine or no machine would be connected to.

Cheers,

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution!