Video Screencast Help

PE Boot CD not working with Lenovo x131e

Created: 07 Aug 2013 | 17 comments
DM1's picture

Version of Ghost is 11.5.1.2266.

Target (and source) machines are Lenovo Thinkpad x131e.

I created a boot disk (CD) using drivers downloaded from the Lenovo website:

http://support.lenovo.com/en_US/research/hints-or-...

I used the Realtek LAN drivers (7.50.1123.2011).

More specifically the Realtek driver for Windows 7 (32 bit) NDIS5.

So, using the Ghost Boot Wizard, I added that to the existing drivers and made sure it was checked.

I then created the Windows PE based boot disk (not PC DOS).

OK...

The computer boots fine, the Windows PE interface and then Ghost interface appears...

I can attempt to connect to a Ghost Cast session (the option is not grayed out) but... nothing happens.

"Attempting to contact session ...

It ultimately times out with error code:

"Unable to establish contact with session . Check that the GhostCasting Server is ready to accept clients! (10030).

Status on Ghost Cast server is "Waiting for clients to connect".

I think the problem is with the network drivers or the BIOS:

ipconfig produces:

"Windows IP configuration"

That's all.

Not surprisingly, ping fails: "transmit failed, error code 1231"

Pinging loopback address is successful however: (0% loss).

I tried "wpeutil initializenetwork" which completes successfully but results for ipconfig and ping are the same.

Operating Systems:

Comments 17 CommentsJump to latest comment

DM1's picture

What about the settings in the BIOS.

First, BIOS level of the Lenovo Thinkpad x131e is:

UEFI BIOS version ... 2.50
Embedded controller version ... 2.00

Network settings:

Ethernet LAN Option ROM - Enabled

Startup:

Network Boot: PCI LAN: Realtek

But technically, I am not booting from the network, I am booting from a Windows PE based CD.

I do not see any reference to PXE or UNDI in the BIOS and whether or not they would be enabled.

I intend to call Lenovo to verify if such settings exist... somewhere. Maybe with a BIOS upgrade?

EdT's picture

The error appears to be in the use of Win 7 drivers, as WinPE V2 as used in Ghost, is based on the Vista 32 bit kernel. You therefore need to source Vista 32 bit drivers for addition via Ghost Boot Wizard. The following two links may be of help:

https://www-secure.symantec.com/connect/articles/do-i-have-correct-driver-winpe

http://www.symantec.com/business/support/index?page=content&id=TECH110134

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

EdT's picture

You also need to turn off the UEFI bios while using Ghost.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Terry BU's picture

Remember, the drivers you need for the WinPE from Ghost are always the 32bit Vista drivers.  It doesnt matter what OS will be on the machine when you are done.

The fact that no IP is shown (not even 127.0.0.1) says it doesnt even have anything for the card.  You could always try downloading the vista drivers to a thumbdrive and using DRVLOAD inside the winpe to see if you can renew the connection and get an IP address

DM1's picture

OK, no progress, no improvement.

I tried with Vista 32 bit NDIS5 drivers.

Same results as above.

As for UEFI Bios, I do not see any setting to enable or disable this (Lenovo x131e).

I do see this settings under USB options:

"USB UEFI BIOS Support"

When I disable it, it seems that I cannot boot from the CD.

I've tried this 3 times now and... it's pretty consistent.

I might have to resort to the USB trial and error option but...

Shouldn't this work with UNDI regardless of the particular drivers normally needed?

Of course, I cannot see any reference to UNDI in the bios to verify that it is enabled or not, or even present.

x131e (Lenovo Thinkpad).

Terry BU's picture

try the NDIS61 drivers.  5 is usually for XP, 61 for Vista, 62 for 7, and 63 for 8

DM1's picture

Using this process...

http://www.symantec.com/connect/articles/do-i-have...

I can successfully load the NDIS6 drivers and establish a Ghost Cast session.

Yet, the boot CD I create does not work.

Same problem as above.

???

So... I can image the laptops but it will be a clumsy and laborious process.

I wonder why the boot CD does not work.

I did check that the appropriate driver was checked (after adding it).

Is there any way you can check to see what drivers are actually contained in the boot disk?

Making some progress anyway...

Terry BU's picture

so you can use DRVLOAD to load a driver and it works, but including the same driver in the PE does not work?  My first suggestion is to delete the NDIS5, 62, and 63 drivers (if they exist) from the pack before adding the files in.  You dont want it to grab the wrong driver by accident.

you said you checked the driver after adding it to the PE, my recommendation is to uncheck drivers you added but were incorrect and rebuild it again.

DM1's picture

Right. It seems very strange. Will get back to this ASAP.

DM1's picture

I removed the other Realtek drivers and then most of the others (some are included automatically).

Same problem.

Maybe I'm not creating the disk correctly...???

But I've created these before...

At any rate, I was able to image all the machines, even if that meant loading the drivers manually.

This is actually much faster than using Bart PE or the Ultimate Boot CD for Windows (that takes forever to load).

EdT's picture

You could include the DRVLOAD step into the startup batch file to automate it, if you cannot find where your boot disk creation is going wrong....

Just for the record, your driver needs to include a .INF, .CAT and .SYS file as a minimum.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

dgarcia15's picture

can someone please tell me where you got these drivers? i tried the lenovo site and when i download the drivers i cannot find the com file to load the driver into ghost suite.  I am able to boot into ghost using the uni driver but only get about ~67bm/min speed which is insane, take me about 4+ hours to load (1) 16gb ghost image into 4 laptops.  I've tried using drivers downloaded from the realtek site but the transfer rate got worse.(who knew that was possible) any help would be appreciated.

Terry BU's picture

are you positive its using the right drivers that you want it to use?  are you unchecking incorrect drivers from the PE Builder?

dgarcia15's picture

As far as I know I am using the correct drivers, it the UNI driver that is in Ghost Boot Wizard that works for most computers,  I have EFI off in the BIOS (set as legacy only).  I'm at a loss at this point.  It's absurdly slow, and I've used ghost many many times before to image laptops that I have to perapre, such as Lenovo L420, x130, various dell laptops, and even hp, lenovo, and dell desktops.  Any help is appreciated.  Thanks. 

PS. I don't know if i mentioned before that I am using ghostcast multicast. I am building my USB bootable stick using the PC-DOS option.

I've never used the PE-Enviornment how would that apply here? How do i use it ?

Terry BU's picture

the PE environment uses a stripped down version of VISTA.  it has better built in driver support than PCDOS (for example, SATA)

in my opinion the best part about PE over the older DOS method is that if your restore explodes in the middle (such as a loss of network connection), it wont just start boot looping.  it can stay in the PE and you can start over (but only for so long).  you also get the opportunity to open other cmd prompts for info such as MAC addresses, IP, etc

dgarcia15's picture

Would it possible to explain to me how I would effectively use it?  How do i get the ghost cast started when I create the usb boot stick it just loads to a cmd promt and i cannot type anything.  When I am createing the stick am I choosing standard boot image ? Once I get into the network client config screen do I need to fill out that information? please advise. I appreciate your time. thanks.

Edit: BTW not trying to hijack anyones thread here, just the last response before mine was in aug and It is also involving a lenovo x131e. 

EdT's picture

>Would it possible to explain to me how I would effectively use it?

Use what exactly?  If you are referring to a USB boot stick running DOS, then speed may be improved by loading smartdrv.exe, but realistically, you should dump DOS and move to WinPE.

Here are some links that may help:

http://www.symantec.com/business/support/index?page=content&id=TECH110134&profileURL=https%3A%2F%2Fsymaccount-profile.symantec.com%2FSSO%2Findex.jsp%3FssoID%3D1379325844236H648XIOBo89QYnlyyqy8JBXy4XpzTOpCi8Nmu

https://www-secure.symantec.com/connect/articles/do-i-have-correct-driver-winpe

https://www-secure.symantec.com/connect/articles/readyadventures-winpe

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.