Video Screencast Help

PECTAgent not connecting to HTTPS

Created: 06 May 2011 | 4 comments

I'm running DS 7.1/CMS 7.1 and I'm having an issue with getting PECTAgent.exe to connect to my NS via https. My PECTAgent.ini file appears to be correct but when I look at Agent.log, I see that its trying to connect via http://<NotificationServer>:443 instead of https://<NotificationServer>:443. If I disable require SSL in IIS and modify the PECTAgent.ini file to use http and port 80, things start to work. Otherwise, the logs just show HTTP errors about SSL being required.

I've seen http://www.symantec.com/business/support/index?page=content&id=TECH127620 and http://www.symantec.com/connect/forums/pectagent-crashing-winpe-ds-71 but neither accurately describe the issue I'm running into.

Has anyone else foudn fix that isn't a work-around for this issue? It's as if PECTAgent.exe is ignoring the protocol specified in PECTAgent.ini, just using http regardless.

Thanks in advance!

Comments 4 CommentsJump to latest comment

DustinW's picture

I'm having similar problems. I'm REALLY regretting enabling SSL at all, and I wish the installation documentation had warned me how much of a PITA it was going to be if I chose to use SSL, instead of blithely giving me the option to use it if I so desired.  

If I may ask, how are you modifying the PECTAgent.exe? I want to change mine back to HTTP and scrap SSL entirely. This is the one place where I'm being held up.

NedBingham's picture

So far, I haven't found a way to edit it. At the point that I discovered that PECTAgent wouldn't connect to HTTPS, I was still in testing and thus was able to reinstall. Now the issue has cropped back up (after applying some updates) and I'm trying to figure it out again. Too bad I didn't take better notes...

Scratch that... I just remembered (after reading my initial post again) that the PECTAgent.ini file that is in the bootwiz folder (<Deployment Share>\Task Handler\bootwiz\oem\DS\winpe2\<x64/x86>\Base\Program Files\Altiris\Altiris Agent) is where I found to change how PECTAgent connects. Hope this helps. Sorry I didn't notice your response sooner. You'll have to regenerate your PXE images, but changing the port to 80 instead of 443 should do the job. This is also where I tested/verrified using https for the protocol had no effect.

NedBingham's picture

By the way, for anyone else who happens on this article, I have received confirmation from Support that "Automation DOES NOT support SSL". They were working on a solution when I asked them, but they only gave an ETA of Q4 (and this was in June of 2011).

noodleNT's picture

INI files shows it's using HTTPS but it will not connect to my server using HTTPS.