Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PECTAgent registering into SMP console with APIPA addresses

Created: 14 Jul 2014 • Updated: 14 Jul 2014 | 5 comments

I have a problem with sites and APIPA addresses when attempting to deploy a new server.  The environment is ITMS v7.5 HF6 with 30 site servers for our various geographic locations.  Each site server is configured with DHCP to issue addresses to new computers in thier respective locations (there are valid reasons why we don't use IPHelper entries in the firewalls/routers so don't go there).  The new servers PXE boot into the WinPE4 automation client without any problems.  But this is where my problem starts.

Most of our new computers have multiple NICs with only one configured into an imaging network where it gets a valid DHCP address from the local site server.  The rest of the NICs get APIPA addresses when they fail to obtain a DHCP address.  This is expected and works as designed.  No DHCP for those other NICs again with valid reasons for the configuration.  The problem is the PECTAgent registers with the SMP console using one of the APIPA addresses instead of the issued DHCP address.  Since the APIPA networks are not assigned to the site of the new server, the PECTAgent picks a site server at random (or by whatever algorithm is used) for its task server.  This ends up causing the ghost task to fail because the PECTAgent cannot communicate with the chosen site/task server due to firewall restrictions (again, this cannot be changed).  If we assign the APIPA networks of the new computer into the appropriate site, the ghost task runs without incident.

My question is: how do I get the PECTAgent to register consistently with the SMP console using the issued DHCP address and not one of the APIPA addresses?  And disabling the extra NICs is not an option.

Operating Systems:

Comments 5 CommentsJump to latest comment

Brandon's picture

Is plugging the second NIC in after its imaged or disabling APIPA an option? Is one an onboard and one external maybe you could utilize NBS Global Settings > MAC Address Filtering if they are different manufacturers. With the previous agent you could use customdata.ini to do filtering. You might search around to see if something like this exists for the pectagent.

Icefoot's picture

Brandon,

I'll see if the MAC filtering in NBS Global Settings works since most of the time one is an onboard and the imaging NIC is an addin.  So far, efforts to disable the extra NICs in BIOS so they will not show up in the WinPE client have proven fruitless.  Disabling APIPA is an intersting idea I will have to try.  But I'm not confident it would help since the problem stems from the Windows device enumration order: the first enumerated NIC is the one the PECTAgent seems to want to use and the one with a valid DHCP address is usually the forth or fifth NIC in the system.

Thank you for the suggestions.

Satish_Satav's picture

Hi,

Have you tried same scenario by disabling APIPA NICs? Do you have any updates on this? 

anil_kamlapure's picture

Icefoot,

You can also try by removing NICs or changing thier order

Icefoot's picture

No updates on this yet.  I ended up having to rebuild the lab ITMS servers I am using to troubleshoot this problem due to unrelated problems and am still getting their configuration back to where it was when I asked the question.