Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Pending Delete on User in Symantec DLO Server

Created: 16 Nov 2012 | 3 comments

We are having a rash of users that hang in Pending Delete status on our Symantec DLO server.  They sit in this status forever.  We found the following resolution on Symantec forums, and successfully got this to work once on a user (after many attempts), but cannot get to work again on other cases.  Can anyone help with resolution to this?

osql -E -S%COMPUTERNAME%\bkupexec -d BE_DLO

1> selectUserID from SUser where UserName = <username> <- enter username

2> go

**Should get a record number ID for that user record**

osql -E -S%COMPUTERNAME%\bkupexec -d BE_DLO

1> EXECUTEDelete_User <enter user ID number> <- enter user ID number from above

2> go

When we enter "go" on first command set, we get following error:
Msg 156, Level 15, State 1, Server ROS1ITSBKP001\BKUPEXEC, Line 1
Incorrect syntax near the keyword 'from'.

Cannot figure out a way around this, or how we got this to work the first time.  Please advise.
 

Comments 3 CommentsJump to latest comment

Orionex's picture

Hello,

I advise to check in SQL by using  Microsoft SQL Server Management Studio Express what going on with the database . or to contact our Technical Support in order that they help you .

Best Regards,

eavinash's picture

Once the user status is displayed as 'delete pending' could you restart both the database service and the DLO administrator service. Once the services are restarted, launch the agent. All the users should be deleted.

psj_symhelp's picture

Hi

Make sure the agent is uninstall from client computer then unmap user to profile.
Now delete user from DLO management console and restart DLO services.