Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Perl is not getting while configuring SAVFL reporter

Created: 11 Dec 2012 • Updated: 25 Mar 2013 | 6 comments
This issue has been solved. See solution.

Hi,

This is the first time when I am trying to install the SAVFL on Linux Machines.

I have checked the configurations details specified at the Symantec Website.

Then I got the SAVFL ver 1.0.13. I installed it on the Linux server. But According to requirement SAVFL Client should forward the logs to the SEPM Server.

So I tried to installed the SAVFL reporter also.

But getting error message while doing given below:

error: Failed dependencies:
        perl(HTTP::Request::Common) is needed by savreporter-1.0.13-16.noarch
        perl(LWP::UserAgent) is needed by savreporter-1.0.13-16.noarch.

 

Kindly let me know what is the meaning of this error messag.

 

Thanks & Regards

KK

Comments 6 CommentsJump to latest comment

Ajit Jha's picture

Hi

Try to:

1.Disable the legacy upload option

  1. From the Symantec Endpoint Protection Manager Console page, under "Security Status", click Preferences
  2. Click Logs and Reports
  3. Uncheck the radio button under "Legacy Support", Upload Symantec AntiVirus version 10.x log files
  4. Restart IIS
 
2.Enable the legacy upload option
  1. From the Symantec Endpoint Protection Manager console page, under "Security Status", click Preferences
  2. Click Logs and Reports
  3. Check the radio button under "Legacy Support", Upload Symantec AntiVirus version 10.x log files
  4. Restart IIS 
  5.  

Regard's

Ajit Jha

Technical Consultant

ASC & STS

Mick2009's picture

Hi KK,

I have encountered something similar myself.  There is a Perl module needed so that SAVFL can function.  Here's an article on how to fix the issue in Ubuntu: it will likely be similar in your distro.

Symantec AntiVirus for Linux Reporter Fails to Forward Events, Error "Undefined subroutine.... line 128"
Article:TECH189759   |  Created: 2012-05-25   |  Updated: 2012-05-25   | 
Article URL http://www.symantec.com/docs/TECH189759 
 

Solution

Downloading and installing the libwww-perl module package enabled an affected Ubuntu LinuxMint 13 computer to correctly forward logs to the organization's SEPM.

The readme.txt for SAVFL Reporter mentions another file as well:

 

 4. Make sure that Perl 5.8.0 or later and the related Perl module package (for example, perl-libwww-perl for RedHat/SuSe Linux) are installed on the client.

If this module is missing, SAVFL will not be able to function correctly.
 

 

 

 

 

With thanks and best regards,

Mick

Mick2009's picture

Hi KK,

Just a ping to check if you managed to get this working correctly.  The thread is still marked "needs solution."

With best regards,

 

With thanks and best regards,

Mick

Sagar D. Kanase's picture

Hello Kumar,

Kindly make sure that Perl 5.8.0 or later and the related Perl module package (for example, perl-libwww-perl for RedHat/SuSe Linux).

Regards,

Sagar D. Kanase.
Technical Support Analyst.
 

 

 

Regards,

Sagar D. Kanase.
Technical Support Analyst.

Mick2009's picture

This new article may be of interest to followers of this thread...

SAV for Linux: A (Somewhat) Illustrated Guide Part 4: SAVFL Reporter
https://www-secure.symantec.com/connect/articles/sav-linux-somewhat-illustrated-guide-part-4-savfl-reporter

With thanks and best regards,

Mick

SOLUTION