Video Screencast Help

PERSISTENT DEFERRED-FREE or REDZONED MEMORY READ ERRORS ON AIX AGENT SERVERS DESPITE PATCHING.

Created: 13 Jun 2012 • Updated: 01 Aug 2012 | 12 comments

Hi Guys.

I have having some issues on a few AIX 5.3 and 6.1 agent servers that are running the SCSP Service.

Apparently this patch should have done the job for this : http://www.symantec.com/business/support/index?pag...

We installed, rebooted yet the problem persists. We are still getting DEFERRED-FREE or REDZONED MEMORY READ on the AIX machines. Any idea why is this happening? By right this fix pack should do the job already.

Our agent is 5.2.8.264

Error Messages after Patch installation :

 

No MOD enabled.

Appreciate the help.

Thanks.

 

Comments 12 CommentsJump to latest comment

Chuck Edson's picture

 

This issue has been resolved in SCSP Agent 5.2.8-MP2-HF1 as well as in 5.2.8 MP3

www.symantec.com/docs/TECH180370

You mentioned that you are using build 5.2.8.264, which IS 5.2.8 MP3.

When installing, IPS will be enabled by default -- if you disable it during the install, does that help at all?

Have you tried a full uninstall and reinstall?  Are you 100% certain that you are using the correct build?

I do know of cases where the .264 build fixed this issue.

If a post helps you, please mark it as the solution to your issue.

AIDIL HARITH's picture

Hi Chuck,

Yes, we are very sure that the Agent installed is correct. The link was given by Symantec support however the problem still persists.

What happened was, we get the message "IPS driver not loaded" at first, then the server went down, right after we boot up, we received the "Deferred free or redzoned memory read".

Any idea as to why this is happening? Has the .264 build failed to fix this issue before?

 

Ali_Tazzemtark's picture

I just encountered the same problem as this when installing SCSP on AIX 5.3 where the deferred free memory redzone occurs but the .264 build solved the issue.

The .264 should get rid of your issue.

1) Can you double confirm that you have installed the correct Patch?

2) Try uninstalling the patch, uninstall the agent and reinstall everything back from scratch, And make sure IPS is disabled before patching.

The patch release should rid your problem.

AIDIL HARITH's picture

Hi Ali,

Can you please reconfirm if the problem goes away after the patch? I believe if the server becomes heavily utilized, you will receive that memory red zone error again.

 

Thanks

Ali_Tazzemtark's picture

Hi Aidil,

You are absolutely correct. The patch did not work once the server reaches a certain threshold. I have logged a case with Symantec on this. I think we have established a common issue on SCSP running on AIX 5.3 and 6.1 where the Patch don't work. I am yet to install Patch MP4.

Chuck Edson's picture

Please let us know if you were able to resolve this issue.

 

Thanks.

If a post helps you, please mark it as the solution to your issue.

AIDIL HARITH's picture

Hi Chuck,

Problem still persists. Seems like we might be the first having problem of this kind on SCSP. Here is word from our Symantec support guy (Case 417-608-037) :

"I just received a status update from our engineering team after performing an analysis of the data provided.

The root cause is yet to be determined, as such development would not proceed with the 2nd webex schedule.

They provided a workaround currently available for the “Redzone Error” would be to disable IPS driver for now until root cause is determined.

Is the customer using IPS in their environment? If not, then disabling IPS should not be an issue.

 

Disable Intrusion Prevention [IPS] for Solaris|AIX|Linux|Windows
http://www.symantec.com/docs/HOWTO66119

Regards,
Sunny Yu
Technical Support Engineer
Symantec Corporation

 

Chuck Edson's picture

Thanks for the update.  I will keep an eye on the case.

 

If a post helps you, please mark it as the solution to your issue.

AIDIL HARITH's picture

Here is what Symantec Support has to say.

Development has completed their analysis of the syslog messages and the problem appears to result from some low level kernel interface errors.  One thing in common seen on the two problematic machines (sapweb_dr and ermsrstg03),  is that they are both running AIX 6.1 TL1 (nearly 5 years old).   The supported TL with 5.2.8 MP3 and MP4 are AIX 6.1 TL5 & TL6.   The issue is very likely caused by the old OS version.

The recommendation from development is to move to a supported TL of AIX 6.1 and if the issue persists, we will be better suited to address it there.

Please let me know if you have any questions with the above. Thanks.

Regards,

Barry Meehan

Senior Technical Support Engineer

Apparently Support has mentioned that the supported TL with 5.2.8 MP3 and MP4 are TL5 and Tl6 which we have highlighted to our customer. However the Customer has got back to us mentioning that 1 of the server that is causing this error is running AIX 5.3 TL12. The customer now is skeptical whether SCSP can really work in their environment. If their server is running a higher TL, must it be degraded to TL5 or TL6? It's very strange.

Next I like to point out is that, that the SCSP 5.2 RU8 MP3 patch link below did not specify anything regarding TL versions of the AIX. It simply states in general AIX 5.3 and 6.1. This is very misleading as that gives the impression that all TLs are supported. I believe Symantec should revise this document and specify clearly that the patch only supports AIX 5.3 and 6.1 TL 5 and TL6.

http://www.symantec.com/business/support/index?pag...

 
Beyond that, there is no update to this problem.

 

AIDIL HARITH's picture

Hi Guys,

After all those rants, the deferred redzoned memory is now solved. The AIX TL version was the issue. This should be highlighted in this link here : www.symantec.com/business/support/index?page=conte...

 

There is no TL versions being mentioned in the link. This is very misleading as this gives the impression that SCSP is supported in all TL versions for AIX 5.3 and 6.1 which certainly isn't the case.