Video Screencast Help

PGP 10.0.2 Can't find my Master Key!

Created: 04 Aug 2011 | 7 comments

Just upgraded to version 10.0.2 and when I try to send an encrypted file PGP says:

Could not find one or more of your Master Keys.  The operation is unable to continue.  Please go to the Master Keys panel of PGP Options

So in PGP Options, under Master Keys I have ONE Master keys, and two other keys (all of which have different creation dates and information), which PGP can't see either of them.

I can't even delete these keys and re-create them.  If I try to delete the old keys it keeps asking me for my password, but I set it up so it doesn't need a password only my smartcard properties password.  I don't seem to have the necessary "krb" file (have searched my entire hard drive and network drive to no avail).

My company has "smart card" readers for our badges and I have no access to the security side of the badge I have to use.

I am about ready to request a refund as this new version is totally useless to me.

Any help is greatly appreciated!

Comments 7 CommentsJump to latest comment

Tom Mc's picture

My immediate thought is that your keyrings are not in the default My Documents location.  PGP 10.0 through 10.0.2 have a bug that requires keyrings to be in the default location.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Tom Mc's picture

The default keyrings and location:

C:\Users\<username>\Documents\PGP

pubring.pkr & secring.skr
 

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

Tom Mc's picture

Does this problem remain?

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

fiskede's picture

Uninstalled and downloaded a second version (10.1.2) and reinstalled.  PGP created yet ANOTHER Master Key using my Smart Card (that's three that I have now!).  In order to decrypt or encrypt I have to DISABLE my Master Keys.  Then everything is perfect.  I can receive files and decrypt, I can encrypt files and send and receipient can decrypt.

Do not understand why, but if it works, I'm not going to complain.

Tom Mc's picture

I wonder if we may not have been communicating well.  That error message usually refers to a key listed in PGP Options as a Master Key, but which is not on your keyring.  It needs to be removed from the Master Key list in PGP Options - not from the keyring.  I think you may have been wanting to remove it from your keyring?

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

jquadri's picture

Make sure your key ring contains all your key.

Goto into options, then click on the "master keys" tab click Add to add all the keys in your ring

Voula! thats it

Tom Mc's picture

For most people, doing this pretty much defeats the purpose of using encryption.  The Master Key list in PGP Options is a list of keys that anything you encrypt will also be encrypted to.  So, if you do this, even any file you encrypt on your computer will also be encrypted to everybody whose key you have in your keyring.  I think the most common use of the Master Key list is just to place your own plubic key there, which will let you always be able to decrypt anything you encrypt.

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &