Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP 10.2 upgrade - fast user switching/interactive log on change?

Created: 28 Aug 2012 • Updated: 30 Aug 2012 | 4 comments
This issue has been solved. See solution.

Recently we upgraded from 10.1.2 to v 10.2 and we are noticing some odd behavior immediately following.

The Single sign on from the PGP logon into the windows desktop continued to work fine. However when the computer is locked (or wakes from sleep/hibernate) the PGP encrypted laptop no longer defaults to the interactive logon (where the loged in user name is displayed along with the password field). Instead the fast user switching screen is displayed by default and you have to select the user you want to log in with (even if you are already loged in), prior to getting the interactive logon screen to enter your password.

Very odd. I would have thought that this would only be modified with a GPO, so either there is a coincidence and there was a change made to a GPO (highly unlikely but not out of the world of possibilities I suppose), or the recent PGP upgrade had something to do with it.

Any thoughts, comments or suggestions would be appreciated!

Thank you! 

EDIT - I wanted to add that we found more evidence that its related to the upgrade. We found a user who had ignored the upgrade every time it prompted (go figure), however the behavior of his machine is how we want it (interactive after a lock). We are going to go upgrade him and confirm that this changes to the fast user switching afterwards.

Comments 4 CommentsJump to latest comment

James Hawk's picture

What happens if you try a fresh install of WDE 10.2, or more specifically a fresh enrollment with SSO? The upgrade could be breaking SSO somehow.

PGP_Ben's picture

Hi, I just wanted to comment that this is actually a feature with PGP Desktop 10.2 and newer. please see this KB article for more information.

 

http://www.symantec.com/docs/TECH192203

 

This is due to changes in our SSO code to use the Credential Provider which is part of Windows 7 now.  Other single-sign on providers will have similar types of behavior when switching to this method.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

SOLUTION
boldt's picture

Ben, thank you! that explains that. Looks like it cannot be changed back, so ctrl+alt+del+spacebar is going to be the ticket now that we are running 10.2.1 (4461).

Thanks for replying, I can sleep better now (and stop trying to figure out where the GPO confilict was coming from that was causing this odd behavior). 

PGP_Ben's picture

Glad to hear that we could answer your question. Please click the "mark as solution" option on my comment if you feel it resolves your technical issue. That way the thread gets marked as resolved and I get credit for the solution :)

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.