Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Blocking Oulook Mail

Created: 11 Mar 2013 | 8 comments

Hello,

One of our users is experiencing an issue with PGP blocking messages at least once a day.  The user has  PGP 10.2.1, running Win7x64, with Outlook 2007. 

Here is an example of a bounce back....the error code is always the same:

     From: System Administrator
Sent: March-11-13 9:29 AM
Subject: PGP blocked: RE: *************

Your message did not reach some or all of the intended recipients.

            Subject:        RE: *************

            Sent:           11/03/2013 10:43:00 AM

The client operation failed. Error code: [0x80070057].

The original message is embedded in this non-delivery report. Click Send Again to see the original text and have the opportunity to re-send the message. If the problem persists and you still receive another non-delivery report, please contact your administrator for details.

And here is an example of the log file error:

09:30:32 Email  Error MAPI Proxy: OutMessage.cpp : Line 1309 : Echo::oc::mapi::OMessage::SubmitMessage
09:30:32 Email  Error  IMessage::SubmitMessage failed
09:30:32 Email  Error  IMessage::SubmitMessage failed
09:30:32 Email  Error  Received MAPI Specific error code 80070057

This only happens to one user (we have roughly 30 using PGP).  I have decrypted, uninstalled and reinstalled with the same results.  Any help with this would be greatly appreciated.

Thanks!

Comments 8 CommentsJump to latest comment

EdinSoMC's picture

Hi,

If you try to resend the blocked mail can you see what mail policy is processed?

You should be able to read that as default,  down in the right corner when sending e-mails (Symantecs notifier for outgoing mails ). When you point with your mouse pointer you should be able to read exactly which mail policy is processed.

This could help us to identify why that mail is blocked. 

Does your user want to send mail encrypted or unecrypted?

Chears

Edin

doberman76's picture

Hello,

Actually, we do not have the option to resend the email.  Once the PGP bounce-back happens, the original message is nowhere to be found.  Not in drafts, sent, deleted, so the user has no choice but to write the email again.  This is quite frustrating, as you can imagine.

Also, the user is sending non-encrypted emails.

Thanks.

EdinSoMC's picture

You should be able to find a mail from "System Administrator" when mail blocked.

If you open that mail can you see "Send Again" buttom. When you click on it your orginal mail will be reopened.

Edin

PGP_Ben's picture

Looking at Microsoft's website for that MAPI error code:

http://support.microsoft.com/kb/238119

It says:

MAPI_E_INVALID_PARAMETER 80070057

-2147024809

I would suggest trying to disable cached exchange mode (if possible) to see if that helps.  I also managed to find this known issue related to using Exchange server 2007 and free/busy information with calendar items related to that same MAPI error code. Not sure if that is related or not, but worth checking into possibly.

http://support.microsoft.com/kb/955443

Here is another article posted by us

http://www.symantec.com/docs/TECH149958

With a similar error message. Indicating that it's an Exchange Server update which addresses this issue.

I would check that your Exchange Server has all the most recent updates and then if that does'nt work put PGP Desktop in debug mode and gather more verbose logging so we can gather more information.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

PGP_Ben's picture

One last thing that I noticed, there is also a known issue related to mailing list size that has what appears to be the same error message documented here:

http://www.symantec.com/docs/TECH149494

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

PGP_Ben's picture

I suspect if it's not the known issue I just commented on here with. It's having to do with a delay in processing the email messages for some reason (mailing list size, key lookup delay, etc) based on the input I found here on MSDN's website:

http://msdn.microsoft.com/en-us/library/office/cc8...

Regarding the

IMessage::SubmitMessage

method

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

stevenuk's picture

I found if you go to PGP Desktop and Tools and untick E-mail Proxy, we stopped getting this issue when it happened to us.

PGP_Ben's picture

You could also just disable the MAPI function in the PGP installer using MSI switches. See here for more info:

http://www.symantec.com/docs/HOWTO84112

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.