Video Screencast Help

PGP can't Proxy Incoming Connection

Created: 01 Aug 2014 | 5 comments
Arvin.MISPL's picture

I've problem on PGP Desktop Email 10.3.2 after upgrading from 10.3.1 where Outlook 2010 SP2 32 bit stops downloading email with error 0x800CCC0F. I've no problem receiving mail. Telnet to mail server outgoing port gives me PGP message but not to the incoming port, it will be blank. I've tried 10.3.2 MP2, and also reinstalled 10.3.1 but it still fails with same problem. I've also refreshed PGP by deleting the PGPprefs,policy and randomseed files. Tried to disable TLS too. Outlook able to receive mail after unistalling PGP. Below is the error log from PGP.

07:39:35 Attempting to connect to server at 79.170.44.53
VE 07:39:35 Attempting tunneled TLS connection on port 995
VE 07:39:35 Connect attempt on port 995 failed: unknown error (-11980)
VE 07:39:35 Connect attempt on port 110 failed: unknown error (-11980)
EE 07:39:35 Cannot connect server socket to 79.170.44.53
VE 07:39:36

Operating Systems:

Comments 5 CommentsJump to latest comment

Anthony_Betow's picture

Hello,

Did you disable the SSL in Outlook and set the POP to 110, SMTP to 25?

This would be done if your setup is a stand-alone install so PGP can proxy mail.

When you do the Send and Recieve is there a POP3 error?

Thanks

Anthony

Arvin.MISPL's picture

Yes, I'm aware of that. The SSL is disabled on Outlook. POP is 110 and SMTP is 25. The Outlook has 0x800CCC0F error. PGP log shows "Connect attempt on port 110 failed: unknown error (-11980)". Outgoing no problem, only incoming on 110.

Anthony_Betow's picture

Hello Arvin,

The problem you may have is the PGPLsp protocol problem which is preventing you to receive incoming mail.  This maybe a new Bug but not yet confirmed.  I've seen this in many cases.

The PGPLsp protocol will have to be removed.

First, open Windows command Line and create a text file of the Winsock Catalog

1. Type: netsh winsock show catalog > cat.txt and press Enter.  You'll be returned to the command prompt.

2. Type notepad cat.txt and Notepad will open with the Winsock catalog of what is in the network stack for Windows.  Check the catalog to see if PGPLsp is the only Layered Service provider.  If PGP is the only LSP Protocol then to remove from the Winsock, at the prompt.

3. Type Netsh, Enter

4. Winsock, Enter

5 Reset, Enter and Windows will prompt you to reboot and it will be removed from the Winsock.

6. Test your E-mail

This should only be done if you're not using the E-mail Encryption feature for PGP.

Thanks

Anthony

Arvin.MISPL's picture

Hi Anthony,

I uninstalled PGP just to confirm it is the cause. PGP email encryption feature is required. After removing the PGPlsp, do you mean that it will be fixed or email will not be encrypted anymore?

Anthony_Betow's picture

Hi Arvin,

If you're using an e-mail account with the Mapi protocol then you should be fine.  Outlook uses this protocol by default. Removing the PGPLSP will not affect proxing with Mapi.

The PGPLsp protocol is used to proxy e-mail accounts using the POP protocol.  Remove the PGPLsp from the Winsock stack and test your e-mail.  If you have an account that uses the POP protocol then check to see if you have an option to change the protocol.  (Example Google mail)

If you use an e-mail account that only uses POP protocol and you need email encryption then use PGP 10.3.0 MP3 for e-mail encryption until this can be resolved.  PGP version 10.3.0 MP3 doesn't support Windows 8 if you use this platform.

Thanks

Anthony