Video Screencast Help

PGP - Catastrophic Data Loss

Created: 02 Oct 2012 | 4 comments

I've been using PGP Desktop to secure my confidential files for over six years.  I use a virtual disk that I mount daily using a passphrase to store these files.  I've moved the drive from three different computers and never experienced an interruption in service.  I backup m virtual disk and many other files (including my keyring files) weekly.

Yesterday, when I tried to mount the virtual drive, PGP returned an error that my passphrase was incorrect, but that "there were one or more users with public keys that could not be checked, possibly because these private keys are not on the default keyring...."  I've tried replacing my keyring files with those from my backup, but nothing seems to work.

I called in to Tech Support, but they refused to help me.  Can anyone offer any suggestions for gaining access to my years of encrypted files?

Comments 4 CommentsJump to latest comment

Alex_CST's picture

Hi,

What version of PGP Desktop are you currently using?  What operating system are you on now?

Please mark posts as solutions if they solve your problem!

http://www.cstl.com

PfDoug's picture

Thanks for your quick reply.

I'm running Windows 7 Enterprise 64-bit.  I was using PGP Desktop version 9.12.0 when the problem occured yesterday morning.  Since that version is EOL, I have upgraded to 10.0.3, but it has not made a difference.

PfDoug's picture

I have not been able to identify the root cause of this problem.  It appears that my keyring files were corrupted during a reboot.  My original backup files did not take affect because I didn't restart the services.  The PGP software seems to have updated the files before my weekly backup process archived the bad ones, overwriting my good files.  I was able to go to my monthly and quarterly backup media and recover my keyring, and now I have access to my files.

Alex_CST's picture

Yet another testament for keeping good backups :)

Glad you got it sorted!

Please mark posts as solutions if they solve your problem!

http://www.cstl.com