Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Command line 10.2 error libPGPsdk.so.4: cannot open shared object file: No such file or directory

Created: 30 Nov 2011 • Updated: 06 Dec 2011 | 8 comments
This issue has been solved. See solution.

Hi

When executing the Licence command I am getting the below error

/usr/bin/pgp --license-authorize --license-name"Myname" --license-organization "My Org" --license-number "XYZ provided by sales team" -license-email "mymail@mysite.com"

Following error is received:
/usr/bin/pgp: error while loading shared libraries: libPGPsdk.so.4: cannot open shared object file: No such file or directory

do I have to use my old information as was present for licensing or can I give new name and other new information with this licensing ?
I couldn't get this library error any where in the forum, therefore posting it.

My OS: RHEL 6 64bit

PGP 10.2 64bit

Thank you for your quick response in advance.

Comments 8 CommentsJump to latest comment

dfinkelstein's picture

By default PGP Command Line is installed in /opt/pgp, and the corresponding libraries should be there (/opt/pgp/lib).  Double-check that you have the right path to your installation and that all the files installed correctly.

--------

David Finkelstein

Symantec R&D

Julian_M's picture

You can either reinstall PGP or look for library file in the tar installation package and copy to the right folder.

When you consider the issue resolved, please click Mark As Solution on the post that best provided the solution.
 

GiridharV's picture

Thank you for the information

when executed the command: rpm -qlp PGPCommandLine-10.2.0.283--283.linux.x86_64.rpm
/opt/pgp
/opt/pgp/bin
/opt/pgp/bin/pgp
/opt/pgp/lib64
/opt/pgp/lib64/libPGPln.so
/opt/pgp/lib64/libPGPln.so.4
/opt/pgp/lib64/libPGPln.so.4.2.0
/opt/pgp/lib64/libPGPsdk.so
/opt/pgp/lib64/libPGPsdk.so.4
....

now that I have the library folder where it is installed.  Created a file as:PGPCommandLine-10.2.0.283.conf in the /etc/ld.so.conf.d folder and provided the library path /opt/pgp/lib64 as the path to look for.

Ran the 'ldconfig' command.

Will confirm back once my PGP administrator is able to run or configure the license successfully.

dfinkelstein's picture

In your original report, you state you are running /usr/bin/pgp.  Make sure you are running the correct binary, installed in /opt/pgp/bin/pgp.

--------

David Finkelstein

Symantec R&D

GiridharV's picture

Hi

When the rpm is installed it is a bit confusing to find the rpm getting installed under /usr/bin/lib64 when no --prefix is provided

I have erased the installation and reinstalled it with rpm --prefix=/opt/pgp -ivh PGPCommandLine-10.2.0.283--283.linux.x86_64.rpm  this has installed correctly as documented in the pdf for RHEL

But when we try to cache the libraries using the ldconfig we get the below error:

# ldconfig
ldconfig: /usr/bin/lib64/libPGPsdk.so.4.sig is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/bin/lib64/libPGPsdk.so.sig is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/bin/lib64/libPGPsdk.so.4.2.0.sig is not an ELF file - it has the wrong magic bytes at the start.

Can you please tell what could be the error

But with all the above, we did get the licence error resolved. System is now licenced

Thank you

dfinkelstein's picture

Your installation into /opt/pgp should have put all the libraries into /opt/pgp/lib.  I'm not sure what those other files are or where they came from but they might be related to the intial problematic installation you had.  I would suggest just removing any traces of the files in /usr/bin/lib64.

PGP Command Line itself knows where to look to find its libraries.

--------

David Finkelstein

Symantec R&D

GiridharV's picture

Hi There

Suspect some problem with the 10.2 rpm downloaded.  When the rpm package is installed directly with no prefix defined (rpm -ivh rpmname).  It did not get installed as listed with rpm -qlp {rpmname}. rpm package got installed in /usr/bin and the libraries for the same got installed in /usr/bin/lib64 .

Had it erased using the command rpm -e {rpmname} and reinstalled with prefix in place as rpm --prefix=/opt/pgp -ivh {rpmname}  installation happend as listed in rpm -qlp {rpmname}.

Created a PGPCommandline.conf with path added as /opt/pgp/lib64 in /etc/ld.so.conf.d folder and ran the ldconfig command.

It resulted in few config errors as docmented above.  But the commands and other elements worked normal.

Able to decrypt files normally.

There is one question still remaining.  When executing the PGP license command, administrator executed the command with new names for authority.

As we didn't want to lose our existing home area where pgp scripts run. After the upgrade, all the home and its sub folders have been put back as is.  When pgp --version --verbose command is given, for the user(where scripts execute), it lists the old member information or license information.

Which probably symantec can check.

Overall everything went smooth. Installation was successful (Our internal Dev configuration is complete)

Thanks to the team who posted their reponses.

SOLUTION
dfinkelstein's picture

The license information is stored in the PGPPrefs.xml file, which has a per-user location.  Each of your other users is likely still using their "old" PGPPrefs.xml file, with the old license information.

We will improve this behavior in a future release.  In the meantime, you can use the "--home-dir" option (or set the PGP_HOME_DIR environment variable) so everyone uses a shared home directory with the same preference file.  People can still have their own keyrings by using the "--public-keyring" and "--private-keyring" options.

--------

David Finkelstein

Symantec R&D