Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

PGP Command line 10.3.2 install fails - unknown software exception

Created: 07 May 2014 • Updated: 13 May 2014 | 5 comments
This issue has been solved. See solution.

I downloaded the trial version of PGP command line, but when attempting to install either the 32-bit or 64-bit version, I get this error:

Application popup: Windows - Application Error : The exception unknown software exception (0xc0000417) occurred in the application at location 0x6abe42eb.

I can click OK, then the install appears to continue, but gets hung at some point and I have to kill it.

I am running Windows 7 64-bit with SP1.

I have admin rights on my machine.

I have also re-downloaded the software, in case it was corrupt, but that didn't help.

Any ideas?

Operating Systems:

Comments 5 CommentsJump to latest comment

Mike Ankeny's picture

Are you disabling any security or antivirus software before installation?

Do you have any other encryption products installed, or was there previously any sort of encryption software on the system?

peter.bollwerk's picture

Our anti-virus cannot be disabled. It is locked down very tight, as we have to comply with PCI regulations.

No other encryption products are installed.

For what it's worth, I decided to just leave it alone while "hung" and it actually finished installing eventually.

Weird.

BTW, I've installed many, many things on my machine and never had to disable anti-virus. I find that "go-to" response unhelpful.

SOLUTION
Mike Ankeny's picture

There is a reason it is a "go-to" response, as many antivirus programs can cause a failed installation, particularly when things are "locked down very tight" as you put it.  McAfee in particular has caused some issues with installation and encryption.  I apologize if you felt that it was a "have you tried turning it off and back on again" type of response, but it is always better to have asked for confirmation than to find out it was something simple later.

I'm glad you got it working.  How long did it seem to 'hang' before it finished the install?  It is definitely odd behavior, and I would be interested in looking into it further if you are willing to do so.

peter.bollwerk's picture

Unfortunately, I'm far too busy to spend any more time on this than I have to.

It eventually completed after about 20 minutes.

We use McAfee VirusScan Enterprise version 8.8.0.777. Perhaps you can replicate the problem in a lab environment?

I can appreciate that you've had issues with anti-virus programs, but from my 20+ years in IT, I've not yet seen any definitive evidence of anti-virus software causing a failed install. But perhaps I've just been lucky.

I also find it very common for companies to be quick to point the finger somewhere else before doing any investigation, so I apologize if I came across a bit too harsh.

Mike Ankeny's picture

Not a problem at all, and thanks for the additional information.  I'll see if I can get ahold of the software and try some lab testing.

Most often, I see antivirus interfere with the whole disk encryption products, not the Command Line product specifically.  My assumption is that any good antivirus should have a problem when something attempts to modify the boot sector, and if the program isn't in a list of acceptable programs, it can cause problems with that installation, sometimes simply stripping out the pieces that modify the boot sector.

I understand that you are busy, so I'll do what I can to take it from here, and if I come up with anything I'll forward it on to engineering.  Have a great day!